summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2023-12-21 13:22:11 -0500
committerRichard Freeman <rich0@gentoo.org>2023-12-21 13:22:11 -0500
commit5e2f8254423cb6a8e67d4152feb32a529a474b54 (patch)
treee06a1e66166ce01cdb8c02ddcbdb52e91522b2fe
parentnet-misc/s3cmd: add 2.4.0 (diff)
downloadgentoo-5e2f8254423cb6a8e67d4152feb32a529a474b54.tar.gz
gentoo-5e2f8254423cb6a8e67d4152feb32a529a474b54.tar.bz2
gentoo-5e2f8254423cb6a8e67d4152feb32a529a474b54.zip
sys-process/systemd-cron: add 2.3.0
Signed-off-by: Richard Freeman <rich0@gentoo.org>
-rw-r--r--sys-process/systemd-cron/Manifest1
-rw-r--r--sys-process/systemd-cron/systemd-cron-2.3.0.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/sys-process/systemd-cron/Manifest b/sys-process/systemd-cron/Manifest
index 34c9c9fa5c12..a7301a128266 100644
--- a/sys-process/systemd-cron/Manifest
+++ b/sys-process/systemd-cron/Manifest
@@ -3,3 +3,4 @@ DIST systemd-cron-1.15.20.tar.gz 33384 BLAKE2B 1e048009d19eb9e40a96ab7dee5099753
DIST systemd-cron-1.16.7.tar.gz 37887 BLAKE2B a900058cef1cd02ac464d3ecdd43ce2f264bdba386f349ef82f0a915104302b1e88d94331d5fbaabe2c54f526900f3e1ac65ea6bdc2f27a6464e6d7514561a19 SHA512 d65d641fd449cdc0e91db3ae6ebe464bc4e24027c501b30a8ab17e7cc40de290cc6141bfb7880a724d97248861587e6f5fea113a6aa6e468d971aff3a13b056f
DIST systemd-cron-2.1.3.tar.gz 53796 BLAKE2B 438229f84e2ad815bf658d93dcd3afd49d382f2c9499b6273d8e94a1d1ecda28016327a2e21882c0ed27e7d9e5603d804d3b697f04bbd130cc11ee9bfa341c80 SHA512 e8fccfdbd52d8e24b77e93db8f5afe25007e43c5d67e50aa7eda70f8a1197ebae8d080a2e179e8cf694188ba4c0bd2795740ef021f6991ae80ece4408e3500f9
DIST systemd-cron-2.2.0.tar.gz 55825 BLAKE2B ca4b02fdea5084439aa56b3f04603000d811f21922c11cd26a22ea6387e4b54575587ff4e1eb7fc7a3260d2f656ea0eb91365942c135982f4bd26aead1a080f1 SHA512 f26c7d7e2da7eb5cd5558f352aff852585bfefd961de6ecc2409a4a53b63f82662a89bdbf71f739ea8e44ef9e3e1fdec15cdc63ce1e90c289fb0e636ff679ca0
+DIST systemd-cron-2.3.0.tar.gz 56873 BLAKE2B 3efe8adc1b735ed5eb91c64d0936edceec50ff476d42ba5c1e9941c196a7bc8c777b0c293c8ed71894dae31c5b721a45a2876cab0143298e1b1ab3e82fcb7ceb SHA512 abb7c34d6901160395d64cfc4e5124887909b963bcfee027f64642b25bb138b3f085eb45595197a380faf39b7f5980e32c50d083be6307d7c985a55057962565
diff --git a/sys-process/systemd-cron/systemd-cron-2.3.0.ebuild b/sys-process/systemd-cron/systemd-cron-2.3.0.ebuild
new file mode 100644
index 000000000000..752240ab8359
--- /dev/null
+++ b/sys-process/systemd-cron/systemd-cron-2.3.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit systemd toolchain-funcs
+
+DESCRIPTION="systemd units to create timers for cron directories and crontab"
+HOMEPAGE="https://github.com/systemd-cron/systemd-cron/"
+SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${PV}.tar.gz -> systemd-cron-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="cron-boot etc-crontab-systemd minutely +runparts setgid test yearly"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+
+RDEPEND=">=sys-apps/systemd-253
+ dev-libs/openssl
+ runparts? ( sys-apps/debianutils )
+ !sys-process/cronie[anacron]
+ !etc-crontab-systemd? ( !sys-process/dcron )
+ sys-process/cronbase
+ acct-user/_cron-failure
+ acct-group/_cron-failure"
+
+DEPEND="sys-process/cronbase
+ test? ( sys-apps/man-db || ( dev-util/shellcheck dev-util/shellcheck-bin ) )"
+
+pkg_pretend() {
+ if use runparts && ! [ -x /usr/bin/run-parts ] ; then
+ eerror "Please complete the migration to merged-usr."
+ eerror "https://wiki.gentoo.org/wiki/Merge-usr"
+ die "systemd-cron no longer supports split-usr"
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e 's/^crontab/crontab-systemd/' \
+ -e 's/^CRONTAB/CRONTAB-SYSTEMD/' \
+ -- "${S}/src/man/crontab."{1,5}".in" || die
+
+ if use etc-crontab-systemd
+ then sed -i \
+ -e "s!/etc/crontab!/etc/crontab-systemd!" \
+ -- "${S}/src/man/crontab."{1,5}".in" \
+ "${S}/src/bin/systemd-crontab-generator.cpp" \
+ "${S}/test/test-generator" || die
+ fi
+
+ eapply_user
+}
+
+my_use_enable() {
+ if use ${1}; then
+ echo --enable-${2:-${1}}=yes
+ else
+ echo --enable-${2:-${1}}=no
+ fi
+}
+
+src_configure() {
+ tc-export PKG_CONFIG CXX CC
+
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --mandir="${EPREFIX}/usr/share/man" \
+ --unitdir="$(systemd_get_systemunitdir)" \
+ --generatordir="$(systemd_get_systemgeneratordir)" \
+ $(my_use_enable cron-boot boot) \
+ $(my_use_enable minutely) \
+ $(my_use_enable runparts) \
+ $(my_use_enable yearly) \
+ $(my_use_enable yearly quarterly) \
+ $(my_use_enable yearly semi_annually) || die
+
+ export CRONTAB=crontab-systemd
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/lib/sysusers.d/systemd-cron.conf
+}
+
+src_test() {
+ emake test-nounshare
+}
+
+pkg_postinst() {
+ elog "This package now supports USE=runparts which is enabled by default."
+ elog "This enables the traditional run-parts behavior."
+ elog "If you disable this flag you will get the new behavior of having"
+ elog "multiple jobs for each cron.* entry run in parallel with"
+ elog "separate services/logs/etc."
+}