summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-02 09:11:44 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-02 09:20:58 +0200
commit63ac3c270a090dffe417a75f5f172112db4fb3a2 (patch)
treee99d11de2b1d2a15cf5ccbda4b44add07ff65133
parentdev-python/pytest-django: New package, ebuild written by me (diff)
downloadgentoo-63ac3c270a090dffe417a75f5f172112db4fb3a2.tar.gz
gentoo-63ac3c270a090dffe417a75f5f172112db4fb3a2.tar.bz2
gentoo-63ac3c270a090dffe417a75f5f172112db4fb3a2.zip
dev-python/pytest-pythonpath: New package, ebuild written by me
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/pytest-pythonpath/Manifest1
-rw-r--r--dev-python/pytest-pythonpath/metadata.xml9
-rw-r--r--dev-python/pytest-pythonpath/pytest-pythonpath-0.7.ebuild22
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-pythonpath/Manifest b/dev-python/pytest-pythonpath/Manifest
new file mode 100644
index 000000000000..51a4ad7530d3
--- /dev/null
+++ b/dev-python/pytest-pythonpath/Manifest
@@ -0,0 +1 @@
+DIST pytest-pythonpath-0.7.tar.gz 1704 SHA256 036bc2b62b5d3a991e45c389748ccfb61e88eb5b14b27cab4b5c1fbcd4ffd191 SHA512 cb20ace8eb0e55d988d3b8b5836907ffbb257adbdb416a4feac8b176b97280d94acce99b98bc7b7e62dc2f7e9531f9ff147b7ce2ab2254edc2187123fb27446b WHIRLPOOL a2f0ca5f8968e788f06d9bce6559da8c2c318a5d38465fa3af49d6305bf0d4181a6ce6ffbc66389831e83b6c6e00e2bba363b785f519c99ead7077f91d090069
diff --git a/dev-python/pytest-pythonpath/metadata.xml b/dev-python/pytest-pythonpath/metadata.xml
new file mode 100644
index 000000000000..cdf82d15f553
--- /dev/null
+++ b/dev-python/pytest-pythonpath/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pytest-pythonpath/pytest-pythonpath-0.7.ebuild b/dev-python/pytest-pythonpath/pytest-pythonpath-0.7.ebuild
new file mode 100644
index 000000000000..53061425518e
--- /dev/null
+++ b/dev-python/pytest-pythonpath/pytest-pythonpath-0.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for adding to the PYTHONPATH from command line or configs"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-pythonpath https://github.com/bigsassy/pytest-pythonpath"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"