summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2025-01-24 15:25:32 -0800
committerZac Medico <zmedico@gentoo.org>2025-01-24 15:26:13 -0800
commit6b14d998992c13ff481fff05aefad3d1c930be9f (patch)
treeef23e515cebe6482349ec0a2947852c6dd263a43
parentnet-libs/nodejs: drop 18.20.4, 18.20.5 (diff)
downloadgentoo-6b14d998992c13ff481fff05aefad3d1c930be9f.tar.gz
gentoo-6b14d998992c13ff481fff05aefad3d1c930be9f.tar.bz2
gentoo-6b14d998992c13ff481fff05aefad3d1c930be9f.zip
dev-db/etcd: add 3.5.18
Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--dev-db/etcd/Manifest2
-rw-r--r--dev-db/etcd/etcd-3.5.18.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-db/etcd/Manifest b/dev-db/etcd/Manifest
index 5df8a2221ae9..2a229aba126b 100644
--- a/dev-db/etcd/Manifest
+++ b/dev-db/etcd/Manifest
@@ -6,3 +6,5 @@ DIST etcd-3.5.15-deps.tar.xz 5885840 BLAKE2B 378d8136da0ca3486433ee2d55f2d65e569
DIST etcd-3.5.15.tar.gz 4113649 BLAKE2B b65ae93875cefffc09ff0c61eda485abd3a32691b0b8bb2d957c109c2e43cb36d26a51c4d81b7dadb9e96452dfdbfb626dfc5a151678154339d7e08324c15efb SHA512 1b22376fcda4c182ea0388b97f3b5a6a2fd62f753c2f4c13d06c3b53e9b7fb8efb2b20177f1724a5775f5ecc13bfcaabe6b308d4ee205dea86f7311fbe3a2900
DIST etcd-3.5.17-deps.tar.xz 5651912 BLAKE2B bd5293b0e125082736b785534eb7fb4a7f32e4427419f1b298a5dcb9d07ced41b1435e9cd8db2a1c05f81318416436d2ad3f4a8f2815801e6973039a8a5ed716 SHA512 70b50559e2c3be40fadc2462087db8e773858c948cc5e7d9441845a70c6f6ded022b12a4f24b2959748825fbec0772e73694f907b3aec1b3e713ca9beefc1944
DIST etcd-3.5.17.tar.gz 4124391 BLAKE2B 9602c31369cfd5604ac7283307b712ffb5468e6264731a78d6a598752d533b18906d22d44aafe70027da217b85220376972b5305fad562f0a80704f30637381c SHA512 6d1cae12f7352c7075eeec2273e70870ac89d7e92c313e5cf2c2316b0c93813047f7412756712169faf48657efefec98062ba03853fcd11c8b08d4d587752291
+DIST etcd-3.5.18-deps.tar.xz 46453448 BLAKE2B 677370cb6d9064f8474adbfc5030b46f3367198cb8defc9242be00423c570f8c9bc5358d6dbe9d8cfee8e7797a2f8c93e7b4c8cbee4702c59287005cd7885fef SHA512 f1ed36d49f199fff4b0ee920870c3ac66dee0dcb5e92fa24a3861d841bdcfa99b210b292138116de9aafeec424c7663111f9bb0ad87910e1314031eb501f4aeb
+DIST etcd-3.5.18.tar.gz 4128059 BLAKE2B 32f867170bf1195d019dcf562bff9104db00f6ccff6b91bf12a4c95a63a5d92dda6984437bed819240be7bd8d4e2b507904251f636e945c5847ef93e72f1dd63 SHA512 0d72c40d575997d70d9d4964e7ff4be75c77e13a40ea08fcc020fddc64dc420338f1853d5a51a2dbe3f4c2881ae196a7aa32565e4b41dbda77bc2b6ae2313104
diff --git a/dev-db/etcd/etcd-3.5.18.ebuild b/dev-db/etcd/etcd-3.5.18.ebuild
new file mode 100644
index 000000000000..86439836af48
--- /dev/null
+++ b/dev-db/etcd/etcd-3.5.18.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+GIT_COMMIT=5bca08ec1
+
+DESCRIPTION="Highly-available key value store for shared configuration and service discovery"
+HOMEPAGE="https://github.com/etcd-io/etcd"
+SRC_URI="https://github.com/etcd-io/etcd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+LICENSE+=" BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~riscv"
+IUSE="doc +server"
+
+COMMON_DEPEND="server? (
+ acct-group/etcd
+ acct-user/etcd
+ )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+# Unit tests attempt to download go modules.
+RESTRICT="test"
+
+src_prepare() {
+ export FORCE_HOST_GO=1 GO_BUILD_FLAGS="-v -x"
+ default
+ sed -e "s|GIT_SHA=.*|GIT_SHA=${GIT_COMMIT}|" \
+ -i "${S}"/build.sh || die
+ sed -e 's:\(for p in \)shellcheck :\1 :' \
+ -e 's:^ goword \\$:\\:' \
+ -e 's:^ gofmt \\$:\\:' \
+ -e 's:^ govet \\$:\\:' \
+ -e 's:^ revive \\$:\\:' \
+ -e 's:^ mod_tidy \\$:\\:' \
+ -e "s|GO_BUILD_FLAGS=\"[^\"]*\"|GO_BUILD_FLAGS=\"${GO_BUILD_FLAGS}\"|" \
+ -e "s|go test |go test ${GO_BUILD_FLAGS} |" \
+ -e 's|PASSES=${PASSES:-"fmt bom dep build unit"}|PASSES=${PASSES:-"fmt dep unit"}|' \
+ -i ./test.sh || die
+}
+
+src_compile() {
+ ./build.sh || die
+}
+
+src_test() {
+ ./test || die
+}
+
+src_install() {
+ dobin bin/etcdctl
+ use doc && dodoc -r Documentation
+ if use server; then
+ insinto /etc/${PN}
+ sed -e 's|^data-dir:|\0 /var/lib/etcd|' -i etcd.conf.yml.sample || die
+ newins etcd.conf.yml.sample etcd.conf.yml
+ dobin bin/etcd
+ dodoc README.md
+ systemd_newunit "${FILESDIR}/${PN}.service-r1" "${PN}.service"
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
+ newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd-r1 ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ keepdir /var/lib/${PN} /var/log/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN} /var/log/${PN}
+ fperms 0700 /var/lib/${PN}
+ fperms 0755 /var/log/${PN}
+ fi
+}
+
+pkg_postinst() {
+ if use server; then
+ tmpfiles_process ${PN}.conf
+ fi
+}