summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-06-10 11:55:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-06-10 12:02:05 +0200
commit6d5dd145ad5c555722f228e187ed8e3eca8ca48c (patch)
treeab90239d8f747dfeec968fe6f6b6b2bbb99d8ff2
parentnet-im/skypeforlinux: add 8.98.0.402 (diff)
downloadgentoo-6d5dd145ad5c555722f228e187ed8e3eca8ca48c.tar.gz
gentoo-6d5dd145ad5c555722f228e187ed8e3eca8ca48c.tar.bz2
gentoo-6d5dd145ad5c555722f228e187ed8e3eca8ca48c.zip
kde-frameworks/frameworkintegration: 5.107.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.107.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 34ff5805ca01..90d3a079f7f1 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.104.0.tar.xz 1759964 BLAKE2B 83dbd951eefea03d8ad544a7f1ca1e39609ec7ed565b17c02a40ce3be795cc8386593fea09727a041e4ddec41dd795a7642901a24c8cdfc955a8cca5f77d9254 SHA512 2c5130b555b93cb72ce36be3708868fd35ebcda0a226e5099efe337477d53f938f066fd35a7e90efddadd3a51f427810b1b412028bbe6222e9208915afa06a74
DIST frameworkintegration-5.106.0.tar.xz 1759984 BLAKE2B e0de31798596cb8b2abb23938bc27c90bf7c898eacc666940a75dcb2adf2e99afb048afbba6b756b25a64f525cf19c129e4783cbd0a2479d2737dd917897a8e4 SHA512 bf0baafcdda7ecd9f66501a1585af3c6bc8417c17168ee11883bfe9096bb00f0a93313c246296bfdc096c230ff35d4f3fc223da7cba875aca2978b42b6bb5cb5
+DIST frameworkintegration-5.107.0.tar.xz 1759976 BLAKE2B 925b6e956e6e301b0128e4c3a64020fb357fc265cfa4cbbf20096a63bf870cc02a29e08c5a03eaedc0c5886f69acc8b0b3d594f990ea46be54f7b89e34b4ab4d SHA512 8041b5699d5d55e1e2b1656a57ade120f7e81ca2cb2377d1cadde8e01084c324b7eea59f141eab6e6043d7e93903260b92c47b5ef8dee589b9aa743c2aba86b1
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.107.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.107.0.ebuild
new file mode 100644
index 000000000000..36b3122c1d84
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.107.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}