summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-12-14 13:36:42 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-12-14 13:36:42 +0000
commit6ef32f80f3cc98c35a50f8fe6ea52a593ba331f8 (patch)
treeea08c9c6503a9cafec6dc0ed714ff399e925bb91
parent2021-12-14 13:21:48 UTC (diff)
parentdev-libs/plasma-wayland-protocols: Drop 1.3.0 (diff)
downloadgentoo-6ef32f80f3cc98c35a50f8fe6ea52a593ba331f8.tar.gz
gentoo-6ef32f80f3cc98c35a50f8fe6ea52a593ba331f8.tar.bz2
gentoo-6ef32f80f3cc98c35a50f8fe6ea52a593ba331f8.zip
Merge updates from master
-rw-r--r--dev-libs/plasma-wayland-protocols/Manifest1
-rw-r--r--dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.3.0.ebuild19
-rw-r--r--eclass/dune.eclass56
3 files changed, 35 insertions, 41 deletions
diff --git a/dev-libs/plasma-wayland-protocols/Manifest b/dev-libs/plasma-wayland-protocols/Manifest
index 39798bc6640d..e0caa1542d6b 100644
--- a/dev-libs/plasma-wayland-protocols/Manifest
+++ b/dev-libs/plasma-wayland-protocols/Manifest
@@ -1,2 +1 @@
-DIST plasma-wayland-protocols-1.3.0.tar.xz 39052 BLAKE2B 4024ac8c31c1620eb88b027084e9219368f570719cdb53ccff30594de7ebd5e0c01c8baf580d9c19115aa4632bc960fd8e44fd6bf97919e61faf24c1a43fbfdf SHA512 4c0466bbbe07399d4c54d4f04d7bee92826a6009c61fd7e6898c04d12e906c68fce25c520583225aef18737071b71b85814070a769a4f00e2a71b709568c1695
DIST plasma-wayland-protocols-1.5.0.tar.xz 41488 BLAKE2B 1235506ffb69fdbabd2d8a0b6c9b477a50c83431571b000a10907caa16b178ddbe628d63b4fdf2c98905fdb8a8fdd0699ca13dc3b718ab672b08719f9f434ea3 SHA512 bec83ee401e71fff3c5a38768034b0dfc1dd191af634b9ffa765bf86d9c14143abc2c5abd743dc53cc6c0aac1dbbf79104683c9ff5c6d880b03e71399806a6d7
diff --git a/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.3.0.ebuild b/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.3.0.ebuild
deleted file mode 100644
index b0b60287dd8e..000000000000
--- a/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.3.0.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_NONGUI=true
-KFMIN=5.69.0
-inherit ecm kde.org
-
-DESCRIPTION="Plasma Specific Protocols for Wayland"
-HOMEPAGE="https://invent.kde.org/libraries/plasma-wayland-protocols"
-
-if [[ ${KDE_BUILD_TYPE} = release ]]; then
- SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-fi
-
-LICENSE="LGPL-2.1"
-SLOT="0"
diff --git a/eclass/dune.eclass b/eclass/dune.eclass
index 02a8a870ef43..69aad36921b9 100644
--- a/eclass/dune.eclass
+++ b/eclass/dune.eclass
@@ -8,7 +8,7 @@
# ML <ml@gentoo.org>
# @AUTHOR:
# Rafael Kitover <rkitover@gmail.com>
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 6 7 8
# @BLURB: Provides functions for installing Dune packages.
# @DESCRIPTION:
# Provides dependencies on dDne and OCaml and default src_compile, src_test and
@@ -19,9 +19,10 @@
# @DESCRIPTION:
# Sets the actual Dune package name, if different from Gentoo package name.
# Set before inheriting the eclass.
+: ${DUNE_PKG_NAME:-${PN}}
case ${EAPI:-0} in
- 5|6|7) ;;
+ 6|7|8) ;;
*) die "${ECLASS}: EAPI ${EAPI} not supported" ;;
esac
@@ -32,7 +33,7 @@ EXPORT_FUNCTIONS src_compile src_test src_install
RDEPEND=">=dev-lang/ocaml-4:=[ocamlopt?] dev-ml/dune:="
case ${EAPI:-0} in
- 5|6)
+ 6)
DEPEND="${RDEPEND} dev-ml/dune"
;;
*)
@@ -42,11 +43,15 @@ case ${EAPI:-0} in
esac
dune_src_compile() {
- dune build @install --profile release || die
+ ebegin "Building"
+ dune build @install --profile release
+ eend $? || die
}
dune_src_test() {
- dune runtest || die
+ ebegin "Testing"
+ dune runtest
+ eend $? || die
}
# @FUNCTION: dune-install
@@ -54,26 +59,35 @@ dune_src_test() {
# @DESCRIPTION:
# Installs the dune packages given as arguments. For each "${pkg}" element in
# that list, "${pkg}.install" must be readable from "${PWD}/_build/default"
+#
+# Example use:
+# @CODE
+# dune-install menhir menhirLib menhirSdk
+# @CODE
dune-install() {
+ local -a pkgs=( "${@}" )
+ [[ ${#pkgs[@]} -eq 0 ]] && pkgs=( "${DUNE_PKG_NAME}" )
+
+ local -a myduneopts=(
+ --prefix="${ED%/}/usr"
+ --libdir="${D%/}$(ocamlc -where)"
+ --mandir="${ED%/}/usr/share/man"
+ )
local pkg
- for pkg ; do
- dune install \
- --prefix="${ED%/}/usr" \
- --libdir="${D%/}$(ocamlc -where)" \
- --mandir="${ED%/}/usr/share/man" \
- "${pkg}" || die
+ for pkg in "${pkgs[@]}" ; do
+ ebegin "Installing ${pkg}"
+ dune install ${myduneopts[@]} ${pkg}
+ eend $? || die
+
+ # Move docs to the appropriate place.
+ if [ -d "${ED%/}/usr/doc/${pkg}" ] ; then
+ mkdir -p "${ED%/}/usr/share/doc/${PF}/" || die
+ mv "${ED%/}/usr/doc/${pkg}" "${ED%/}/usr/share/doc/${PF}/" || die
+ rm -rf "${ED%/}/usr/doc" || die
+ fi
done
}
dune_src_install() {
- local pkg="${1:-${DUNE_PKG_NAME:-${PN}}}"
-
- dune-install "${pkg}"
-
- # Move docs to the appropriate place.
- if [ -d "${ED%/}/usr/doc/${pkg}" ] ; then
- mkdir -p "${ED%/}/usr/share/doc/${PF}/" || die
- mv "${ED%/}/usr/doc/${pkg}/"* "${ED%/}/usr/share/doc/${PF}/" || die
- rm -rf "${ED%/}/usr/doc" || die
- fi
+ dune-install ${1:-${DUNE_PKG_NAME}}
}