summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-05 16:09:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-05 16:11:45 +0200
commit7407f018fe7b883c0bedd34416e8eb8d07a3a8c9 (patch)
treeaab0a3733140ba48e92d6401db786d76f52e8c44
parentdev-util/catfish: Use PEP517 build (diff)
downloadgentoo-7407f018fe7b883c0bedd34416e8eb8d07a3a8c9.tar.gz
gentoo-7407f018fe7b883c0bedd34416e8eb8d07a3a8c9.tar.bz2
gentoo-7407f018fe7b883c0bedd34416e8eb8d07a3a8c9.zip
dev-python/python-distutils-extra: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.46.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.46.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.46.ebuild
index 5e898d180bee..d00792e6360e 100644
--- a/dev-python/python-distutils-extra/python-distutils-extra-2.46.ebuild
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.46.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -34,5 +35,6 @@ BDEPEND="
"
python_test() {
+ local -x SETUPTOOLS_USE_DISTUTILS=stdlib
"${EPYTHON}" test/auto.py -v || die "Tests fail with ${EPYTHON}"
}