summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-08-19 10:40:20 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-08-19 10:40:20 +0200
commit787961515ccd33de9f95a618fcaf4f9db6890bec (patch)
tree144568165d0b274a4160b1c6ecddb85c7adb682a
parentsys-apps/sysvinit: Minor cosmetic change to halt.sh (diff)
downloadgentoo-787961515ccd33de9f95a618fcaf4f9db6890bec.tar.gz
gentoo-787961515ccd33de9f95a618fcaf4f9db6890bec.tar.bz2
gentoo-787961515ccd33de9f95a618fcaf4f9db6890bec.zip
dev-libs/protobuf-c: Bump to version 1.3.2
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-libs/protobuf-c/Manifest1
-rw-r--r--dev-libs/protobuf-c/protobuf-c-1.3.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/protobuf-c/Manifest b/dev-libs/protobuf-c/Manifest
index 0dd2386a7ba6..684098a5a12f 100644
--- a/dev-libs/protobuf-c/Manifest
+++ b/dev-libs/protobuf-c/Manifest
@@ -1 +1,2 @@
DIST protobuf-c-1.3.1.tar.gz 498779 BLAKE2B f9ecb2cccd8e01a2ab5bd797883f245db418a76ac73ba3e756e997e944637732d45b3fca2a45d3caf4cd89f35259180fa05e64b8b02b63537005420f2233ba37 SHA512 b32920130b4be5e8a8373c2ca37ffe7eb263accf163d93e25a9eb4b6336ec40b05dda2458fe8f0c3cbcf6e0e08e9541fdff004d696f30a5d135b7a3bdca8b2c3
+DIST protobuf-c-1.3.2.tar.gz 500100 BLAKE2B b8bcd4ad6f9ddc05f28526f7cc58778b21a34fc18c7c7aa2a5bb45ae7fdc7c5d8957f989fe1bbfe353214ca87b02afed8cf0ad43c0f0e39f7e13059a5dfd6b7d SHA512 d94d2c6f11b3e482fd3d1b8cef5b2d896ad37a679068f393d29916311deadc5b6b86f946b046d7ee49260b0223e3128e052dc76324b4a8cd6ea184d566ad9aa6
diff --git a/dev-libs/protobuf-c/protobuf-c-1.3.2.ebuild b/dev-libs/protobuf-c/protobuf-c-1.3.2.ebuild
new file mode 100644
index 000000000000..e666446a3b08
--- /dev/null
+++ b/dev-libs/protobuf-c/protobuf-c-1.3.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Protocol Buffers implementation in C"
+HOMEPAGE="https://github.com/protobuf-c/protobuf-c"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+# Subslot == SONAME version
+SLOT="0/1.0.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static-libs test"
+
+BDEPEND="dev-libs/protobuf:0
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+DEPEND="dev-libs/protobuf:0=[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ if ! use test; then
+ eapply "${FILESDIR}"/${PN}-1.3.0-no-build-tests.patch
+ fi
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}