summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-27 14:01:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-27 14:56:23 +0200
commit8e9c5ac893c6151da79210df9d512d84199ff674 (patch)
tree08d53fadc9eec00e00e4217875d4565abe747754
parentnet-dns/libidn2: Remove old (diff)
downloadgentoo-8e9c5ac893c6151da79210df9d512d84199ff674.tar.gz
gentoo-8e9c5ac893c6151da79210df9d512d84199ff674.tar.bz2
gentoo-8e9c5ac893c6151da79210df9d512d84199ff674.zip
dev-python/imapclient: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/imapclient/Manifest1
-rw-r--r--dev-python/imapclient/imapclient-3.0.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/imapclient/Manifest b/dev-python/imapclient/Manifest
index 1fb691c27a24..3cc822e5d5da 100644
--- a/dev-python/imapclient/Manifest
+++ b/dev-python/imapclient/Manifest
@@ -1 +1,2 @@
DIST imapclient-2.3.1.gh.tar.gz 91141 BLAKE2B c4efbdb4a513277039389e13d0f86498df3bb4c466026510fba55a8cf88316a3c5b02c15215e3e40e8e0b6206e8bd4659e75b1f83ba2a905a2aaec21f8af4b48 SHA512 06a9264e8cc001b8a4a6a855032bbb9b904c94999d090c3f1bedea1ae3a16524f668eb4dfa36e7a23a0622bd9d3e83191dcc1e5e30275cb6fcb7604142e5e2a6
+DIST imapclient-3.0.0.gh.tar.gz 93743 BLAKE2B f1477cc01076876f65afc4e1ca8dcdc5964a2ec129f8decc7c963361a94e262d1312f70959d82772e077062d15d758289fe6942c8395ccea124fbf83ebcc0505 SHA512 01f2b0eaa148e84bf3aae428888da55dec80c3738d31989644da9f7f476fc22877348e9db737d420bbdcc3986e0e74825666ba6970a43d5e2ab6b53b3fee6c1e
diff --git a/dev-python/imapclient/imapclient-3.0.0.ebuild b/dev-python/imapclient/imapclient-3.0.0.ebuild
new file mode 100644
index 000000000000..babb66090be8
--- /dev/null
+++ b/dev-python/imapclient/imapclient-3.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="easy-to-use, pythonic, and complete IMAP client library"
+HOMEPAGE="
+ https://github.com/mjs/imapclient/
+ https://pypi.org/project/IMAPClient/
+"
+SRC_URI="
+ https://github.com/mjs/imapclient/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+distutils_enable_sphinx doc/src
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}