summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 19:15:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 15:34:21 +0100
commit8f8c6827621d0aa475f92a2c19b9f530db3db114 (patch)
treecbda2aced505450fa95656af2fe1d3b265688de0
parent*/*: Switch sound proj packages to cmake.eclass (diff)
downloadgentoo-8f8c6827621d0aa475f92a2c19b9f530db3db114.tar.gz
gentoo-8f8c6827621d0aa475f92a2c19b9f530db3db114.tar.bz2
gentoo-8f8c6827621d0aa475f92a2c19b9f530db3db114.zip
*/*: Switch proaudio proj packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-libs/portmidi/portmidi-217-r3.ebuild10
-rw-r--r--media-sound/csound/csound-6.13.0.ebuild9
-rw-r--r--media-sound/csound/csound-9999.ebuild9
-rw-r--r--media-sound/hydrogen/hydrogen-9999.ebuild10
-rw-r--r--media-sound/rosegarden/rosegarden-17.12.1.ebuild6
-rw-r--r--media-sound/rosegarden/rosegarden-19.06.ebuild8
-rw-r--r--media-sound/rosegarden/rosegarden-19.12.ebuild8
-rw-r--r--media-sound/zynaddsubfx/zynaddsubfx-3.0.5.ebuild18
8 files changed, 38 insertions, 40 deletions
diff --git a/media-libs/portmidi/portmidi-217-r3.ebuild b/media-libs/portmidi/portmidi-217-r3.ebuild
index f50b4e526ed5..27dd06fd49d7 100644
--- a/media-libs/portmidi/portmidi-217-r3.ebuild
+++ b/media-libs/portmidi/portmidi-217-r3.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{6,7,8} )
DISTUTILS_OPTIONAL=1
# ninja: error: build.ninja:521: multiple rules generate pm_java/pmdefaults.jar [-w dupbuild=err]
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils desktop xdg distutils-r1 java-pkg-opt-2
+inherit cmake desktop xdg distutils-r1 java-pkg-opt-2
DESCRIPTION="Library for real time MIDI input and output"
HOMEPAGE="http://portmedia.sourceforge.net/"
@@ -58,7 +58,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# install wrapper for pmdefaults
if use java ; then
@@ -88,11 +88,11 @@ src_configure() {
mycmakeargs+=(-DJAR_INSTALL_DIR="${EPREFIX}/usr/share/${PN}/lib")
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use python ; then
sed -i -e "/library_dirs=.*linux/s#./linux#${CMAKE_BUILD_DIR}#" pm_python/setup.py || die
@@ -110,7 +110,7 @@ src_compile() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc CHANGELOG.txt README.txt pm_linux/README_LINUX.txt
diff --git a/media-sound/csound/csound-6.13.0.ebuild b/media-sound/csound/csound-6.13.0.ebuild
index bee79ef48771..e7d1d96b3f99 100644
--- a/media-sound/csound/csound-6.13.0.ebuild
+++ b/media-sound/csound/csound-6.13.0.ebuild
@@ -8,7 +8,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils python-single-r1 toolchain-funcs
+inherit cmake python-single-r1 toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/csound/csound.git"
@@ -113,7 +113,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -e '/set(PLUGIN_INSTALL_DIR/s/-${APIVERSION}//' \
-e '/-O3/d' \
@@ -153,7 +153,6 @@ src_configure() {
-DBUILD_SCANSYN_OPCODES=OFF # this is not allowed to be redistributed: https://github.com/csound/csound/issues/1148
-DBUILD_SELECT_OPCODE=ON
-DBUILD_SERIAL_OPCODES=ON
- -DBUILD_SHARED_LIBS=ON
-DBUILD_STACK_OPCODES=ON
-DBUILD_STATIC_LIBRARY=$(usex static-libs)
-DBUILD_STATIC_LIBRARY=$(usex test)
@@ -225,11 +224,11 @@ src_configure() {
-DUSE_LIB64=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc -r Release_Notes/.
# generate env.d file
diff --git a/media-sound/csound/csound-9999.ebuild b/media-sound/csound/csound-9999.ebuild
index d6e3677445f6..f29357886e45 100644
--- a/media-sound/csound/csound-9999.ebuild
+++ b/media-sound/csound/csound-9999.ebuild
@@ -8,7 +8,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils python-single-r1 toolchain-funcs
+inherit cmake python-single-r1 toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/csound/csound.git"
@@ -113,7 +113,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -e '/set(PLUGIN_INSTALL_DIR/s/-${APIVERSION}//' \
-e '/-O3/d' \
@@ -154,7 +154,6 @@ src_configure() {
-DBUILD_SCANSYN_OPCODES=OFF # this is not allowed to be redistributed: https://github.com/csound/csound/issues/1148
-DBUILD_SELECT_OPCODE=ON
-DBUILD_SERIAL_OPCODES=ON
- -DBUILD_SHARED_LIBS=ON
-DBUILD_STACK_OPCODES=ON
-DBUILD_STATIC_LIBRARY=$(usex static-libs)
-DBUILD_STATIC_LIBRARY=$(usex test)
@@ -226,11 +225,11 @@ src_configure() {
-DUSE_LIB64=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc -r Release_Notes/.
# generate env.d file
diff --git a/media-sound/hydrogen/hydrogen-9999.ebuild b/media-sound/hydrogen/hydrogen-9999.ebuild
index db964f614256..9245c1140a0d 100644
--- a/media-sound/hydrogen/hydrogen-9999.ebuild
+++ b/media-sound/hydrogen/hydrogen-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit git-r3 xdg cmake-utils
+inherit git-r3 xdg cmake
DESCRIPTION="Advanced drum machine"
HOMEPAGE="http://www.hydrogen-music.org/"
@@ -62,15 +62,15 @@ src_configure() {
-DWANT_RUBBERBAND=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile doc
+ cmake_src_compile
+ use doc && cmake_src_compile doc
}
src_install() {
use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
- cmake-utils_src_install
+ cmake_src_install
}
diff --git a/media-sound/rosegarden/rosegarden-17.12.1.ebuild b/media-sound/rosegarden/rosegarden-17.12.1.ebuild
index 34f80417db54..dac7760081c1 100644
--- a/media-sound/rosegarden/rosegarden-17.12.1.ebuild
+++ b/media-sound/rosegarden/rosegarden-17.12.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="MIDI and audio sequencer and notation editor"
HOMEPAGE="https://www.rosegardenmusic.com/"
@@ -43,12 +43,12 @@ DEPEND="${RDEPEND}
"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
"-DDISABLE_LIRC=$(usex lirc OFF ON)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-sound/rosegarden/rosegarden-19.06.ebuild b/media-sound/rosegarden/rosegarden-19.06.ebuild
index eaedb77e1951..a86fbbdda3ed 100644
--- a/media-sound/rosegarden/rosegarden-19.06.ebuild
+++ b/media-sound/rosegarden/rosegarden-19.06.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg virtualx
+inherit cmake xdg virtualx
DESCRIPTION="MIDI and audio sequencer and notation editor"
HOMEPAGE="https://www.rosegardenmusic.com/"
@@ -44,16 +44,16 @@ DEPEND="${RDEPEND}
"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
"-DDISABLE_LIRC=$(usex lirc OFF ON)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
- virtx cmake-utils_src_test
+ virtx cmake_src_test
}
diff --git a/media-sound/rosegarden/rosegarden-19.12.ebuild b/media-sound/rosegarden/rosegarden-19.12.ebuild
index 43ed83b26b8c..7ed9801029fe 100644
--- a/media-sound/rosegarden/rosegarden-19.12.ebuild
+++ b/media-sound/rosegarden/rosegarden-19.12.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg virtualx
+inherit cmake xdg virtualx
DESCRIPTION="MIDI and audio sequencer and notation editor"
HOMEPAGE="https://www.rosegardenmusic.com/"
@@ -44,16 +44,16 @@ DEPEND="${RDEPEND}
"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
"-DDISABLE_LIRC=$(usex lirc OFF ON)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
- virtx cmake-utils_src_test
+ virtx cmake_src_test
}
diff --git a/media-sound/zynaddsubfx/zynaddsubfx-3.0.5.ebuild b/media-sound/zynaddsubfx/zynaddsubfx-3.0.5.ebuild
index 01b612a4bcdb..72b005731674 100644
--- a/media-sound/zynaddsubfx/zynaddsubfx-3.0.5.ebuild
+++ b/media-sound/zynaddsubfx/zynaddsubfx-3.0.5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils flag-o-matic
+inherit cmake flag-o-matic
DESCRIPTION="Software synthesizer capable of making a countless number of instruments"
HOMEPAGE="http://zynaddsubfx.sourceforge.net/"
@@ -43,7 +43,7 @@ PATCHES=( "${FILESDIR}"/${P}-docs.patch )
DOCS=( ChangeLog HISTORY.txt README.adoc )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if ! use dssi; then
sed -i -e '/pkg_search_module.*DSSI/s/^/#DONT/' src/CMakeLists.txt || die
@@ -67,21 +67,21 @@ src_configure() {
local mycmakeargs=(
-DPluginLibDir=$(get_libdir)
- $(cmake-utils_use_find_package alsa Alsa)
- $(cmake-utils_use_find_package doc Doxygen)
- $(cmake-utils_use_find_package fltk FLTK)
+ $(cmake_use_find_package alsa Alsa)
+ $(cmake_use_find_package doc Doxygen)
+ $(cmake_use_find_package fltk FLTK)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile doc
+ cmake_src_compile
+ use doc && cmake_src_compile doc
}
src_install() {
use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
- cmake-utils_src_install
+ cmake_src_install
insinto /usr/share/${PN}
doins -r instruments/*
}