summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-10-17 18:48:52 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-10-17 18:48:52 +0000
commit934f05ca21f6732242f8c9293f48c8b2be61f0d5 (patch)
tree4c351ee7445d1aecfbeb25700c9d8625833d0c37
parent2022-10-17 18:18:53 UTC (diff)
parentgui-libs/wlroots: drop 0.15.0-r1, 0.15.0-r2 (diff)
downloadgentoo-934f05ca21f6732242f8c9293f48c8b2be61f0d5.tar.gz
gentoo-934f05ca21f6732242f8c9293f48c8b2be61f0d5.tar.bz2
gentoo-934f05ca21f6732242f8c9293f48c8b2be61f0d5.zip
Merge updates from master
-rw-r--r--eclass/kernel-build.eclass2
-rw-r--r--eclass/linux-mod.eclass2
-rw-r--r--gui-apps/grim/Manifest1
-rw-r--r--gui-apps/grim/grim-1.3.1.ebuild43
-rw-r--r--gui-apps/kanshi/Manifest1
-rw-r--r--gui-apps/kanshi/kanshi-1.2.0.ebuild43
-rw-r--r--gui-apps/slurp/Manifest1
-rw-r--r--gui-apps/slurp/slurp-1.2.0.ebuild41
-rw-r--r--gui-libs/wlroots/Manifest1
-rw-r--r--gui-libs/wlroots/wlroots-0.15.0-r1.ebuild72
-rw-r--r--gui-libs/wlroots/wlroots-0.15.0-r2.ebuild74
11 files changed, 2 insertions, 279 deletions
diff --git a/eclass/kernel-build.eclass b/eclass/kernel-build.eclass
index 1fa25cbc9574..7086297bf52a 100644
--- a/eclass/kernel-build.eclass
+++ b/eclass/kernel-build.eclass
@@ -91,7 +91,7 @@ kernel-build_src_configure() {
)
if type -P xz &>/dev/null ; then
- export XZ_OPT="-T$(makeopts_jobs)"
+ export XZ_OPT="-T$(makeopts_jobs) --memlimit-compress=50%"
fi
if type -P zstd &>/dev/null ; then
diff --git a/eclass/linux-mod.eclass b/eclass/linux-mod.eclass
index f0005a8cca65..6846c528354a 100644
--- a/eclass/linux-mod.eclass
+++ b/eclass/linux-mod.eclass
@@ -716,7 +716,7 @@ linux-mod_src_install() {
# and similarily compress the module being built if != NONE.
if linux_chkconfig_present MODULE_COMPRESS_XZ; then
- xz -T$(makeopts_jobs) ${modulename}.${KV_OBJ} || die "Compressing ${modulename}.${KV_OBJ} with xz failed"
+ xz -T$(makeopts_jobs) --memlimit-compress=50% ${modulename}.${KV_OBJ} || die "Compressing ${modulename}.${KV_OBJ} with xz failed"
doins ${modulename}.${KV_OBJ}.xz
elif linux_chkconfig_present MODULE_COMPRESS_GZIP; then
if type -P pigz &>/dev/null ; then
diff --git a/gui-apps/grim/Manifest b/gui-apps/grim/Manifest
index 8e07f6935b66..f6c8d088facd 100644
--- a/gui-apps/grim/Manifest
+++ b/gui-apps/grim/Manifest
@@ -1,2 +1 @@
-DIST grim-1.3.1.tar.gz 15778 BLAKE2B 7dc1f2fbc9e0f81c41d8ca535346d185a0f6c7a0ee28f0168a29864a36d1077be961278c1be3e647aa09165d9f3800e1bc7979f9fca95f8b39c339d621cd984d SHA512 07d04681ec589bf3e48b14c3bfcdc2a6012dfe5c5c2d7ee0cba95bc128187ca0de19ec04140dbe00907778f3d68844e6a90dc35365dafa489d65048b590fdf1b
DIST grim-1.4.0.tar.gz 18287 BLAKE2B 72606de01624c98876fe1018877a3cf0b25b44ac4bd6a053f82c40ad1ea2c6c0e510cbb6a0bce988f14607ea162dda1d8350b9f30b0f2b9acd8f8e20ba50bc99 SHA512 d0b33528a00528b3ef7488a0984cde5034de4f5a211eb5c8d3299aea356d9348c5d02d08171802bc0315afb19d2446f5f132ea9dca0579ace803b7d5d90a89cc
diff --git a/gui-apps/grim/grim-1.3.1.ebuild b/gui-apps/grim/grim-1.3.1.ebuild
deleted file mode 100644
index 3db3bf2b4aca..000000000000
--- a/gui-apps/grim/grim-1.3.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="Grab images from a Wayland compositor"
-HOMEPAGE="https://github.com/emersion/grim"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
-else
- SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+man jpeg"
-
-DEPEND="
- dev-libs/wayland
- >=dev-libs/wayland-protocols-1.14
- x11-libs/cairo
- jpeg? ( media-libs/libjpeg-turbo )
-"
-RDEPEND="${DEPEND}"
-
-if [[ ${PV} == 9999 ]]; then
- BDEPEND+="man? ( ~app-text/scdoc-9999 )"
-else
- BDEPEND+="man? ( app-text/scdoc )"
-fi
-
-src_configure() {
- local emesonargs=(
- $(meson_feature jpeg)
- $(meson_feature man man-pages)
- )
- meson_src_configure
-}
diff --git a/gui-apps/kanshi/Manifest b/gui-apps/kanshi/Manifest
index 177e6bf48d9d..f20c66d2b975 100644
--- a/gui-apps/kanshi/Manifest
+++ b/gui-apps/kanshi/Manifest
@@ -1,2 +1 @@
-DIST kanshi-1.2.0.tar.gz 16501 BLAKE2B a527b62a5aa39c7b0ee28c5a7b30827c525d07c9b85b7256392e641448e84bd6eff51d9b0a8d7f9df149efb6a49019412ec756b517ade6b72615a09a95f35c52 SHA512 d863547f0fcc2289d52220d913a7092af1c164ef0cd118288a1731983d06d1821e03f2defec9b43275b40fee23da25135e2bea39293b9de0ec8a32775369dac0
DIST kanshi-1.3.0.tar.gz 20721 BLAKE2B 56ba2241f21c41c5ba0e33c25ed0fb32ce471ac1c5f8dd030f93cb27e142319d1643143e78d4b375f855af1af5a078168e589ef74c82aaf738cef95618c122ab SHA512 f89164b1c4440d1cb29dfd70aab0721607dd63ea144ace9a2ff30cf89e662d404044bb30a5bc6c5544e8988db498eba3cd80100424ca76d31cc35b60e38036d9
diff --git a/gui-apps/kanshi/kanshi-1.2.0.ebuild b/gui-apps/kanshi/kanshi-1.2.0.ebuild
deleted file mode 100644
index b415cae3b1ac..000000000000
--- a/gui-apps/kanshi/kanshi-1.2.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson
-
-DESCRIPTION="dynamic display configuration (autorandr for wayland)"
-HOMEPAGE="https://wayland.emersion.fr/kanshi/ https://sr.ht/~emersion/kanshi/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/emersion/kanshi"
-else
- SRC_URI="https://github.com/emersion/kanshi/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+man"
-
-RDEPEND="
- dev-libs/wayland
-"
-BDEPEND="
- ${RDEPEND}
- virtual/pkgconfig
- dev-libs/wayland-protocols
-"
-
-if [[ ${PV} == 9999 ]]; then
- BDEPEND+="man? ( ~app-text/scdoc-9999 )"
-else
- BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
-fi
-
-src_configure() {
- local emesonargs=(
- $(meson_feature man man-pages)
- )
- meson_src_configure
-}
diff --git a/gui-apps/slurp/Manifest b/gui-apps/slurp/Manifest
index 55e3f975e91b..46a2254a9872 100644
--- a/gui-apps/slurp/Manifest
+++ b/gui-apps/slurp/Manifest
@@ -1,2 +1 @@
-DIST slurp-1.2.0.tar.gz 15317 BLAKE2B 92de74abb54b2d53334e0f0c5d08b0b50e9c4583eb192226e38fcefa07cce2265f808ce81c04170e65d3c1209fa263352e3d70cc0a7cf745ed5e18d57c4d3af6 SHA512 443cd497049a5128e80a48c7b2afcc555a8d58a5eacc2dc6207058a9a399bc9e9804c7bca8b010af63f8be99000c05245720bd3e8cca248a74d5aa63a7faf4f9
DIST slurp-1.3.2.tar.gz 17734 BLAKE2B 42795f1927742ce9606c685a49f2fb395905c875b50b50b60b68bf129d3c6743278a0eeaed72b94921dd65bd4ca4c078c24c693029cff84dbcbe20165242653c SHA512 9e7f9e4b46095fce5dcc05f8d04b5e576771d15080a0ec451a8a5df681d5ab818cb4d5284a74e1650f775e2d05ca32d66551d8e333d6002827c8b60b12d6bb28
diff --git a/gui-apps/slurp/slurp-1.2.0.ebuild b/gui-apps/slurp/slurp-1.2.0.ebuild
deleted file mode 100644
index b6721e1160fe..000000000000
--- a/gui-apps/slurp/slurp-1.2.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="Select a region in a Wayland compositor and print it to the standard output"
-HOMEPAGE="https://github.com/emersion/slurp"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
-else
- SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+man"
-
-DEPEND="
- >=dev-libs/wayland-protocols-1.14
- dev-libs/wayland
- x11-libs/cairo"
-
-RDEPEND="${DEPEND}"
-
-if [[ ${PV} == 9999 ]]; then
- BDEPEND+="man? ( ~app-text/scdoc-9999 )"
-else
- BDEPEND+="man? ( app-text/scdoc )"
-fi
-
-src_configure() {
- local emesonargs=(
- $(meson_feature man man-pages)
- )
- meson_src_configure
-}
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index ce2290bd369b..e307e5dade54 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -1,4 +1,3 @@
DIST wlroots-0.14.0.tar.gz 505461 BLAKE2B d2fa28f64014ef9d840838cb5938af23f6f6b211b62dc352d0d5bb824ccaa7d7a85531e1eca14feeb06d31d59955ff9a913e40a73cad21ed1ebfe76ada39d558 SHA512 83f001133cb4b11a72bb9532b7321655428826662848f67de8e3220a33d9dff4d37c859602bdc319929949d387d014a257b0347039a6649944d7b084c76bb611
DIST wlroots-0.14.1.tar.gz 505840 BLAKE2B fca4d259cdde62da0c196344ce1d0f5dd679d012ff33e3ceb5385b9374667e16d91059a2ba6a318153e79ac2f0a6464e3066e614a13398f8c433f442560d84d2 SHA512 4f557c827f9673eccf208a3644954de80e7355b95cc374cc5e851a47087b227f196e0936c0913d21a6c776c29b74de2d028a100931264e41934c747568d8ebe0
-DIST wlroots-0.15.0.tar.gz 565059 BLAKE2B d98529b4548e3b751a505a26af143be585ed42fb9617bc67b4a10747bb494f1359d7bdb75d1730a72396e7c550fe481e858a5ac88621d61671698439e3656920 SHA512 730b1e0cf003dabae23101664c6d1993636bd3a8ecbdb3c165eef415a92811c4d5228f48e0275f75361d8528f118dfb8a2298cfb05dbf6364539224ceedca447
DIST wlroots-0.15.1.tar.gz 565816 BLAKE2B 09b704a55d8b4a5ab19bb0fcdd041635fbbbb8eed94ff6d189ef47f9f86e90178efa8441c7db78839b1145ed79ed016d520d6599e256cdcf49130cda38bc307d SHA512 6228160f2f350a406c612f1048d7075cf2f78206cc84bc16f889d5d0acd614f9e98845fffed03d7067cfdbd7558b77fcc5d8cedc3868d866e476523126a63677
diff --git a/gui-libs/wlroots/wlroots-0.15.0-r1.ebuild b/gui-libs/wlroots/wlroots-0.15.0-r1.ebuild
deleted file mode 100644
index 79e777c25134..000000000000
--- a/gui-libs/wlroots/wlroots-0.15.0-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
-HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots"
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}.git"
- inherit git-r3
- SLOT="0/9999"
-else
- SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
- SLOT="0/15"
-fi
-
-LICENSE="MIT"
-IUSE="vulkan x11-backend X"
-
-DEPEND="
- >=dev-libs/libinput-1.14.0:0=
- >=dev-libs/wayland-1.20.0
- >=dev-libs/wayland-protocols-1.24
- media-libs/mesa[egl(+),gles2,gbm(+)]
- sys-auth/seatd:=
- virtual/libudev
- vulkan? (
- dev-util/glslang:0=
- dev-util/vulkan-headers:0=
- media-libs/vulkan-loader:0=
- )
- >=x11-libs/libdrm-2.4.109:0=
- x11-libs/libxkbcommon
- x11-libs/pixman
- x11-backend? ( x11-libs/libxcb:0= )
- X? (
- x11-base/xwayland
- x11-libs/libxcb:0=
- x11-libs/xcb-util-image
- x11-libs/xcb-util-wm
- )
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- >=dev-libs/wayland-protocols-1.24
- >=dev-util/meson-0.60.0
- virtual/pkgconfig
-"
-
-src_configure() {
- # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
- local emesonargs=(
- "-Dxcb-errors=disabled"
- "-Dexamples=false"
- -Drenderers=$(usex vulkan 'gles2,vulkan' gles2)
- -Dxwayland=$(usex X enabled disabled)
- -Dbackends=drm,libinput$(usex x11-backend ',x11' '')
- )
-
- meson_src_configure
-}
-
-pkg_postinst() {
- elog "You must be in the input group to allow your compositor"
- elog "to access input devices via libinput."
-}
diff --git a/gui-libs/wlroots/wlroots-0.15.0-r2.ebuild b/gui-libs/wlroots/wlroots-0.15.0-r2.ebuild
deleted file mode 100644
index c304488ebcbd..000000000000
--- a/gui-libs/wlroots/wlroots-0.15.0-r2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
-HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots"
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}.git"
- inherit git-r3
- SLOT="0/9999"
-else
- SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
- KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
- SLOT="0/15"
-fi
-
-LICENSE="MIT"
-IUSE="vulkan x11-backend X"
-
-DEPEND="
- >=dev-libs/libinput-1.14.0:0=
- >=dev-libs/wayland-1.20.0
- >=dev-libs/wayland-protocols-1.24
- media-libs/mesa[egl(+),gles2,gbm(+)]
- sys-auth/seatd:=
- virtual/libudev
- vulkan? (
- dev-util/glslang:0=
- dev-util/vulkan-headers:0=
- media-libs/vulkan-loader:0=
- )
- >=x11-libs/libdrm-2.4.109:0=
- x11-libs/libxkbcommon
- x11-libs/pixman
- x11-backend? ( x11-libs/libxcb:0= )
- X? (
- x11-base/xwayland
- x11-libs/libxcb:0=
- x11-libs/xcb-util-image
- x11-libs/xcb-util-wm
- )
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- >=dev-libs/wayland-protocols-1.24
- >=dev-util/meson-0.60.0
- virtual/pkgconfig
-"
-
-PATCHES=( "${FILESDIR}/0.15.0-59b9518f.patch" )
-
-src_configure() {
- # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
- local emesonargs=(
- "-Dxcb-errors=disabled"
- "-Dexamples=false"
- -Drenderers=$(usex vulkan 'gles2,vulkan' gles2)
- -Dxwayland=$(usex X enabled disabled)
- -Dbackends=drm,libinput$(usex x11-backend ',x11' '')
- )
-
- meson_src_configure
-}
-
-pkg_postinst() {
- elog "You must be in the input group to allow your compositor"
- elog "to access input devices via libinput."
-}