summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-21 02:47:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-21 03:46:49 +0200
commitc2599e45c9774da5dc3a67e42bce0bd7ee1db68b (patch)
tree56b02b3b000dec4a0e464651ff86794f11071920
parentdev-python/botocore: Bump to 1.34.131 (diff)
downloadgentoo-c2599e45c9774da5dc3a67e42bce0bd7ee1db68b.tar.gz
gentoo-c2599e45c9774da5dc3a67e42bce0bd7ee1db68b.tar.bz2
gentoo-c2599e45c9774da5dc3a67e42bce0bd7ee1db68b.zip
dev-python/boto3: Bump to 1.34.131
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.131.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 497e19ed1c9f..cca3311716c6 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.34.127.gh.tar.gz 820740 BLAKE2B ddfb7802440a01af27059daed4bc7cd3797
DIST boto3-1.34.128.gh.tar.gz 821252 BLAKE2B 7f7d13106d69b54d4932a52c0d0b2803cc5131773ce9503a1fc8ea8ff3fdfb5ba5f372b2665312ce3c136f4f37889e54cd61b49eec72ac21902f379b0ec87f29 SHA512 ee46351e613c55cf720e2bf361df8bb07954a05bc9707ce20fe75390abf195674d50e4f862ed8d357397e83c7ffcc586eff396d186596e688b895deaaaf4699f
DIST boto3-1.34.129.gh.tar.gz 821825 BLAKE2B c672b77844c366190ed1a7d3bd1621267da9db321bdf36bad3d6f4de359b560509467156a602a598b53e5f12c4442558294199185c6a6074b7c303b914b645ae SHA512 af548985020c54ff5f9838639c89daafb2d14d2da0376a541f274d4440219758610811fb71654ecf4aa59cad1e6b56c8cb4e830949d0686665ae30a99d48f3fc
DIST boto3-1.34.130.gh.tar.gz 822203 BLAKE2B b7abf46e88f08a64f13abc39089fb3b61164cf115c41716b038b285fc1002bd0a3bc63e30774a001a9965ed5beecdd792d19ba41ca658b49dfa2c2c52566b8a7 SHA512 c6a600577a5be8639a42d5c643eb6cb4f7b534667ecff4d78f7c5ebe79e6f79fd94e8ed0a86b777d7b2fa253fbe9ce6b78fcf85e7887f1fd8bc94a69ddc685e6
+DIST boto3-1.34.131.gh.tar.gz 822851 BLAKE2B cc4b06ca1785e62314308efb7d9ffa6e10a40fe48bdd3e31f9f12490a57843ad528685d04ea9ec40cf2203acc0ee0a9fb58ee272837c9a637f44c2716f60de7a SHA512 79cd8718c6d84cdcdcadfcde80368addc095770624806eb8cfa981852c2a8ebcc8074533ec8f8e24b01a3aed241afccb6f49fdce250ae07f630d8596931778e3
diff --git a/dev-python/boto3/boto3-1.34.131.ebuild b/dev-python/boto3/boto3-1.34.131.ebuild
new file mode 100644
index 000000000000..2c733040b7a3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.131.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}