summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 04:24:12 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 04:56:01 -0400
commitc57297b700025083c73cf90a6c9ea0829126f478 (patch)
treef74b8841712442a9dd0202bbcd05ba168eea1625
parentmedia-gfx/xli: pass -std=gnu89 (diff)
downloadgentoo-c57297b700025083c73cf90a6c9ea0829126f478.tar.gz
gentoo-c57297b700025083c73cf90a6c9ea0829126f478.tar.bz2
gentoo-c57297b700025083c73cf90a6c9ea0829126f478.zip
media-radio/ibp: pass -std=gnu89
Does not build with `clang -std=c2x`, early workaround for when this will become a default. (not actively hunting for these, merely revisiting packages previously looked at for clang16 even if not an issue "yet"). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--media-radio/ibp/ibp-0.21-r2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/media-radio/ibp/ibp-0.21-r2.ebuild b/media-radio/ibp/ibp-0.21-r2.ebuild
index 3a9d39772a5e..66da2274b686 100644
--- a/media-radio/ibp/ibp-0.21-r2.ebuild
+++ b/media-radio/ibp/ibp-0.21-r2.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Shows currently transmitting beacons of the International Beacon Project (IBP)"
HOMEPAGE="http://www.pa3fwm.nl/software/ibp/"
@@ -37,6 +37,8 @@ src_prepare() {
}
src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
if use X ;then
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die