summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-18 08:44:51 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-18 09:07:40 +0200
commitc9f35baddc548a2b01733e8f2d3a93ae20f23dd3 (patch)
treeb8da07522f80049cd662ea6798bdece0617b5b64
parentdev-python/httpretty: Bump to 0.9.6 (diff)
downloadgentoo-c9f35baddc548a2b01733e8f2d3a93ae20f23dd3.tar.gz
gentoo-c9f35baddc548a2b01733e8f2d3a93ae20f23dd3.tar.bz2
gentoo-c9f35baddc548a2b01733e8f2d3a93ae20f23dd3.zip
dev-python/PyGithub: Bump to 1.43.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/PyGithub/Manifest1
-rw-r--r--dev-python/PyGithub/PyGithub-1.43.7.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/PyGithub/Manifest b/dev-python/PyGithub/Manifest
index 33f89f18f502..9b0006f08ab3 100644
--- a/dev-python/PyGithub/Manifest
+++ b/dev-python/PyGithub/Manifest
@@ -1,2 +1,3 @@
DIST PyGithub-1.39.tar.gz 2662602 BLAKE2B 5e3e4ca2483e7ade968f170e7615258b4bcca0f1c6741146c38b3c7405fb1fb66351fa5686863892a6751bc4cb6ea39b6cf4ec0d8e6cc878b302c87512c9d159 SHA512 5fa6e5a1b8e7cbe2be13e7f866ce8586f6ba37bfc8f3bfb5a52497a9edc267c14512e4572f56e898c61b8c84dfc8aa8f325c5eb2563e68450b8a3b2acf8308d4
DIST PyGithub-1.40a4.tar.gz 2668409 BLAKE2B 5638f228620fc5c6741f79e3272ba374a71b1a0a9fe3d6f0edd45a7b0468fd4ed1a6fe967d37e6169a4cfc90a3f084c948f0d72592cd225569275a3d8ae3546a SHA512 6d832e2a101a80e2b0aec45a99ec2f28d9d64d130bf23f291a643bc8450a86c4ed9296a005de000c975e28d91d52e648937abb09399554b9d17988fd58f280e7
+DIST PyGithub-1.43.7.gh.tar.gz 2832588 BLAKE2B df1bf783d8644493151b7192325cd2feded48dd95853e0f2ccef9e0560c39877de3e38e95a339291e585612c795d2180900dc5db5fecb0f844a97a6d0a5bf04c SHA512 15d7c7ca6a505a259fe59c96db667a278179df7acfe794116f118bb18966c573cbdcd9276fe50b321fd759988810250a0268c2e8e330c1ef5a8bdcc3a50b6391
diff --git a/dev-python/PyGithub/PyGithub-1.43.7.ebuild b/dev-python/PyGithub/PyGithub-1.43.7.ebuild
new file mode 100644
index 000000000000..5585ba44ef02
--- /dev/null
+++ b/dev-python/PyGithub/PyGithub-1.43.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to access the Github API v3"
+HOMEPAGE="https://github.com/PyGithub/PyGithub/"
+# Use github since pypi is missing test data
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/deprecated[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # tests requiring network access
+ sed -i -e 's:testDecodeJson:_&:' tests/Issue142.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # silly!
+ cp -r tests "${BUILD_DIR}" || die
+ if python_is_python3; then
+ 2to3 --no-diffs -n -w "${BUILD_DIR}"/tests || die
+ fi
+
+ cd "${BUILD_DIR}" || die
+ "${EPYTHON}" -m unittest -v tests.AllTests || die "Tests fail with ${EPYTHON}"
+}