summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-03 17:29:48 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-03 17:35:14 +0200
commitcbc61f76948abe4fb609192525eb7485921ec1ca (patch)
tree41e8c2814eeda7c01a7f996617b4b487c1cf3812
parentapp-misc/spacenavd: 1.3 (diff)
downloadgentoo-cbc61f76948abe4fb609192525eb7485921ec1ca.tar.gz
gentoo-cbc61f76948abe4fb609192525eb7485921ec1ca.tar.bz2
gentoo-cbc61f76948abe4fb609192525eb7485921ec1ca.zip
dev-python/bibtexparser: Bump to 1.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/bibtexparser/Manifest1
-rw-r--r--dev-python/bibtexparser/bibtexparser-1.4.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/bibtexparser/Manifest b/dev-python/bibtexparser/Manifest
index 26ee0e990245..a1b3291cecb1 100644
--- a/dev-python/bibtexparser/Manifest
+++ b/dev-python/bibtexparser/Manifest
@@ -1 +1,2 @@
DIST bibtexparser-1.4.1.gh.tar.gz 97146 BLAKE2B 8040532fe2153ff6ec664631a11b4f61548f99198c565bb554d0fe09d1fa54ee368c08be72bf7e86c5b6ca696deb0210496d4772243a05c5c9b28d73f52e6dc5 SHA512 f8e8f911eac38e98362bbbeff5b4af986e426911db9c54e93ec4a4eee1b1ceed630222c1a51454639566a6b5bad60c86a70b882a1c05084927fcbe7315e837ce
+DIST bibtexparser-1.4.2.gh.tar.gz 81042 BLAKE2B 4522e46c371ae66af933ff6edc3cf1ce37336597c815facd8bbc62cc5b976c66bce45563af18f15a62c5ddf8ddda1bfbfa986eb16f21544aafaef3e22883cf4d SHA512 7aa58cb50c42773b8ae6d0448f817e83cc7445b8e65806430df17f9956219f440116cb227825da3423b40a5815921d1e42e407b236f6e917b3713eee5b8a989b
diff --git a/dev-python/bibtexparser/bibtexparser-1.4.2.ebuild b/dev-python/bibtexparser/bibtexparser-1.4.2.ebuild
new file mode 100644
index 000000000000..b32c01f4d19c
--- /dev/null
+++ b/dev-python/bibtexparser/bibtexparser-1.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A BibTeX parser written in Python"
+HOMEPAGE="
+ https://github.com/sciunto-org/python-bibtexparser/
+ https://pypi.org/project/bibtexparser/
+"
+SRC_URI="
+ https://github.com/sciunto-org/python-bibtexparser/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pylatexenc-2.10[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest