summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-07 21:47:38 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-07 21:56:20 +0200
commitce536c2855117bfdf2a072e49ba1a5627941e481 (patch)
tree5119f03ede0cb2508d01ddb494028d3dbb2c3168
parentdev-util/meson: sync live (diff)
downloadgentoo-ce536c2855117bfdf2a072e49ba1a5627941e481.tar.gz
gentoo-ce536c2855117bfdf2a072e49ba1a5627941e481.tar.bz2
gentoo-ce536c2855117bfdf2a072e49ba1a5627941e481.zip
dev-python/pandas: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pandas/Manifest2
-rw-r--r--dev-python/pandas/files/pandas-0.24.2-skip-broken-test.patch15
-rw-r--r--dev-python/pandas/pandas-0.24.2.ebuild166
-rw-r--r--dev-python/pandas/pandas-1.0.4.ebuild175
4 files changed, 0 insertions, 358 deletions
diff --git a/dev-python/pandas/Manifest b/dev-python/pandas/Manifest
index 61155686962e..8a40c3370c6c 100644
--- a/dev-python/pandas/Manifest
+++ b/dev-python/pandas/Manifest
@@ -1,4 +1,2 @@
-DIST pandas-0.24.2.tar.gz 11837693 BLAKE2B 3762e94554a3ae3c803c9a412c5c551c15a9fbf15cb05633f7d1b0ccbfddc646f68f0306666e688a83a4495b0537cea2fec671157f5a63aaa5f9cad6b791261e SHA512 0795c6bb8a47a511853558ea59d371b4540ec175f213cfba4ad2361d6481fea5d3f7074bb4961c32f2f0080a72d7436a9b3706f5cc692074f98d83bfc587fd15
-DIST pandas-1.0.4.tar.gz 5040267 BLAKE2B 2855b1708e1ae4c56b6118613ec644d010a3af7db474bb30aec3cf84e497371af03b63a2168f6daf0fc42da07274f8724734117c6aaea34f49eeafbf6ac73b9f SHA512 01ef73cab3db067ca4a29992d71aa637425b8d70473fde6ccfb359dfedc9546315c6d37d74f3825c924cab789c2536ec69db071a303cfc5e1a7897b253dd9467
DIST pandas-1.0.5.tar.gz 5007108 BLAKE2B 6aff9602f8b1642af1dca70c7c596f2978bfef8ca9bc782d55aeeab85d3768289849ccd0150291c33cab3442d38cedada91fb846abaade1b3905098edb06c06e SHA512 bb9e3ed9988f7b878ac6f9d7c6c054b119acfc4b960ae42ea92436979ef2098289123cac32b176753942a1edb3b6bd35c4eaf05112a25fbf8a89078fd76a2646
DIST pandas-1.1.0.tar.gz 5211071 BLAKE2B 538e7579384dceb29f1761e00181fda4f07556ee15723a127966e47c317babead19b364943808d11f03007d5a48da3b28bf8fd9e5c1f40bb3285604307bff267 SHA512 496344967e6061ed451edfe2057d0b63d7277cdce0e12e2e2ce558aef2c23fa5d85daae239fcf88820196add3a928734f31af2734866da7b0385f363607e2885
diff --git a/dev-python/pandas/files/pandas-0.24.2-skip-broken-test.patch b/dev-python/pandas/files/pandas-0.24.2-skip-broken-test.patch
deleted file mode 100644
index dcc61dc0cfd2..000000000000
--- a/dev-python/pandas/files/pandas-0.24.2-skip-broken-test.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/pandas/tests/io/json/test_ujson.py b/pandas/tests/io/json/test_ujson.py
-index 63ba9bc0f..854afecab 100644
---- a/pandas/tests/io/json/test_ujson.py
-+++ b/pandas/tests/io/json/test_ujson.py
-@@ -841,7 +841,9 @@ class TestNumpyJSONTests(object):
- arr_out = ujson.decode(ujson.encode(arr), numpy=True, dtype=dtype)
- tm.assert_almost_equal(arr, arr_out)
-
-- def test_0d_array(self):
-+ # Segfaulting on gentoo, not sure why. TODO: find why.
-+ # Clue: https://github.com/pandas-dev/pandas/issues/22718
-+ def xtest_0d_array(self):
- with pytest.raises(TypeError):
- ujson.encode(np.array(1))
-
diff --git a/dev-python/pandas/pandas-0.24.2.ebuild b/dev-python/pandas/pandas-0.24.2.ebuild
deleted file mode 100644
index fd193a5c0249..000000000000
--- a/dev-python/pandas/pandas-0.24.2.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="threads(+)"
-
-VIRTUALX_REQUIRED="manual"
-
-inherit distutils-r1 eutils flag-o-matic virtualx
-
-DESCRIPTION="Powerful data structures for data analysis and statistics"
-HOMEPAGE="https://pandas.pydata.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/_/}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc full-support minimal test X"
-RESTRICT="!test? ( test )"
-
-RECOMMENDED_DEPEND="
- >=dev-python/bottleneck-1.2.1[${PYTHON_USEDEP}]
- >=dev-python/numexpr-2.1[${PYTHON_USEDEP}]
-"
-
-# TODO: add pandas-gbq to the tree
-OPTIONAL_DEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/blosc[${PYTHON_USEDEP}]
- || (
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- )
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- || (
- dev-python/openpyxl[${PYTHON_USEDEP}]
- dev-python/xlsxwriter[${PYTHON_USEDEP}]
- )
- >=dev-python/pytables-3.2.1[${PYTHON_USEDEP}]
- dev-python/s3fs[${PYTHON_USEDEP}]
- dev-python/statsmodels[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-0.8.1[${PYTHON_USEDEP}]
- >=dev-python/xarray-0.10.8[${PYTHON_USEDEP}]
- >=dev-python/xlrd-1.0.0[${PYTHON_USEDEP}]
- dev-python/xlwt[${PYTHON_USEDEP}]
- >=sci-libs/scipy-1.1[${PYTHON_USEDEP}]
- X? (
- || (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- x11-misc/xclip
- x11-misc/xsel
- )
- )
-"
-COMMON_DEPEND="
- >dev-python/numpy-1.13.1[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
-"
-DEPEND="${COMMON_DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- doc? (
- ${VIRTUALX_DEPEND}
- app-text/pandoc
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/nbsphinx[${PYTHON_USEDEP}]
- >=dev-python/numpydoc-0.9.1[${PYTHON_USEDEP}]
- >=dev-python/openpyxl-1.6.1[${PYTHON_USEDEP}]
- >=dev-python/pytables-3.0.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/rpy[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/xlrd[${PYTHON_USEDEP}]
- dev-python/xlwt[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- x11-misc/xclip
- )
- test? (
- ${VIRTUALX_DEPEND}
- ${RECOMMENDED_DEPEND}
- ${OPTIONAL_DEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pymysql[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/psycopg:2[${PYTHON_USEDEP}]
- x11-misc/xclip
- x11-misc/xsel
- )
-"
-# dev-python/statsmodels invokes a circular dep
-# hence rm from doc? ( ), again
-RDEPEND="${COMMON_DEPEND}
- !minimal? ( ${RECOMMENDED_DEPEND} )
- full-support? ( ${OPTIONAL_DEPEND} )
-"
-
-S="${WORKDIR}/${P/_/}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.24.2-skip-broken-test.patch"
-)
-
-python_prepare_all() {
- # Prevent un-needed download during build
- sed -e "/^ 'sphinx.ext.intersphinx',/d" \
- -i doc/source/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # To build docs the need be located in $BUILD_DIR,
- # else PYTHONPATH points to unusable modules.
- if use doc; then
- cd "${BUILD_DIR}"/lib || die
- cp -ar "${S}"/doc . && cd doc || die
- LANG=C PYTHONPATH=. virtx ${EPYTHON} make.py html
- fi
-}
-
-python_test() {
- pushd "${BUILD_DIR}"/lib > /dev/null
- "${EPYTHON}" -c "import pandas; pandas.show_versions()" || die
- PYTHONPATH=. virtx pytest pandas -v --skip-slow --skip-network \
- -m "not single"
- popd > /dev/null
-}
-
-python_install_all() {
- if use doc; then
- dodoc -r "${BUILD_DIR}"/lib/doc/build/html
- einfo "An initial build of docs is absent of references to statsmodels"
- einfo "due to circular dependency. To have them included, emerge"
- einfo "statsmodels next and re-emerge pandas with USE doc"
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
- optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
- optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
- optfeature "for msgpack compression using blosc" dev-python/blosc
- optfeature "necessary for Amazon S3 access" dev-python/s3fs
- optfeature "Template engine for conditional HTML formatting" dev-python/jinja
- optfeature "Plotting support" dev-python/matplotlib
- optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-1.6.1" dev-python/xlsxwriter dev-python/xlrd dev-python/xlwt
- optfeature "necessary for HDF5-based storage" ">=dev-python/pytables-3.2.1"
- optfeature "R I/O support" dev-python/rpy
- optfeature "Needed for parts of pandas.stats" dev-python/statsmodels
- optfeature "SQL database support" ">=dev-python/sqlalchemy-0.8.1"
- optfeature "miscellaneous statistical functions" sci-libs/scipy
- optfeature "necessary to use pandas.io.clipboard.read_clipboard support" dev-python/PyQt5 dev-python/pygtk x11-misc/xclip x11-misc/xsel
-}
diff --git a/dev-python/pandas/pandas-1.0.4.ebuild b/dev-python/pandas/pandas-1.0.4.ebuild
deleted file mode 100644
index 3fb89871d2a7..000000000000
--- a/dev-python/pandas/pandas-1.0.4.ebuild
+++ /dev/null
@@ -1,175 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-PYTHON_REQ_USE="threads(+)"
-
-VIRTUALX_REQUIRED="manual"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 eutils flag-o-matic virtualx
-
-DESCRIPTION="Powerful data structures for data analysis and statistics"
-HOMEPAGE="https://pandas.pydata.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/_/}.tar.gz"
-S="${WORKDIR}/${P/_/}"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 ~x86"
-IUSE="doc full-support minimal test X"
-RESTRICT="!test? ( test )"
-
-RECOMMENDED_DEPEND="
- >=dev-python/bottleneck-1.2.1[${PYTHON_USEDEP}]
- >=dev-python/numexpr-2.1[${PYTHON_USEDEP}]
-"
-
-# TODO: add pandas-gbq to the tree
-OPTIONAL_DEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/blosc[${PYTHON_USEDEP}]
- || (
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- )
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- || (
- dev-python/openpyxl[${PYTHON_USEDEP}]
- dev-python/xlsxwriter[${PYTHON_USEDEP}]
- )
- >=dev-python/pytables-3.2.1[${PYTHON_USEDEP}]
- dev-python/s3fs[${PYTHON_USEDEP}]
- dev-python/statsmodels[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/xarray-0.10.8[${PYTHON_USEDEP}]
- ' python3_{6,7})
- >=dev-python/sqlalchemy-0.8.1[${PYTHON_USEDEP}]
- >=dev-python/xlrd-1.0.0[${PYTHON_USEDEP}]
- dev-python/xlwt[${PYTHON_USEDEP}]
- >=sci-libs/scipy-1.1[${PYTHON_USEDEP}]
- X? (
- || (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- x11-misc/xclip
- x11-misc/xsel
- )
- )
-"
-COMMON_DEPEND="
- >dev-python/numpy-1.13.1[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
-"
-DEPEND="${COMMON_DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/cython-0.29.20-r1[${PYTHON_USEDEP}]
- doc? (
- ${VIRTUALX_DEPEND}
- app-text/pandoc
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/nbsphinx[${PYTHON_USEDEP}]
- >=dev-python/numpydoc-0.9.1[${PYTHON_USEDEP}]
- >=dev-python/openpyxl-1.6.1[${PYTHON_USEDEP}]
- >=dev-python/pytables-3.0.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/rpy[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/xlrd[${PYTHON_USEDEP}]
- dev-python/xlwt[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- x11-misc/xclip
- )
- test? (
- ${VIRTUALX_DEPEND}
- ${RECOMMENDED_DEPEND}
- ${OPTIONAL_DEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pymysql[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/psycopg:2[${PYTHON_USEDEP}]
- x11-misc/xclip
- x11-misc/xsel
- )
-"
-# dev-python/statsmodels invokes a circular dep
-# hence rm from doc? ( ), again
-RDEPEND="${COMMON_DEPEND}
- !minimal? ( ${RECOMMENDED_DEPEND} )
- full-support? ( ${OPTIONAL_DEPEND} )
-"
-
-python_prepare_all() {
- # Prevent un-needed download during build
- sed -e "/^ 'sphinx.ext.intersphinx',/d" \
- -i doc/source/conf.py || die
-
- # requires package installed
- sed -e 's:test_register_entrypoint:_&:' \
- -i pandas/tests/plotting/test_backend.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # To build docs the need be located in $BUILD_DIR,
- # else PYTHONPATH points to unusable modules.
- if use doc; then
- cd "${BUILD_DIR}"/lib || die
- cp -ar "${S}"/doc . && cd doc || die
- LANG=C PYTHONPATH=. virtx ${EPYTHON} make.py html
- fi
-}
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- local -x LC_ALL=C.UTF-8
- pushd "${BUILD_DIR}"/lib > /dev/null || die
- "${EPYTHON}" -c "import pandas; pandas.show_versions()" || die
- PYTHONPATH=. pytest pandas -v --skip-slow --skip-network \
- -m "not single" || die "Tests failed with ${EPYTHON}"
- find . '(' -name .pytest_cache -o -name .hypothesis ')' \
- -exec rm -r {} + || die
- popd > /dev/null || die
-}
-
-python_install_all() {
- if use doc; then
- dodoc -r "${BUILD_DIR}"/lib/doc/build/html
- einfo "An initial build of docs is absent of references to statsmodels"
- einfo "due to circular dependency. To have them included, emerge"
- einfo "statsmodels next and re-emerge pandas with USE doc"
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
- optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
- optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
- optfeature "for msgpack compression using blosc" dev-python/blosc
- optfeature "necessary for Amazon S3 access" dev-python/s3fs
- optfeature "Template engine for conditional HTML formatting" dev-python/jinja
- optfeature "Plotting support" dev-python/matplotlib
- optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-1.6.1" dev-python/xlsxwriter dev-python/xlrd dev-python/xlwt
- optfeature "necessary for HDF5-based storage" ">=dev-python/pytables-3.2.1"
- optfeature "R I/O support" dev-python/rpy
- optfeature "Needed for parts of pandas.stats" dev-python/statsmodels
- optfeature "SQL database support" ">=dev-python/sqlalchemy-0.8.1"
- optfeature "miscellaneous statistical functions" sci-libs/scipy
- optfeature "necessary to use pandas.io.clipboard.read_clipboard support" dev-python/PyQt5 dev-python/pygtk x11-misc/xclip x11-misc/xsel
-}