summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-12 14:02:13 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-12 14:04:06 +0200
commitcf2e4eb2cad25a7b4647faebe6509c1033b49ba8 (patch)
tree543860d7c802b373d1e90417d47f798fc8aa9aa6
parentsys-kernel/linux-firmware: stabilize 20230625 (diff)
downloadgentoo-cf2e4eb2cad25a7b4647faebe6509c1033b49ba8.tar.gz
gentoo-cf2e4eb2cad25a7b4647faebe6509c1033b49ba8.tar.bz2
gentoo-cf2e4eb2cad25a7b4647faebe6509c1033b49ba8.zip
sci-libs/linux-gpib-modules: add small patch for kernel 6.4
Closes: https://bugs.gentoo.org/910230 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.3.4-kernel-6.4.patch27
-rw-r--r--sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.5-r3.ebuild (renamed from sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.5-r2.ebuild)2
2 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.3.4-kernel-6.4.patch b/sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.3.4-kernel-6.4.patch
new file mode 100644
index 000000000000..90112106584d
--- /dev/null
+++ b/sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.3.4-kernel-6.4.patch
@@ -0,0 +1,27 @@
+--- linux-gpib-kernel/compat/include/linux/device.h (revision 2052)
++++ linux-gpib-kernel/compat/include/linux/device.h (revision 2053)
+@@ -47,6 +47,13 @@
+ * for kernel versions prior to 2.6.26, so the 'drvdata' parameter of
+ * CLASS_DEVICE_CREATE() is pretty useless.
+ */
++#if LINUX_VERSION_CODE < KERNEL_VERSION(6,4,0)
++#define CLASS_CREATE(owner, name) \
++ class_create(owner, name)
++#else
++#define CLASS_CREATE(owner, name) \
++ class_create(name)
++#endif
+
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2,5,0)
+ #include <pcmcia/cs_types.h>
+--- linux-gpib-kernel/drivers/gpib/sys/osinit.c (revision 2052)
++++ linux-gpib-kernel/drivers/gpib/sys/osinit.c (revision 2053)
+@@ -207,7 +207,7 @@
+ printk( "gpib: can't get major %d\n", GPIB_CODE );
+ return -EIO;
+ }
+- gpib_class = class_create(THIS_MODULE, "gpib_common");
++ gpib_class = CLASS_CREATE(THIS_MODULE, "gpib_common");
+ if(IS_ERR(gpib_class))
+ {
+ printk("gpib: failed to create gpib class\n");
diff --git a/sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.5-r2.ebuild b/sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.5-r3.ebuild
index 7be607ff4d47..0736e0159f4d 100644
--- a/sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.5-r2.ebuild
+++ b/sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.5-r3.ebuild
@@ -25,6 +25,8 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
# don't fix debian bugs if they break gentoo
"${FILESDIR}/${PN}-4.3.4-depmod.patch"
+ # https://sourceforge.net/p/linux-gpib/code/2053/
+ "${FILESDIR}/${PN}-4.3.4-kernel-6.4.patch"
)
MODULES_KERNEL_MIN=2.6.8