summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-10-26 00:47:03 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-10-26 00:47:03 +0000
commite37d357ab8bcd303bd284a711d5290ec99d2fe42 (patch)
tree65339f60afdcc2f03ccbf270d30895ed4951a44e
parent2023-10-25 22:46:59 UTC (diff)
parentcmake.eclass: do not mention media-gfx/gmic in comments, it no longer uses CMake (diff)
downloadgentoo-e37d357ab8bcd303bd284a711d5290ec99d2fe42.tar.gz
gentoo-e37d357ab8bcd303bd284a711d5290ec99d2fe42.tar.bz2
gentoo-e37d357ab8bcd303bd284a711d5290ec99d2fe42.zip
Merge updates from master
-rw-r--r--app-emulation/protontricks/Manifest1
-rw-r--r--app-emulation/protontricks/protontricks-1.10.5.ebuild58
-rw-r--r--dev-python/griffe/Manifest5
-rw-r--r--dev-python/griffe/griffe-0.36.5.ebuild45
-rw-r--r--dev-python/griffe/griffe-0.36.6.ebuild45
-rw-r--r--dev-python/griffe/griffe-0.36.7.ebuild45
-rw-r--r--dev-python/griffe/griffe-0.36.8.ebuild (renamed from dev-python/griffe/griffe-0.36.2.ebuild)0
-rw-r--r--dev-python/mkdocs-ansible/Manifest1
-rw-r--r--dev-python/mkdocs-ansible/files/mkdocs-ansible-0.2.0-prune_deps.patch20
-rw-r--r--dev-python/mkdocs-ansible/mkdocs-ansible-0.2.0.ebuild41
-rw-r--r--dev-python/mkdocs-autorefs/mkdocs-autorefs-0.5.0.ebuild2
-rw-r--r--dev-python/mkdocs-gen-files/mkdocs-gen-files-0.5.0.ebuild2
-rw-r--r--dev-python/mkdocs-htmlproofer-plugin/mkdocs-htmlproofer-plugin-1.0.0.ebuild2
-rw-r--r--dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.0.5.ebuild2
-rw-r--r--dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild5
-rw-r--r--dev-python/pyopencl/Manifest1
-rw-r--r--dev-python/pyopencl/pyopencl-2023.1.4.ebuild72
-rw-r--r--dev-python/python-rtmidi/Manifest1
-rw-r--r--dev-python/python-rtmidi/python-rtmidi-1.5.7.ebuild60
-rw-r--r--dev-vcs/pre-commit/Manifest1
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.5.0.ebuild58
-rw-r--r--eclass/cmake.eclass2
-rw-r--r--media-gfx/gmic/Manifest1
-rw-r--r--media-gfx/gmic/gmic-3.3.1.ebuild140
24 files changed, 465 insertions, 145 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index ac15507ba590..8b98ae43195a 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1 +1,2 @@
DIST protontricks-1.10.3.tar.gz 162698 BLAKE2B 7e3f696f3589a4a92d2cc6132132546bc0c38a5110d688cd486c2d52bd37275b8df4085edc38d4876583aa0d5ec0a9de599ca05616bf92812decf624e2259406 SHA512 c389a712bcbb9dace8e6b3fa10ddb9db0a67abbd3b8d000d312fd59bb682aa68c10d5411b10b31948967536418e56116ac435054ff6d6999bc471ba2a97ca6ba
+DIST protontricks-1.10.5.tar.gz 163931 BLAKE2B 299fd6c77460de3d2fa1b585a1ad3dae857e4b78898c753007b358cc25b82918d33cb31c2028a4b1b562ee6c20b95ebafc532d97e2bc1fa5358464c6a4c1da5c SHA512 305b27ceaf428946a0ed09994173c861da1097c0bd21eebcc8b255bed3c4c50a920f0cc422601fbd44e0af373b71e928096fdd6f4cc2aa05c88126212fb4401f
diff --git a/app-emulation/protontricks/protontricks-1.10.5.ebuild b/app-emulation/protontricks/protontricks-1.10.5.ebuild
new file mode 100644
index 000000000000..cbecf711b3cf
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.10.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index ef87a5f2b250..7a0c1c0c9e84 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1,5 +1,2 @@
-DIST griffe-0.36.2.gh.tar.gz 188707 BLAKE2B b444dcbb38ab39715f975a17f502cf331bb3385b287f30bd66115bd7c565b248d1bce45ca80167ab5da0a59f8f73e41f63c4114f0f02029a56b735c0aa9c36d7 SHA512 1ec7efaf8b2c030b7c33ddb41a04e927fdd8678061a7ccbcd632c17d9fd80c664320be5ac0c9f05340358835dd430b6082b770c849fc2ed3c3266f65474da92d
DIST griffe-0.36.4.gh.tar.gz 192823 BLAKE2B 42815673835bffebf97ab3bd436997329229596d24f4cd6fcd0b57f137b113bd42461cf9b8a33472ef6887dc7efdb4d88f31b6f503abb365f101311ff89fb5f3 SHA512 76d672f91643d347d15e97eb29bd1cdb24f843d396777287d5f5c28259f4f25dc7a89d53a83189e84572fcbed5201144d2b15f1bbc0864799c7703ce90b1cc7a
-DIST griffe-0.36.5.gh.tar.gz 193265 BLAKE2B f8727c42b0a5527fcc5d8fafcf1e16e3b4cae516db5f3a5ba790c068e5d1520c50a8cd467d40d12bce9d4793d94aabb67148ff79c81f58fcc5711e1e4c9345ce SHA512 e1ed6c2ece246b1583a18df30151186a605e02d4ad19748c9c4ccd6bf2e47fa493d2cf4b37ca5fa3f91c4c3c3927b034f92a344a9f9601b516673ccf3e7906f1
-DIST griffe-0.36.6.gh.tar.gz 193375 BLAKE2B 12760d8892226162536afa15a7bba2076ddc22f606272d71ece261ae0b2b5306fdde2cfe3e163607da63f80d52414e46f16f40058716382bff0eab431c8c2c9b SHA512 627524403a0d5157bb0c5287e629e7e489ed624a29d25d4d32f0bbb607391249efabe7c0793ef2ef590a79f2dc0ac52d86ab110d99c4fac4c70af26ec81da020
-DIST griffe-0.36.7.gh.tar.gz 193857 BLAKE2B 5208cf313c8137441bb256c06093383fa259952d0978bd1e2658920c55703eb4d576a01888f746705e9d82d1d328bd5f1e49cc0d8f4fc83836080d6356241348 SHA512 e3bffd19925db7113bbcd5339cedccb444ed682d07b7d03941525c373b1ab34074ae11279b17429c9ce6f411b5be985ce88ad8408099a569dd9f7b5b85e74fd2
+DIST griffe-0.36.8.gh.tar.gz 194133 BLAKE2B 6fb1f38e3f9da452ba79253ed3786ec29d96bf208bd17f3920fcfff6dd0bc0fda39c26dca28ab07736dd64481137b0f4aa7d058b94d0815fddff0bcf8cf6cfc9 SHA512 bde9bd8313f4c5ff4617cc1f6edcb754a445366e2f03cb8b1126e13ab644c700ccab4fe6ebfed163a4da046ec729d3b2fe79b89d6d17b8c5446c198535795294
diff --git a/dev-python/griffe/griffe-0.36.5.ebuild b/dev-python/griffe/griffe-0.36.5.ebuild
deleted file mode 100644
index c8d57610c9ff..000000000000
--- a/dev-python/griffe/griffe-0.36.5.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=pdm-backend
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Signature generator for Python programs"
-HOMEPAGE="
- https://mkdocstrings.github.io/griffe/
- https://github.com/mkdocstrings/griffe/
- https://pypi.org/project/griffe/
-"
-# Tests need files absent from the PyPI tarballs
-SRC_URI="
- https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-RDEPEND="
- >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/jsonschema-4.17.3[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export PDM_BUILD_SCM_VERSION=${PV}
-
-EPYTEST_DESELECT=(
- # fragile to installed packages
- # (failed on PySide2 for me)
- tests/test_stdlib.py::test_fuzzing_on_stdlib
-)
diff --git a/dev-python/griffe/griffe-0.36.6.ebuild b/dev-python/griffe/griffe-0.36.6.ebuild
deleted file mode 100644
index c8d57610c9ff..000000000000
--- a/dev-python/griffe/griffe-0.36.6.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=pdm-backend
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Signature generator for Python programs"
-HOMEPAGE="
- https://mkdocstrings.github.io/griffe/
- https://github.com/mkdocstrings/griffe/
- https://pypi.org/project/griffe/
-"
-# Tests need files absent from the PyPI tarballs
-SRC_URI="
- https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-RDEPEND="
- >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/jsonschema-4.17.3[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export PDM_BUILD_SCM_VERSION=${PV}
-
-EPYTEST_DESELECT=(
- # fragile to installed packages
- # (failed on PySide2 for me)
- tests/test_stdlib.py::test_fuzzing_on_stdlib
-)
diff --git a/dev-python/griffe/griffe-0.36.7.ebuild b/dev-python/griffe/griffe-0.36.7.ebuild
deleted file mode 100644
index c8d57610c9ff..000000000000
--- a/dev-python/griffe/griffe-0.36.7.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=pdm-backend
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Signature generator for Python programs"
-HOMEPAGE="
- https://mkdocstrings.github.io/griffe/
- https://github.com/mkdocstrings/griffe/
- https://pypi.org/project/griffe/
-"
-# Tests need files absent from the PyPI tarballs
-SRC_URI="
- https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-RDEPEND="
- >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/jsonschema-4.17.3[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export PDM_BUILD_SCM_VERSION=${PV}
-
-EPYTEST_DESELECT=(
- # fragile to installed packages
- # (failed on PySide2 for me)
- tests/test_stdlib.py::test_fuzzing_on_stdlib
-)
diff --git a/dev-python/griffe/griffe-0.36.2.ebuild b/dev-python/griffe/griffe-0.36.8.ebuild
index c8d57610c9ff..c8d57610c9ff 100644
--- a/dev-python/griffe/griffe-0.36.2.ebuild
+++ b/dev-python/griffe/griffe-0.36.8.ebuild
diff --git a/dev-python/mkdocs-ansible/Manifest b/dev-python/mkdocs-ansible/Manifest
index 1a4462623a87..9e21c7f1d379 100644
--- a/dev-python/mkdocs-ansible/Manifest
+++ b/dev-python/mkdocs-ansible/Manifest
@@ -1 +1,2 @@
DIST mkdocs-ansible-0.1.6.tar.gz 27829 BLAKE2B ee1248c2301d841876abfde43e0a883d553f7848b9be367634c4332ceccff4f9aa5e22b58c38f997ffc9c861ac36a0b9e40e4ca445aff7dc040f953f83f3fab8 SHA512 96235bc91d86e52781ae190ab6bc83fc086fa5fdd2ecb21a544549bd49d94b0ea99e56956442884930a6d20c975970942ca3bc0c62cee23b17a3884989420672
+DIST mkdocs-ansible-0.2.0.tar.gz 29254 BLAKE2B 3d9582c50a3e6abad56bae2f78ff2970b96b768fd8dbc0aa60d15a0acfc23535acae42b7b7f585db3165bf658b3f18c483484b630b350aff97ebb97edb2abcae SHA512 8e0a3b447a4a31f3d48fef5e381d01e0f2ebee2dd317a699b30e83e483234ebac1ad265f66f15dfa92c52f6c1c4a0a77aacef2915b0a60b11ffe5960cd774820
diff --git a/dev-python/mkdocs-ansible/files/mkdocs-ansible-0.2.0-prune_deps.patch b/dev-python/mkdocs-ansible/files/mkdocs-ansible-0.2.0-prune_deps.patch
new file mode 100644
index 000000000000..7c8c5cbfe590
--- /dev/null
+++ b/dev-python/mkdocs-ansible/files/mkdocs-ansible-0.2.0-prune_deps.patch
@@ -0,0 +1,20 @@
+As of 0.2.0, no mention of pipdeptree anywhere in the actual code.
+
+--- a/.config/requirements.in
++++ b/.config/requirements.in
+@@ -11,5 +11,4 @@
+ mkdocstrings-python>=0.8.3
+ mkdocstrings>=0.21.2
+ pillow>=9.4.0
+-pipdeptree>=2.4.0
+ pymdown-extensions>=9.9.2
+--- a/.config/requirements.txt
++++ b/.config/requirements.txt
+@@ -42,7 +42,6 @@
+ paginate==0.5.6
+ pathspec==0.11.2
+ pillow==10.0.1
+-pipdeptree==2.13.0
+ platformdirs==3.10.0
+ pycparser==2.21
+ pygments==2.16.1
diff --git a/dev-python/mkdocs-ansible/mkdocs-ansible-0.2.0.ebuild b/dev-python/mkdocs-ansible/mkdocs-ansible-0.2.0.ebuild
new file mode 100644
index 000000000000..ea46f6f62663
--- /dev/null
+++ b/dev-python/mkdocs-ansible/mkdocs-ansible-0.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Ansible theme for MkDocs"
+HOMEPAGE="
+ https://github.com/ansible/mkdocs-ansible/
+ https://pypi.org/project/mkdocs-ansible/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/markdown-exec-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/markdown-include-0.8.1[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-gen-files-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-htmlproofer-plugin-0.10.2[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-material-extensions-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-material-9.0.13[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-minify-plugin-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-monorepo-plugin-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/mkdocstrings-python-0.8.3[${PYTHON_USEDEP}]
+ >=dev-python/mkdocstrings-0.21.2[${PYTHON_USEDEP}]
+ >=dev-python/pillow-9.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pymdown-extensions-9.9.2[${PYTHON_USEDEP}]
+ >=media-gfx/cairosvg-2.6.0[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.0-prune_deps.patch
+)
diff --git a/dev-python/mkdocs-autorefs/mkdocs-autorefs-0.5.0.ebuild b/dev-python/mkdocs-autorefs/mkdocs-autorefs-0.5.0.ebuild
index 1d118aaad2ac..8b0ef8e59cce 100644
--- a/dev-python/mkdocs-autorefs/mkdocs-autorefs-0.5.0.ebuild
+++ b/dev-python/mkdocs-autorefs/mkdocs-autorefs-0.5.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=pdm-backend
inherit distutils-r1 pypi
diff --git a/dev-python/mkdocs-gen-files/mkdocs-gen-files-0.5.0.ebuild b/dev-python/mkdocs-gen-files/mkdocs-gen-files-0.5.0.ebuild
index 732770910ba6..25d8ef6aa343 100644
--- a/dev-python/mkdocs-gen-files/mkdocs-gen-files-0.5.0.ebuild
+++ b/dev-python/mkdocs-gen-files/mkdocs-gen-files-0.5.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
diff --git a/dev-python/mkdocs-htmlproofer-plugin/mkdocs-htmlproofer-plugin-1.0.0.ebuild b/dev-python/mkdocs-htmlproofer-plugin/mkdocs-htmlproofer-plugin-1.0.0.ebuild
index 85312274c15f..829d351767c7 100644
--- a/dev-python/mkdocs-htmlproofer-plugin/mkdocs-htmlproofer-plugin-1.0.0.ebuild
+++ b/dev-python/mkdocs-htmlproofer-plugin/mkdocs-htmlproofer-plugin-1.0.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
diff --git a/dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.0.5.ebuild b/dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.0.5.ebuild
index 578a81810428..88c96750c18c 100644
--- a/dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.0.5.ebuild
+++ b/dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.0.5.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
diff --git a/dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild b/dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild
index 1f12e1c46f72..0e8648a7cba5 100644
--- a/dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild
+++ b/dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+# py3.12 blocked by mkdocs-material
DISTUTILS_USE_PEP517=pdm-backend
PYTHON_COMPAT=( python3_{10..11} )
@@ -34,8 +35,10 @@ RDEPEND="
"
BDEPEND="
test? (
+ dev-python/markdown-exec[${PYTHON_USEDEP}]
dev-python/mkdocs-material[${PYTHON_USEDEP}]
dev-python/mkdocstrings-python[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
)
"
@@ -46,7 +49,7 @@ EPYTEST_DESELECT=(
tests/test_plugin.py::test_disabling_plugin
# WTF, it tries to unlink installed files from installed package?!
tests/test_handlers.py::test_extended_templates
- # TODO: package markdown-exec
+ # Needs unpackaged mkdocs-callouts, mkdocs-literate-nav, and possibly more
tests/test_inventory.py::test_sphinx_load_mkdocstrings_inventory_file
# Internet
tests/test_inventory.py::test_load_inventory
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index f3b617ad6322..d9ab93703370 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1 +1,2 @@
DIST pyopencl-2023.1.2.tar.gz 473684 BLAKE2B 3912885395df515f3e935149c0bac618c371b75791ac670d1a2cd25ffe5e3ff1c4d0e82d8a475e26d3280aaa659d900ed7df66b3f6952f54266d3cd2ad3b44c2 SHA512 3414b011f0bd0420df4725904b715d54bad0ae77cb4b8619d8d769cd25b56d44a8d34788c23de80b5da5ae757f38231db980f3abcb2544117b7be7627592bf0e
+DIST pyopencl-2023.1.4.tar.gz 473899 BLAKE2B 7d836d77b14f89b6dbf0dd2a189f3cb9442f224ff5c9c9db902aa93dc582278450b3d47576885bbe3738ee25f979a260d5c6f906366279adc30be7d3cc3545e1 SHA512 2508d21856d9b846bce14bcd11d007eedddc1cc5c1ce9f8d2ac18743ab9aa5d673c85792b535779b2f414caf47e39ed53c07d7ee8a061bcfa020a15f59463861
diff --git a/dev-python/pyopencl/pyopencl-2023.1.4.ebuild b/dev-python/pyopencl/pyopencl-2023.1.4.ebuild
new file mode 100644
index 000000000000..2e70bde9cbd6
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2023.1.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="
+ https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv"
+IUSE="examples opengl"
+
+# Running tests on GPUs requires both appropriate hardware and additional permissions
+# having been granted to the user running them. Testing on CPUs with dev-libs/pocl
+# is in theory possible but has been found to be very fragile, see e.g. Bug #872308.
+RESTRICT="test"
+
+COMMON=">=virtual/opencl-2"
+# libglvnd is only needed for the headers
+DEPEND="${COMMON}
+ opengl? ( media-libs/libglvnd )"
+RDEPEND="${COMMON}
+ >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
+ test? ( dev-libs/pocl )"
+
+distutils_enable_tests pytest
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_test() {
+ # Use dev-libs/pocl for testing; ignore any other OpenCL devices that might be present
+ local -x PYOPENCL_TEST="portable:pthread"
+ # Set the number of threads to match MAKEOPTS
+ local -x POCL_MAX_PTHREAD_COUNT=$(makeopts_jobs)
+ # Change to the 'test' directory so that python does not try to import pyopencl from the source directory
+ # (Importing from the source directory fails, because the compiled '_cl' module is only in the build directory)
+ pushd test >/dev/null || die
+ epytest
+ popd >/dev/null || die
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/python-rtmidi/Manifest b/dev-python/python-rtmidi/Manifest
index b9c0daf749fc..07f779f6b915 100644
--- a/dev-python/python-rtmidi/Manifest
+++ b/dev-python/python-rtmidi/Manifest
@@ -1 +1,2 @@
DIST python_rtmidi-1.5.6.tar.gz 367355 BLAKE2B c544669f51e12e82fe38b68e83078ac01463fcff54941c52fad80a1dd3d55985352dea259bad5ba2f70a895a80d5ad55c0249f9ef6fe4e7b81b84582a5855ef8 SHA512 e834159b07fb0b2d05a511ccd2d5b2a86d25f7b0d3a2b92ebe73edf28cd2a035a7aea0460adc6cf6836535da2815ccc0f986731bc9a23bbb19bc7d559d0ef955
+DIST python_rtmidi-1.5.7.tar.gz 368514 BLAKE2B 32028dff34928b1794cc178b22821fe8e01bff36d18b17b8673c763b21ca7ef85a6cb3ee62adcddbaf0b655079e7b8819ba5a28e58b8d5713015728cd6648246 SHA512 23c88cd307b5bc937920db9b39d0423043fb47878d679f4d721a025368a01e23b8e72749e1146da3277d37a20a9c5486e2c40c2a907c5efc5418567e97c3de91
diff --git a/dev-python/python-rtmidi/python-rtmidi-1.5.7.ebuild b/dev-python/python-rtmidi/python-rtmidi-1.5.7.ebuild
new file mode 100644
index 000000000000..18e140eddb8a
--- /dev/null
+++ b/dev-python/python-rtmidi/python-rtmidi-1.5.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DOCS_BUILDER="sphinx"
+DOCS_DEPEND="dev-python/myst-parser"
+DOCS_DIR="docs"
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+
+inherit distutils-r1 docs pypi
+
+DESCRIPTION="Python bindings for media-libs/rtmidi implemented using Cython"
+HOMEPAGE="
+ https://pypi.org/project/python-rtmidi/
+ https://spotlightkid.github.io/python-rtmidi/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+alsa jack"
+
+# Most of these tests do not play nicely with the sandbox, some only
+# work with exactly the same version of rtmidi as the bundled one, and
+# several fail even with disabled sandbox unless there are actual MIDI
+# I/O devices present.
+RESTRICT="test"
+
+DEPEND="media-libs/rtmidi[alsa?,jack?]"
+RDEPEND="${DEPEND}"
+BDEPEND="<dev-python/cython-2.99[${PYTHON_USEDEP}]
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-unbundle_rtmidi.patch
+)
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Just in case
+ rm -r src/rtmidi || die
+ rm src/_rtmidi.cpp || die
+
+ # Needed by USE=doc because documentation generation happens in ${S}
+ # but the version.py generated by Meson end up in respective ${BUILD_DIR}s.
+ # The version put in ${S} should be ignored by everything except Sphinx but
+ # just in case, be consistent and generate it unconditionally.
+ sed -e "s|@VERSION@|${PV}|" < rtmidi/version.py.in > rtmidi/version.py || die
+}
+
+python_test() {
+ cd "${T}" || die
+ eunittest "${S}"/tests
+}
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 1ce7141a1a0d..ce5941212686 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1 +1,2 @@
DIST pre-commit-3.3.3.gh.tar.gz 267281 BLAKE2B dbe3b90dd3808d24084ede3e9bd76ddc5b070d43bd70b3fa813f8e8e95875a178b86632208463c50a3d68868f2dd9d888e00e7bf3aeba3f3b78c7cd39b514270 SHA512 d126bead7ffa2c72213a894c82bc45d0bce8b508cf7190e7b7d56c667b5d3ebff80eedf7ecb4bb1e01923ef9a43878b73356fda866614d8cbcc8f241ee9e01f7
+DIST pre-commit-3.5.0.gh.tar.gz 268906 BLAKE2B 7585aae950f63845cf132b3472662f19f87942b886687551fbf69e4adb20513304d2c4d399c12619e6c7f9aeab0a6a57c3fe3cd271a29470bedc9480b3b34256 SHA512 c7504fa2d3ba70def3361af0fcc2f7a5454325125e27f44fbaa60906f1ac35b0fa1b646eaf326cb04d4d042ecb6786fbb8e9166099df1e687fa2a64a8113c244
diff --git a/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild b/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild
new file mode 100644
index 000000000000..e6d46da41754
--- /dev/null
+++ b/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# py3.12 blocked by nodeenv
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
+HOMEPAGE="https://pre-commit.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-vcs/git
+ $(python_gen_cond_dep '
+ >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
+ ')"
+# coreutils requirement: see Bug #885559
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+ sys-apps/coreutils[-multicall]
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.1-tests_git_file_transport.patch
+)
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
+# and while some of them do include "skip if not found" logic, most of them do not.
+# The latter consistently fail with
+# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
+# including with the sandbox disabled.
+EPYTEST_DESELECT=(
+ tests/languages/
+ tests/repository_test.py
+ tests/main_test.py::test_all_cmds
+ tests/main_test.py::test_hook_stage_migration
+ tests/main_test.py::test_try_repo
+)
+
+distutils_enable_tests pytest
diff --git a/eclass/cmake.eclass b/eclass/cmake.eclass
index bbab6a8af1ff..10749e9a2f31 100644
--- a/eclass/cmake.eclass
+++ b/eclass/cmake.eclass
@@ -364,7 +364,7 @@ cmake_src_prepare() {
if [[ ${EAPI} == 7 ]]; then
pushd "${S}" > /dev/null || die # workaround from cmake-utils
# in EAPI-8, we use current working directory instead, bug #704524
- # esp. test with 'special' pkgs like: app-arch/brotli, media-gfx/gmic, net-libs/quiche
+ # esp. test with 'special' pkgs like: app-arch/brotli, net-libs/quiche
fi
_cmake_check_build_dir
diff --git a/media-gfx/gmic/Manifest b/media-gfx/gmic/Manifest
index 05b82272c3e9..25fea17dcfce 100644
--- a/media-gfx/gmic/Manifest
+++ b/media-gfx/gmic/Manifest
@@ -1 +1,2 @@
DIST gmic_3.2.6.tar.gz 11574989 BLAKE2B abd33048a448ca8406169c61a9d97bf6e785cbb286cec1d5104f12960640de9eb292677256c074eee5371fa77ed7041671f77a63140c2fa58070c01404962be6 SHA512 26b222c94d68273a8ad4a0c72dca315cb0e17695e601f69cb06d44c49166b8c1050926b8c5d73d21a64613e6ba3b0462e730617db83d2c67b53674bf22e50395
+DIST gmic_3.3.1.tar.gz 18983077 BLAKE2B 1020168de6a80db4998d5f37a28f680a90cac6b0c7b91f3300105c4fdffc88df5517f4ff6439895f9bab91c27deea3436988b3e41c7a9e3b4d7dba6a69e8a552 SHA512 b31c3eac083e280203eb4651a22ed4d49d1b46e8a5a81400bb8cbb9bdd87cb1226f9017b7a1e52d493fbed38a580238c6242b033162213c32316d852ad0f90c5
diff --git a/media-gfx/gmic/gmic-3.3.1.ebuild b/media-gfx/gmic/gmic-3.3.1.ebuild
new file mode 100644
index 000000000000..6987b6673d70
--- /dev/null
+++ b/media-gfx/gmic/gmic-3.3.1.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="GREYC's Magic Image Converter"
+HOMEPAGE="https://gmic.eu/ https://github.com/GreycLab/gmic"
+SRC_URI="https://gmic.eu/files/source/${PN}_${PV}.tar.gz"
+
+LICENSE="CeCILL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="cli curl ffmpeg fftw gimp graphicsmagick jpeg opencv openexr openmp png qt5 tiff X"
+
+REQUIRED_USE="
+ gimp? ( png fftw X )
+ qt5? ( png fftw X )
+"
+
+MIN_QT_VER="5.2.0"
+QT_DEPEND="
+ >=dev-qt/qtcore-${MIN_QT_VER}:5
+ >=dev-qt/qtgui-${MIN_QT_VER}:5
+ >=dev-qt/qtnetwork-${MIN_QT_VER}:5
+ >=dev-qt/qtwidgets-${MIN_QT_VER}:5
+"
+DEPEND="
+ sys-libs/zlib:0=
+ curl? ( net-misc/curl )
+ fftw? ( sci-libs/fftw:3.0=[threads] )
+ gimp? (
+ media-gfx/gimp:0/2
+ ${QT_DEPEND}
+ )
+ graphicsmagick? ( media-gfx/graphicsmagick:= )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ opencv? ( >=media-libs/opencv-2.3.1a-r1:= )
+ openexr? (
+ dev-libs/imath:=
+ media-libs/openexr:=
+ )
+ png? ( media-libs/libpng:= )
+ qt5? ( ${QT_DEPEND} )
+ tiff? ( media-libs/tiff:= )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )"
+RDEPEND="${DEPEND}
+ ffmpeg? ( media-video/ffmpeg:= )
+"
+BDEPEND="
+ virtual/pkgconfig
+ gimp? (
+ dev-qt/linguist-tools:5
+ media-gfx/gimp:0/2
+ )
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.6-ar_so.patch
+ "${FILESDIR}"/${PN}-3.2.0-grep38.patch
+ "${FILESDIR}"/${PN}-3.2.4-makefile_automagic.patch
+ "${FILESDIR}"/${PN}-3.2.5-relative_rpath.patch
+ "${FILESDIR}"/${PN}-3.2.6-makefile_target_deps.patch
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+gmic_emake() {
+ local mymakeargs=(
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ STRIP="/bin/true"
+ LIB="$(get_libdir)"
+ OPT_CFLAGS="${CXXFLAGS}"
+ OPT_LIBS="${LDFLAGS}"
+ GMIC_USE_CURL=$(usex curl)
+ GMIC_USE_EXR=$(usex openexr)
+ GMIC_USE_FFTW=$(usex fftw)
+ GMIC_USE_GRAPHICSMAGICK=$(usex graphicsmagick)
+ GMIC_USE_JPEG=$(usex jpeg)
+ GMIC_USE_OPENCV=$(usex opencv)
+ GMIC_USE_OPENMP=$(usex openmp)
+ GMIC_USE_PNG=$(usex png)
+ GMIC_USE_TIFF=$(usex tiff)
+ GMIC_USE_X11=$(usex X)
+ QMAKE="qmake5"
+ )
+
+ # Possibly unnecessary since 3.2.0, just in case though.
+ tc-is-clang && mymakeargs+=( OPENMP_LIBS="-lomp" )
+
+ emake -j1 -C src \
+ "${mymakeargs[@]}" \
+ $@
+}
+
+src_compile() {
+ gmic_emake lib
+ gmic_emake libc
+ use cli && gmic_emake cli_shared
+ use gimp && gmic_emake gimp_shared
+ use qt5 && gmic_emake gmic_qt_shared
+}
+
+src_install() {
+ # See below for why this has to name a directory even if USE=-gimp
+ local gimp_plugindir="/deleteme"
+ if use gimp; then
+ if type gimptool &>/dev/null; then
+ gimp_plugindir="$(gimptool --gimpplugindir)/plug-ins"
+ elif type gimptool-2.0 &>/dev/null; then
+ gimp_plugindir="$(gimptool-2.0 --gimpplugindir)/plug-ins"
+ elif type gimptool-2.99 &>/dev/null; then
+ gimp_plugindir="$(gimptool-2.99 --gimpplugindir)/plug-ins"
+ else
+ die "Cannot find GIMP plugin directory"
+ fi
+ fi
+
+ gmic_emake DESTDIR="${ED}" PLUGINDIR="${gimp_plugindir}" install
+
+ # Upstream build scripts create PLUGINDIR and write some files to it
+ # regardless of whether the GIMP plug-in has been built or not, or even
+ # when they haven't been able to execute gimptool to get the base path.
+ use gimp || rm -rf "${ED}/${gimp_plugindir}"
+
+ # These are already gzipped in the source tarballs
+ find "${ED}/usr/share/man" -name "*.gz" -exec gunzip {} \; || die
+}