summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-30 20:46:04 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-30 20:47:51 -0400
commitec3d05a8329c95eab16c39506bfb892729c1a8ec (patch)
tree9e47b24fdc9411f67756826a806a767f1f0cc8cf
parentapp-emulation/wine-proton: filter -mfunction-return=thunk for mingw (diff)
downloadgentoo-ec3d05a8329c95eab16c39506bfb892729c1a8ec.tar.gz
gentoo-ec3d05a8329c95eab16c39506bfb892729c1a8ec.tar.bz2
gentoo-ec3d05a8329c95eab16c39506bfb892729c1a8ec.zip
dev-util/mingw64-runtime: filter -mfunction-return=thunk for mingw
Unfortunately mingw doesn't play well with many security/mitigation flags. May need to consider a mingw.eclass if keep adding more of these to every ebuilds using it. Bug: https://bugs.gentoo.org/878849 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild1
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild1
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-9.0.0-r2.ebuild1
3 files changed, 3 insertions, 0 deletions
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
index f3225f01c156..5d3ff4f8587f 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
@@ -66,6 +66,7 @@ src_configure() {
filter-flags '-fstack-clash-protection' #758914
filter-flags '-fstack-protector*' #870136
filter-flags '-fuse-ld=*'
+ filter-flags '-mfunction-return=thunk*' #878849
fi
local CHOST=${CTARGET}
strip-unsupported-flags
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild
index 652dea446b1e..caa50883a838 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild
@@ -68,6 +68,7 @@ src_configure() {
filter-flags '-fstack-clash-protection' #758914
filter-flags '-fstack-protector*' #870136
filter-flags '-fuse-ld=*'
+ filter-flags '-mfunction-return=thunk*' #878849
fi
local CHOST=${CTARGET}
strip-unsupported-flags
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-9.0.0-r2.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-9.0.0-r2.ebuild
index e0d15b0a5f88..7f9b3697a13d 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-9.0.0-r2.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-9.0.0-r2.ebuild
@@ -66,6 +66,7 @@ src_configure() {
filter-flags '-fstack-clash-protection' #758914
filter-flags '-fstack-protector*' #870136
filter-flags '-fuse-ld=*'
+ filter-flags '-mfunction-return=thunk*' #878849
fi
local CHOST=${CTARGET}
strip-unsupported-flags