summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-01-23 09:52:30 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-01-23 09:52:30 +0000
commitf4a0c80f31f1ee3a158ad26f3812167628c4dad6 (patch)
treebeff37fa430bd59b4ebedf80000f28ed6e8ad6e8
parent2022-01-23 09:21:53 UTC (diff)
parentdev-python/warlock: Remove coverage flags (diff)
downloadgentoo-f4a0c80f31f1ee3a158ad26f3812167628c4dad6.tar.gz
gentoo-f4a0c80f31f1ee3a158ad26f3812167628c4dad6.tar.bz2
gentoo-f4a0c80f31f1ee3a158ad26f3812167628c4dad6.zip
Merge updates from master
-rw-r--r--dev-java/commons-imaging/Manifest2
-rw-r--r--dev-java/commons-imaging/commons-imaging-0.97.ebuild49
-rw-r--r--dev-java/commons-imaging/commons-imaging-1.0_alpha2.ebuild41
-rw-r--r--dev-python/multidict/Manifest1
-rw-r--r--dev-python/multidict/multidict-6.0.0.ebuild28
-rw-r--r--dev-python/pulsectl/Manifest1
-rw-r--r--dev-python/pulsectl/pulsectl-22.1.3.ebuild20
-rw-r--r--dev-python/warlock/warlock-1.3.3-r2.ebuild5
-rw-r--r--eclass/distutils-r1.eclass34
-rw-r--r--media-libs/libsdl2/libsdl2-2.0.20-r1.ebuild (renamed from media-libs/libsdl2/libsdl2-2.0.20.ebuild)3
-rw-r--r--net-misc/miniupnpd/Manifest2
-rw-r--r--net-misc/miniupnpd/miniupnpd-2.3.0.ebuild97
12 files changed, 218 insertions, 65 deletions
diff --git a/dev-java/commons-imaging/Manifest b/dev-java/commons-imaging/Manifest
index 13bebfeb5b85..636f8ef3213e 100644
--- a/dev-java/commons-imaging/Manifest
+++ b/dev-java/commons-imaging/Manifest
@@ -1 +1 @@
-DIST apache-sanselan-incubating-0.97-src.tar.gz 33317875 BLAKE2B c9db6c30accc308d2c5d5977b84da118ab50b010b3728665a75dab13f9fecb70075e2d2208a62fabc57af7396f7c39b1ec498e0840e5a2c9c8de9b95d2dd597a SHA512 b7e8af01f4b4ca812313bbf573758d9c0e1355266bfb83898336b14c4b492a8979f2a593f00d53c076e83cf807a049df624491a26623cfbceb00560b748f05f2
+DIST commons-imaging-1.0-alpha2-src.tar.gz 39798631 BLAKE2B 01d0754689896a1f2ff1401cac7d9f59a6bbb245c0880f24f857efc53975c1203c6857d7a5d107763741a2dec7fb48c4faa258786f574cf2f3c5acca251e368b SHA512 f2479e0dc726a8d1193f4eef6289efe493cfbbe257054b5a13e929f5785f7a2c9c937e3f379e0f0066c591d18be27d12f1e5157e789eebab78fba489cc81e688
diff --git a/dev-java/commons-imaging/commons-imaging-0.97.ebuild b/dev-java/commons-imaging/commons-imaging-0.97.ebuild
deleted file mode 100644
index f8c2ba3f2ef3..000000000000
--- a/dev-java/commons-imaging/commons-imaging-0.97.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="A minimalistic realtime charting library for Java"
-HOMEPAGE="https://commons.apache.org/proper/commons-imaging"
-SRC_URI="mirror://apache/commons/sanselan/source/apache-sanselan-incubating-${PV}-src.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="test" # 5/48 failures, dunno why :(
-
-RDEPEND=">=virtual/jre-1.6"
-
-DEPEND=">=virtual/jdk-1.6
- test? ( dev-java/junit:4 )"
-
-S="${WORKDIR}/sanselan-${PV}-incubator"
-JAVA_ENCODING="ISO-8859-1"
-JAVA_SRC_DIR="src/main/java"
-
-java_prepare() {
- # Tsk, Windows developers…
- find src/test/java -name "*.java" -exec sed -i 's:\\:/:g' {} + || die
-}
-
-src_install() {
- java-pkg-simple_src_install
- dodoc README.txt RELEASE_NOTES
-}
-
-src_test() {
- local DIR="src/test/java"
- local CP="${DIR}:${PN}.jar:$(java-pkg_getjars junit-4)"
-
- local TESTS=$(find "${DIR}" -name "*Test.java" ! -name "*BaseTest.java" ! -name SanselanTest.java ! -name ByteSourceTest.java)
- TESTS="${TESTS//src\/test\/java\/}"
- TESTS="${TESTS//.java}"
- TESTS="${TESTS//\//.}"
-
- ejavac -cp "${CP}" -d "${DIR}" $(find "${DIR}" -name "*.java")
- ejunit4 -classpath "${CP}" ${TESTS}
-}
diff --git a/dev-java/commons-imaging/commons-imaging-1.0_alpha2.ebuild b/dev-java/commons-imaging/commons-imaging-1.0_alpha2.ebuild
new file mode 100644
index 000000000000..9ec64af99b77
--- /dev/null
+++ b/dev-java/commons-imaging/commons-imaging-1.0_alpha2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri mirror://apache/commons/imaging/source/commons-imaging-1.0-alpha2-src.tar.gz --slot 0 --keywords "~amd64 ~x86" --ebuild commons-imaging-1.0_alpha2.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.apache.commons:commons-imaging:1.0-alpha2"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Apache Commons Imaging (previously Sanselan) is a pure-Java image library."
+HOMEPAGE="https://commons.apache.org/proper/commons-imaging/"
+SRC_URI="mirror://apache/commons/imaging/source/commons-imaging-${PV/_/-}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Compile dependencies
+# POM: pom.xml
+# test? commons-io:commons-io:2.7 -> >=dev-java/commons-io-2.11.0:1
+# test? org.hamcrest:hamcrest:2.2 -> !!!artifactId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter:5.6.2 -> !!!groupId-not-found!!!
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( {LICENSE,NOTICE,RELEASE-NOTES}.txt README.md )
+
+S="${WORKDIR}/${P/_/-}-src"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+src_install() {
+ default # https://bugs.gentoo.org/789582
+ java-pkg-simple_src_install
+}
diff --git a/dev-python/multidict/Manifest b/dev-python/multidict/Manifest
index ab5507fc0bd0..41f8f5cafdee 100644
--- a/dev-python/multidict/Manifest
+++ b/dev-python/multidict/Manifest
@@ -1 +1,2 @@
DIST multidict-5.2.0.tar.gz 56984 BLAKE2B 3580e3f53b3ec581d338676647f2e8dd78387fdad5730fe703c02b3cd4182d69e3b6896d71bd969413dd27974e07272cc541701a2145a517d9bacea45000e9c8 SHA512 508b6db9219c3dae76da5e89a398f4541beff2a875030c2f11da9aaa1e001324d069d7a291148c510fe555cb3a33288ef297c9baa863e42d3d09d60588bebd7e
+DIST multidict-6.0.0.tar.gz 56006 BLAKE2B 886e7e02da1eb80ca2a7106dd127d0164155fa400125f4fa0c880d508407ad1b436e52d77f331843f908d5ab5497aac002d72445615666b0621a8e436397598f SHA512 9f258795166fd3c6f56286fd98da8cf7ce9bc5d7a974174865164f0955c71263234307733c0edcc5d0142c1356d681e24c93c3be6f5dbee67f01dee6a39b32d2
diff --git a/dev-python/multidict/multidict-6.0.0.ebuild b/dev-python/multidict/multidict-6.0.0.ebuild
new file mode 100644
index 000000000000..f45187aed2ff
--- /dev/null
+++ b/dev-python/multidict/multidict-6.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="multidict implementation"
+HOMEPAGE="https://github.com/aio-libs/multidict/"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND=">=dev-python/cython-0.28.4[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs --no-autodoc
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't enable coverage or other pytest settings
+ sed -i -e 's:--cov.*::' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/pulsectl/Manifest b/dev-python/pulsectl/Manifest
index 6f578b8e29f7..fcfa8a505570 100644
--- a/dev-python/pulsectl/Manifest
+++ b/dev-python/pulsectl/Manifest
@@ -1,3 +1,4 @@
DIST pulsectl-21.10.5.tar.gz 40769 BLAKE2B 8346717714b4e9fd017ca917388d2ddff9c7b5a5a74a33e03e3fd5fc02048ba3d1873fb1bd10a12410dc44d88c253a4afc71f1f2542e70f36f4985659fcd9fb5 SHA512 353af9d33bb6e9f070e46a934f0933935631ca5d254430ece8b9aa9a25dd31607a45718a45c71f35f2e3801c78d7eea18c5e34f69e5a983cfc0115a8fcd05334
DIST pulsectl-22.1.0.tar.gz 40796 BLAKE2B a401500f3927fcc86db7132a9e76b31a8dd2144fb1cf6d62be30c6dc4648298f4ed378061b48dc4c64adb3a24d25810613024d6f652aa72b696f9b05605613a8 SHA512 b55ad512c9b7b11aa848465fe8cd556c76b5e10ebc7862aefc6b459cd4526ca1a0e284e81560b5e86d22acfa8409d09683043ca789c4f59f512a77cf2273cc7e
DIST pulsectl-22.1.1.tar.gz 40813 BLAKE2B f5f5dd1bd958d9a053fa9da1aab7aa49680b7047641088fae9a110162e8be859de275dc79990366197c1be14e0c1e555cd2a37dc20f36ae5ad9bcff29babd1d5 SHA512 7676db1d1da3816d94a297b25613e44a02cd560a4c5495a25efb90f9fafb97e16844a5e36bc67457594afc6378860e57246cc5d07ab22aba328679c6ff1bfd8b
+DIST pulsectl-22.1.3.tar.gz 40899 BLAKE2B e0a3361ce9126afe9a79817165405c38638cd7b2328162750607d7c674431f0e57762f5aaa50ab17325d493b16a5370feaa836e6899cd91c64f299af008c8825 SHA512 cc60ca006518f8be327cf7aa0dccb4820b0891e7118989b31c968bd740134751033802dbe54e203c56cf6a5d541732684dd27128c14f753acc5de38b639bdf64
diff --git a/dev-python/pulsectl/pulsectl-22.1.3.ebuild b/dev-python/pulsectl/pulsectl-22.1.3.ebuild
new file mode 100644
index 000000000000..b7d66bc938a0
--- /dev/null
+++ b/dev-python/pulsectl/pulsectl-22.1.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)"
+HOMEPAGE="https://github.com/mk-fg/python-pulse-control"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-sound/pulseaudio"
+
+distutils_enable_tests unittest
diff --git a/dev-python/warlock/warlock-1.3.3-r2.ebuild b/dev-python/warlock/warlock-1.3.3-r2.ebuild
index 135f317e5036..00daf64b32b9 100644
--- a/dev-python/warlock/warlock-1.3.3-r2.ebuild
+++ b/dev-python/warlock/warlock-1.3.3-r2.ebuild
@@ -29,3 +29,8 @@ EPYTEST_DESELECT=(
# (its only dep) does not seem to be affected
tests/test_core.py::TestCore::test_recursive_models
)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pytest.ini || die
+ distutils-r1_src_prepare
+}
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index a9c86ef55124..a91442459346 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -973,10 +973,16 @@ distutils-r1_python_compile() {
# TODO: workaround for a bug in installer; remove once we depend
# on a properly fixed version
- if [[ -d ${root}/usr/bin ]]; then
- chmod +x "${root}"/usr/bin/* || die
+ # https://github.com/pradyunsg/installer/commit/245896289a590bd9be505bd061d4f49372948a16
+ if [[ -d ${root}${EPREFIX}/usr/bin ]]; then
+ chmod +x "${root}${EPREFIX}"/usr/bin/* || die
fi
+ # remove installed licenses
+ find "${root}$(python_get_sitedir)" \
+ '(' -path '*.dist-info/COPYING*' -o \
+ -path '*.dist-info/LICENSE*' ')' -delete || die
+
# clean the build tree; otherwise we may end up with PyPy3
# extensions duplicated into CPython dists
if [[ ${DISTUTILS_USE_PEP517:-setuptools} == setuptools ]]; then
@@ -984,11 +990,11 @@ distutils-r1_python_compile() {
fi
# enable venv magic inside the install tree
- mkdir -p "${root}"/usr/bin || die
- ln -s "${PYTHON}" "${root}/usr/bin/${EPYTHON}" || die
- ln -s "${EPYTHON}" "${root}/usr/bin/python3" || die
- ln -s "${EPYTHON}" "${root}/usr/bin/python" || die
- cat > "${root}"/usr/pyvenv.cfg <<-EOF || die
+ mkdir -p "${root}${EPREFIX}"/usr/bin || die
+ ln -s "${PYTHON}" "${root}${EPREFIX}/usr/bin/${EPYTHON}" || die
+ ln -s "${EPYTHON}" "${root}${EPREFIX}/usr/bin/python3" || die
+ ln -s "${EPYTHON}" "${root}${EPREFIX}/usr/bin/python" || die
+ cat > "${root}${EPREFIX}"/usr/pyvenv.cfg <<-EOF || die
include-system-site-packages = true
EOF
fi
@@ -1110,11 +1116,11 @@ distutils-r1_python_install() {
[[ -d ${rscriptdir} ]] &&
die "${rscriptdir} should not exist!"
# remove venv magic
- rm "${root}"/usr/{pyvenv.cfg,bin/{python,python3,${EPYTHON}}} || die
- find "${root}"/usr/bin -empty -delete || die
- if [[ ! ${DISTUTILS_SINGLE_IMPL} && -d ${root}/usr/bin ]]; then
+ rm "${root}${EPREFIX}"/usr/{pyvenv.cfg,bin/{python,python3,${EPYTHON}}} || die
+ find "${root}${EPREFIX}"/usr/bin -empty -delete || die
+ if [[ ! ${DISTUTILS_SINGLE_IMPL} && -d ${root}${EPREFIX}/usr/bin ]]; then
mkdir -p "${rscriptdir%/*}" || die
- mv "${root}/usr/bin" "${rscriptdir}" || die
+ mv "${root}${EPREFIX}/usr/bin" "${rscriptdir}" || die
fi
else
local root=${D%/}/_${EPYTHON}
@@ -1184,8 +1190,8 @@ distutils-r1_python_install() {
local shopt_save=$(shopt -p nullglob)
shopt -s nullglob
local pypy_dirs=(
- "${root}/usr/$(get_libdir)"/pypy*/share
- "${root}/usr/lib"/pypy*/share
+ "${root}${EPREFIX}/usr/$(get_libdir)"/pypy*/share
+ "${root}${EPREFIX}/usr/lib"/pypy*/share
)
${shopt_save}
@@ -1244,7 +1250,7 @@ distutils-r1_run_phase() {
fi
if [[ ${DISTUTILS_USE_PEP517} ]]; then
- local -x PATH=${BUILD_DIR}/install/usr/bin:${PATH}
+ local -x PATH=${BUILD_DIR}/install${EPREFIX}/usr/bin:${PATH}
else
local -x PYTHONPATH="${BUILD_DIR}/lib:${PYTHONPATH}"
diff --git a/media-libs/libsdl2/libsdl2-2.0.20.ebuild b/media-libs/libsdl2/libsdl2-2.0.20-r1.ebuild
index 0e22bf102de2..ac70239d8ce4 100644
--- a/media-libs/libsdl2/libsdl2-2.0.20.ebuild
+++ b/media-libs/libsdl2/libsdl2-2.0.20-r1.ebuild
@@ -58,7 +58,7 @@ CDEPEND="
sndio? ( media-sound/sndio:=[${MULTILIB_USEDEP}] )
udev? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
wayland? (
- >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}]
+ >=dev-libs/wayland-1.20[${MULTILIB_USEDEP}]
>=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},egl(+),gles2,wayland]
>=x11-libs/libxkbcommon-0.2.0[${MULTILIB_USEDEP}]
)
@@ -85,6 +85,7 @@ BDEPEND="
app-doc/doxygen
media-gfx/graphviz
)
+ wayland? ( >=dev-util/wayland-scanner-1.20 )
"
MULTILIB_WRAPPED_HEADERS=(
diff --git a/net-misc/miniupnpd/Manifest b/net-misc/miniupnpd/Manifest
index b26631d98c54..30c492813480 100644
--- a/net-misc/miniupnpd/Manifest
+++ b/net-misc/miniupnpd/Manifest
@@ -2,3 +2,5 @@ DIST miniupnpd-2.2.2.tar.gz 250649 BLAKE2B d561916ced9b5c58371382fe0bec68cd0771d
DIST miniupnpd-2.2.2.tar.gz.sig 543 BLAKE2B 461a9149c66b0e314a767405024fc7bfb641a20ae36b908dc467c9211660d5cb0753fb3c99fa9d6df35d693a2f6790efb6a325f0005804572eaa78a02b23a482 SHA512 8ffc9901cd992cbd9d0fa4c5e510fe43f748ab4a7c4732cc8f2f685f19b71a3f087a63a39e1dbf081175ac65de34b5c05dc3ef636a805e550a0406119a5904ef
DIST miniupnpd-2.2.3.tar.gz 254752 BLAKE2B ebdb8d4ce7dc649ef0243d2d698b9f51cb2006055eb3abb70d9ccc839cb57c7113595ef1b9b5886f55bc458d8260edf95ae6e1964a5d5423f9b0b46e07e02775 SHA512 56b1e93e9576fa412202e1940fcd8b7af57584714c15017bbcec1aa4fa7bba7a6fa5d1136048100d7cce3222f31b38837de1eae344b533164314c858cdf08ef9
DIST miniupnpd-2.2.3.tar.gz.sig 543 BLAKE2B 3ba2e69cfd7e0a27a746f45e5eb10e573e00c4fc20a7d62b94a2e0b7e4e9ad8779d53df72e31547b78dc6e34676204a4848652e81d1e479a68973e150f51f468 SHA512 9f766f3e94de1fbd458c7bda30cc87892198af7544aa9dc0fa4c6b6a1c9434e4bab6f8583eeccf3ae613da240ad599d750425c507e8138d483710459f31a0b21
+DIST miniupnpd-2.3.0.tar.gz 256069 BLAKE2B dd21b4ee692cf9958bd996c6fe70e7e1f6cdfe467506676d2335ccf37cd0ed7e55ff435983747cad5d2342019b36597e538fcb9b511872889305330212e88cb0 SHA512 437a4b101bcadd9feb3845d37402c253a0a2114463fd8c5930859c7eae0ffaf7714ef7c9d387be2339c584e2f106fafa008a4364ff347b6640153c9a09919b0a
+DIST miniupnpd-2.3.0.tar.gz.sig 543 BLAKE2B 312d46521d37c1a2fda146f2c7c964af45ffa4a75bc327dc743b40f96586e0916a674db4a0bb847b5e386f0b781319868d1d6cc74fbffaf3a8e989db18f4f6e6 SHA512 87be539c27d0147fcc62b69a82858518e862f2b593a0e03a9986e3641a0d61f4fa831d79a7ce645b33569234463a9517b9dbbc79ee988c9f561474a4757c4c04
diff --git a/net-misc/miniupnpd/miniupnpd-2.3.0.ebuild b/net-misc/miniupnpd/miniupnpd-2.3.0.ebuild
new file mode 100644
index 000000000000..328c65b49bbc
--- /dev/null
+++ b/net-misc/miniupnpd/miniupnpd-2.3.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit toolchain-funcs verify-sig
+
+MY_P=${P/_rc/-RC}
+DESCRIPTION="MiniUPnP IGD Daemon"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${MY_P}.tar.gz
+ verify-sig? ( http://miniupnp.free.fr/files/${MY_P}.tar.gz.sig )"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+leasefile igd2 ipv6 nftables pcp-peer portinuse strict"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ sys-apps/util-linux:=
+ dev-libs/openssl:0=
+ !nftables? (
+ >=net-firewall/iptables-1.4.6:0=[ipv6?]
+ net-libs/libnfnetlink:=
+ net-libs/libmnl:=
+ )
+ nftables? (
+ net-firewall/nftables
+ net-libs/libnftnl:=
+ net-libs/libmnl:=
+ )"
+DEPEND="${RDEPEND}
+ elibc_musl? ( sys-libs/queue-standalone )"
+BDEPEND="
+ sys-apps/lsb-release
+ verify-sig? ( sec-keys/openpgp-keys-miniupnp )"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/miniupnp.asc
+
+src_prepare() {
+ default
+
+ # fails without a default route
+ sed -i -e 's:EXTIF=.*:EXTIF=lo:' testgetifaddr.sh || die
+}
+
+src_configure() {
+ local opts=(
+ --vendorcfg
+ $(usex igd2 '--igd2' '')
+ $(usex ipv6 '--ipv6' '')
+ $(usex leasefile '--leasefile' '')
+ $(usex portinuse '--portinuse' '')
+ $(usex pcp-peer '--pcp-peer' '')
+ $(usex strict '--strict' '')
+ --firewall=$(usex nftables nftables iptables)
+ )
+
+ # custom script
+ ./configure "${opts[@]}" || die
+ # prevent gzipping manpage
+ sed -i -e '/gzip/d' Makefile || die
+}
+
+src_compile() {
+ # By default, it builds a bunch of unittests that are missing wrapper
+ # scripts in the tarball
+ emake CC="$(tc-getCC)" STRIP=true miniupnpd
+}
+
+src_test() {
+ emake CC="$(tc-getCC)" check
+}
+
+src_install() {
+ emake PREFIX="${ED}" STRIP=true install
+
+ local confd_seds=()
+ if use nftables; then
+ confd_seds+=( -e 's/^iptables_scripts=/#&/' )
+ else
+ confd_seds+=( -e 's/^nftables_scripts=/#&/' )
+ fi
+ if ! use ipv6 || use nftables; then
+ confd_seds+=( -e 's/^ip6tables_scripts=/#&/' )
+ fi
+
+ newinitd "${FILESDIR}"/${PN}-init.d-r2 ${PN}
+ newconfd - ${PN} < <(sed "${confd_seds[@]}" \
+ "${FILESDIR}"/${PN}-conf.d-r2 || die)
+}
+
+pkg_postinst() {
+ elog "Please correct the external interface in the top of the two"
+ elog "scripts in /etc/miniupnpd and edit the config file in there too"
+}