summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/SphinxTrain
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/SphinxTrain')
-rw-r--r--app-accessibility/SphinxTrain/Manifest2
-rw-r--r--app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild41
-rw-r--r--app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild39
-rw-r--r--app-accessibility/SphinxTrain/files/gcc.patch34
-rw-r--r--app-accessibility/SphinxTrain/files/gcc34.patch11
-rw-r--r--app-accessibility/SphinxTrain/metadata.xml15
6 files changed, 142 insertions, 0 deletions
diff --git a/app-accessibility/SphinxTrain/Manifest b/app-accessibility/SphinxTrain/Manifest
new file mode 100644
index 000000000000..12efac4514b3
--- /dev/null
+++ b/app-accessibility/SphinxTrain/Manifest
@@ -0,0 +1,2 @@
+DIST SphinxTrain-0.9.1-beta.tar.gz 469617 SHA256 c1a4b74a3e26777b80ddd7a026547aad194040cca8595e6fe1be320a19f99d18 SHA512 1b33a58a6e05069369fe1ba668609e5a25d6a49fbf2fed1f5d86bdc1fc43d4544627c438e61d46003c2dbd8d7fa6f41c686b57cbca215f73b6c4ba0d7682076d WHIRLPOOL 6399233f803f37d8d267a5005a5cb158513cb64b2b7b3727cb9ee93c46781f29e5ed0729c1d7d1e586de49ede098a7d9658c285399bae0d633f34657000074c8
+DIST sphinxtrain-1.0.8.tar.gz 8925803 SHA256 548e3e513ceaa1b2fd6fd7ed1724349e0a4bf7bdeb11be9c91787e6f2b865203 SHA512 465d2c4ade9acc7b49c1d975449c38ac01d5a3ff332f9841be66cd8ca9d2f0b68fd36cc8a46384c8b510042efa91c3887a080481e84f2d0deb9775a598835f2b WHIRLPOOL d9ccbe09d125579e15167fa625bb72c86e114f9c394e909488216ae2f4e6af4c7b968d469455b65c4aff2a41a7d97701ac290df2cbc6b0450c64c94b042ae94d
diff --git a/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild b/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..7e18d2e5b39c
--- /dev/null
+++ b/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Speech Recognition (Training Module)"
+HOMEPAGE="http://cmusphinx.sourceforge.net/html/cmusphinx.php"
+SRC_URI="http://www.speech.cs.cmu.edu/${PN}/${P}-beta.tar.gz"
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="app-accessibility/sphinx2
+ app-accessibility/festival"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/gcc.patch
+ epatch "${FILESDIR}"/gcc34.patch
+ tc-export CC AR RANLIB
+}
+
+src_install() {
+ # dobin bin.*/* fails ... see bug #73586
+ find bin.* -mindepth 1 -maxdepth 1 -type f -exec dobin '{}' \; || die
+
+ dodoc README etc/*cfg
+ dohtml doc/*{txt,html,sgml}
+}
+
+pkg_postinst() {
+ elog "Detailed usage and training instructions can be found at"
+ elog "http://www.speech.cs.cmu.edu/SphinxTrain/"
+}
diff --git a/app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild b/app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild
new file mode 100644
index 000000000000..e0014a9ac0a4
--- /dev/null
+++ b/app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib python-single-r1
+
+DESCRIPTION="Speech Recognition (Training Module)"
+HOMEPAGE="http://cmusphinx.sourceforge.net/html/cmusphinx.php"
+SRC_URI="mirror://sourceforge/cmusphinx/sphinxtrain-${PV}.tar.gz"
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="app-accessibility/sphinxbase
+ dev-lang/perl
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/sphinxtrain-${PV}
+
+src_install() {
+ default
+ dodoc README etc/*cfg
+
+ python_fix_shebang "${D}"/usr/bin/sphinxtrain
+ python_optimize "${D}"/usr/$(get_libdir)/sphinxtrain/python/cmusphinx
+}
+
+pkg_postinst() {
+ elog "Detailed usage and training instructions can be found at"
+ elog "http://cmusphinx.sourceforge.net/wiki/"
+}
diff --git a/app-accessibility/SphinxTrain/files/gcc.patch b/app-accessibility/SphinxTrain/files/gcc.patch
new file mode 100644
index 000000000000..e3c51275f910
--- /dev/null
+++ b/app-accessibility/SphinxTrain/files/gcc.patch
@@ -0,0 +1,34 @@
+--- src/programs/count_3phone/wrec.h.orig 2003-09-28 18:51:49.000000000 +0900
++++ src/programs/count_3phone/wrec.h 2003-09-28 18:52:23.000000000 +0900
+@@ -44,7 +44,7 @@
+ #define WREC_H
+
+ #include "phrec.h"
+-#include <varargs.h>
++#include <stdarg.h>
+
+ int quit (int status, char *fmt, ...);
+
+--- src/programs/count_3phone/quit.c.orig 2003-09-28 19:12:56.000000000 +0900
++++ src/programs/count_3phone/quit.c 2003-09-28 19:13:12.000000000 +0900
+@@ -74,17 +74,14 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include <varargs.h>
++#include <stdarg.h>
+
+-int quit (status,fmt,va_alist)
+- int status;
+- char *fmt;
+- va_dcl
++int quit (int status,char *fmt,...)
+ {
+ va_list args;
+
+ fflush(stdout);
+- va_start(args);
++ va_start(args, fmt);
+ (void) vfprintf(stderr, fmt, args);
+ va_end(args);
+ exit(status);
diff --git a/app-accessibility/SphinxTrain/files/gcc34.patch b/app-accessibility/SphinxTrain/files/gcc34.patch
new file mode 100644
index 000000000000..124aa993edc9
--- /dev/null
+++ b/app-accessibility/SphinxTrain/files/gcc34.patch
@@ -0,0 +1,11 @@
+--- SphinxTrain/src/programs/count_3phone/phone_word_io.c~ 2001-04-05 16:00:33.000000000 -0400
++++ SphinxTrain/src/programs/count_3phone/phone_word_io.c 2005-05-01 12:48:42.000000000 -0400
+@@ -71,7 +71,7 @@
+ #ifdef __alpha
+ void *malloc();
+ #else
+-char *malloc();
++//char *malloc();
+ #endif
+
+ extern int Num_Phones, Num_Words;
diff --git a/app-accessibility/SphinxTrain/metadata.xml b/app-accessibility/SphinxTrain/metadata.xml
new file mode 100644
index 000000000000..acc417de6d38
--- /dev/null
+++ b/app-accessibility/SphinxTrain/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <herd>sound</herd>
+ <longdescription lang="en">
+ SphinxTrain is CMU Sphinx's training package.
+</longdescription>
+ <longdescription lang="ja">
+ SphinxTrainはCMU Sphinxの調教パッケージです。
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">cmusphinx</remote-id>
+ </upstream>
+</pkgmetadata>