summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/edbrowse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/edbrowse')
-rw-r--r--app-accessibility/edbrowse/Manifest1
-rw-r--r--app-accessibility/edbrowse/edbrowse-3.5.1.ebuild58
-rw-r--r--app-accessibility/edbrowse/files/edbrowse-3.5.1-implicit-decl.patch22
-rw-r--r--app-accessibility/edbrowse/metadata.xml9
4 files changed, 90 insertions, 0 deletions
diff --git a/app-accessibility/edbrowse/Manifest b/app-accessibility/edbrowse/Manifest
new file mode 100644
index 000000000000..1bbc405aab26
--- /dev/null
+++ b/app-accessibility/edbrowse/Manifest
@@ -0,0 +1 @@
+DIST edbrowse-3.5.1.zip 745277 SHA256 e379cffb1098cfedf56ceedaaa7e20064551a0737ad6cd8ad5124fdfb18d9a5f SHA512 83bdb1d49afa04a41a84b71e86969880b518d8d6c1e448380d70710ad2373ed57cb3699d3ad50226ea4d5776f511ff50b9510655b27d26948213113699512fc2 WHIRLPOOL e7517c5ae60a438d6d651fbfdbfd7f625c2369f43bb2ba92c1c974e34a7d8ddbb6d441cb1ef79c4354cf88e2796f05110bb0e5ff1b1699cb55b23221c2bd000b
diff --git a/app-accessibility/edbrowse/edbrowse-3.5.1.ebuild b/app-accessibility/edbrowse/edbrowse-3.5.1.ebuild
new file mode 100644
index 000000000000..1c2a80b38620
--- /dev/null
+++ b/app-accessibility/edbrowse/edbrowse-3.5.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils
+
+DESCRIPTION="editor, browser, and mail client using the /bin/ed interface"
+HOMEPAGE="http://the-brannons.com/edbrowse/"
+SRC_URI="http://the-brannons.com/${PN}/${P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_fr odbc"
+COMMON_DEPEND=">=dev-lang/spidermonkey-24.0:24
+ >=sys-libs/readline-6.0
+ >=net-misc/curl-7.36.0
+ >=dev-libs/libpcre-7.8
+ >=dev-libs/openssl-0.9.8j
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ app-arch/unzip"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-implicit-decl.patch"
+}
+
+src_compile() {
+ jscppflags=$(pkg-config --cflags mozjs-24)
+ jslib=$(pkg-config --libs mozjs-24)
+ emake prefix=/usr JSLIB="${jslib}" JS_CXXFLAGS="${jscppflags}" STRIP=''
+ if use odbc; then
+ # Top-level makefile doesn't have this target.
+ cd src
+ emake prefix=/usr JSLIB="${jslib}" JS_CXXFLAGS="${jscppflags}" STRIP=''
+ cd ..
+ fi
+}
+
+src_install() {
+ cd src
+ emake prefix=/usr DESTDIR="${D}" install
+ if use odbc; then
+ dobin edbrowseodbc
+ fi
+ cd ..
+ dodoc CHANGES README todo
+ cd doc
+ dobin setup.ebrc
+ dohtml usersguide.html philosophy.html
+ dodoc sample.ebrc
+ if use linguas_fr; then
+ dohtml usersguide_fr.html philosophy_fr.html
+ dodoc sample_fr.ebrc
+ fi
+}
diff --git a/app-accessibility/edbrowse/files/edbrowse-3.5.1-implicit-decl.patch b/app-accessibility/edbrowse/files/edbrowse-3.5.1-implicit-decl.patch
new file mode 100644
index 000000000000..1880d2b3bfe0
--- /dev/null
+++ b/app-accessibility/edbrowse/files/edbrowse-3.5.1-implicit-decl.patch
@@ -0,0 +1,22 @@
+diff -Naur edbrowse-3.5.1/src/fetchmail.c edbrowse-3.5.1.new/src/fetchmail.c
+--- edbrowse-3.5.1/src/fetchmail.c 2014-09-23 21:50:37.000000000 -0700
++++ edbrowse-3.5.1.new/src/fetchmail.c 2014-09-29 02:29:46.193856866 -0700
+@@ -6,6 +6,7 @@
+ * This file is part of the edbrowse project, released under GPL.
+ */
+
++#define _GNU_SOURCE
+ #include "eb.h"
+
+ #define MHLINE 200 /* length of a mail header line */
+diff -Naur edbrowse-3.5.1/src/sendmail.c edbrowse-3.5.1.new/src/sendmail.c
+--- edbrowse-3.5.1/src/sendmail.c 2014-09-23 21:50:37.000000000 -0700
++++ edbrowse-3.5.1.new/src/sendmail.c 2014-09-29 02:29:37.105874233 -0700
+@@ -5,6 +5,7 @@
+ * This file is part of the edbrowse project, released under GPL.
+ */
+
++#define _GNU_SOURCE
+ #include "eb.h"
+
+ #include <time.h>
diff --git a/app-accessibility/edbrowse/metadata.xml b/app-accessibility/edbrowse/metadata.xml
new file mode 100644
index 000000000000..234d31d93975
--- /dev/null
+++ b/app-accessibility/edbrowse/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<longdescription>
+ edbrowse is a line editor, web browser and email client using the /bin/ed
+ user interface.
+</longdescription>
+</pkgmetadata>