summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/emacspeak
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/emacspeak')
-rw-r--r--app-accessibility/emacspeak/Manifest1
-rw-r--r--app-accessibility/emacspeak/emacspeak-39.0-r2.ebuild81
-rw-r--r--app-accessibility/emacspeak/emacspeak-9999.ebuild81
-rw-r--r--app-accessibility/emacspeak/metadata.xml16
4 files changed, 179 insertions, 0 deletions
diff --git a/app-accessibility/emacspeak/Manifest b/app-accessibility/emacspeak/Manifest
new file mode 100644
index 000000000000..a3025832748b
--- /dev/null
+++ b/app-accessibility/emacspeak/Manifest
@@ -0,0 +1 @@
+DIST emacspeak-39.0.tar.bz2 4989631 SHA256 aff805271ea02ad7e08c121d42886d1a774d1b58a42bf2c570cc6722b903fc71 SHA512 c0a0c503d6ccc2abb53a8be580997b44e0449c2225e8a64cee73c24d69a28c3f47c0e660a95a6e77dd4d660272ad562ff747ce3c0a989f8fe7c8171f60349173 WHIRLPOOL 9f4c3cdd2d2695b7351f83733454afcdfe569921f8d304447132a973fa9a02b572ee149a7b0d0ee0b914c00e37fcacb26aaef270f8fa43a93b528591af12e862
diff --git a/app-accessibility/emacspeak/emacspeak-39.0-r2.ebuild b/app-accessibility/emacspeak/emacspeak-39.0-r2.ebuild
new file mode 100644
index 000000000000..6c2ee753ed4f
--- /dev/null
+++ b/app-accessibility/emacspeak/emacspeak-39.0-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+NEED_EMACS=24
+FORCE_PRINT_ELOG=1
+DISABLE_AUTOFORMATTING=1
+inherit eutils readme.gentoo elisp
+
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="http://${PN}.googlecode.com/svn/trunk"
+ inherit subversion
+else
+ SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+ KEYWORDS="amd64 ppc x86"
+fi
+
+DESCRIPTION="the emacspeak audio desktop"
+HOMEPAGE="http://emacspeak.sourceforge.net/"
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE="+espeak"
+
+ DEPEND="espeak? ( app-accessibility/espeak )"
+
+RDEPEND="${DEPEND}
+ >=dev-tcltk/tclx-8.4"
+
+DOC_CONTENTS='
+As of version 39.0 and later, the /usr/bin/emacspeak
+shell script has been removed downstream in Gentoo.
+You should launch emacspeak by another method, for instance
+by adding the following to your ~/.emacs file:
+(load "/usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak-setup.el")
+'
+
+src_prepare() {
+ # Allow user patches to be applied without modifying the ebuild
+ epatch_user
+}
+
+src_configure() {
+ emake config
+}
+
+src_compile() {
+ emake emacspeak
+ if use espeak; then
+ local tcl_version="$(echo 'puts $tcl_version;exit 0' |tclsh)"
+ if [[ -z $tcl_version ]]; then
+ die 'Unable to detect the installed version of dev-lang/tcl.'
+ fi
+ cd servers/linux-espeak
+ emake TCL_VERSION="${tcl_version}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm "${D}/usr/bin/emacspeak"
+ if use espeak; then
+ pushd servers/linux-espeak > /dev/null || die
+ emake DESTDIR="${D}" install
+ local orig_serverdir="/usr/share/emacs/site-lisp/emacspeak/servers/linux-espeak"
+ local serverfile="${D}${orig_serverdir}/tclespeak.so"
+ install -Dm755 "$serverfile" \
+ "${D}/usr/$(get_libdir)/emacspeak/tclespeak.so" || die
+ rm -f "$serverfile" || die
+ dosym "/usr/$(get_libdir)/emacspeak/tclespeak.so" \
+ "$orig_serverdir/tclespeak.so"
+ popd > /dev/null || die
+ fi
+ dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
+ dohtml -r install-guide user-guide
+ cd "${D}/usr/share/emacs/site-lisp/${PN}"
+ rm -rf README etc/NEWS* etc/FAQ etc/COPYRIGHT install-guide \
+ user-guide || die
+ readme.gentoo_create_doc
+}
diff --git a/app-accessibility/emacspeak/emacspeak-9999.ebuild b/app-accessibility/emacspeak/emacspeak-9999.ebuild
new file mode 100644
index 000000000000..306aeefb0121
--- /dev/null
+++ b/app-accessibility/emacspeak/emacspeak-9999.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+NEED_EMACS=24
+FORCE_PRINT_ELOG=1
+DISABLE_AUTOFORMATTING=1
+inherit eutils readme.gentoo elisp
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/tvraman/emacspeak.git"
+ inherit git-r3
+else
+ SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+DESCRIPTION="the emacspeak audio desktop"
+HOMEPAGE="http://emacspeak.sourceforge.net/"
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE="+espeak"
+
+ DEPEND="espeak? ( app-accessibility/espeak )"
+
+RDEPEND="${DEPEND}
+ >=dev-tcltk/tclx-8.4"
+
+DOC_CONTENTS='
+As of version 39.0 and later, the /usr/bin/emacspeak
+shell script has been removed downstream in Gentoo.
+You should launch emacspeak by another method, for instance
+by adding the following to your ~/.emacs file:
+(load "/usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak-setup.el")
+'
+
+src_prepare() {
+ # Allow user patches to be applied without modifying the ebuild
+ epatch_user
+}
+
+src_configure() {
+ emake config
+}
+
+src_compile() {
+ emake emacspeak
+ if use espeak; then
+ local tcl_version="$(echo 'puts $tcl_version;exit 0' |tclsh)"
+ if [[ -z $tcl_version ]]; then
+ die 'Unable to detect the installed version of dev-lang/tcl.'
+ fi
+ cd servers/linux-espeak
+ emake TCL_VERSION="${tcl_version}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm "${D}/usr/bin/emacspeak"
+ if use espeak; then
+ pushd servers/linux-espeak > /dev/null || die
+ emake DESTDIR="${D}" install
+ local orig_serverdir="/usr/share/emacs/site-lisp/emacspeak/servers/linux-espeak"
+ local serverfile="${D}${orig_serverdir}/tclespeak.so"
+ install -Dm755 "$serverfile" \
+ "${D}/usr/$(get_libdir)/emacspeak/tclespeak.so" || die
+ rm -f "$serverfile" || die
+ dosym "/usr/$(get_libdir)/emacspeak/tclespeak.so" \
+ "$orig_serverdir/tclespeak.so"
+ popd > /dev/null || die
+ fi
+ dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
+ dohtml -r install-guide user-guide
+ cd "${D}/usr/share/emacs/site-lisp/${PN}"
+ rm -rf README etc/NEWS* etc/FAQ etc/COPYRIGHT install-guide \
+ user-guide || die
+ readme.gentoo_create_doc
+}
diff --git a/app-accessibility/emacspeak/metadata.xml b/app-accessibility/emacspeak/metadata.xml
new file mode 100644
index 000000000000..3a804e6c49f5
--- /dev/null
+++ b/app-accessibility/emacspeak/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <herd>emacs</herd>
+ <longdescription lang="en">Emacspeak is a speech interface that allows visually impaired
+ users to interact independently and efficiently with the computer.</longdescription>
+ <longdescription lang="ja">Emacspeakで視覚障害者が単独と手際良くでコンピュータを
+ 使うことが出来る。</longdescription>
+ <use>
+ <flag name="espeak">Adds support for the espeak tts engine</flag>
+ </use>
+ <upstream>
+ <remote-id type="google-code">emacspeak</remote-id>
+ </upstream>
+</pkgmetadata>