summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-01-05 10:17:27 -0300
committerMatt Turner <mattst88@gentoo.org>2023-01-05 11:30:14 -0500
commit1becd03f557139fe1a646d142b4b216ed4b88e2a (patch)
treecd3ff9200b7f79159fadbefed0fc0725e92a275f /app-accessibility
parentnet-p2p/transmission: add 4.0.0_beta3 (diff)
downloadgentoo-1becd03f557139fe1a646d142b4b216ed4b88e2a.tar.gz
gentoo-1becd03f557139fe1a646d142b4b216ed4b88e2a.tar.bz2
gentoo-1becd03f557139fe1a646d142b4b216ed4b88e2a.zip
app-accessibility/orca: Version bump to 43.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28972 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/orca/Manifest1
-rw-r--r--app-accessibility/orca/orca-43.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index 758d2a5afbd0..3d8c7154bbfb 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1 +1,2 @@
DIST orca-43.0.tar.xz 3758480 BLAKE2B 05c31777c1c88452e165bd7fb6fe75fe727149f5337828b5f4e7679430ed5065a03de7074536c4433bedd81c3090c72e02a775db46f4673d6e3264a57732ad7a SHA512 20248e6065c1daa9c3d6ba37515bab60a3ceb14065b862d6d0610a7659bddc04f49a1cda7850646b45bb0afb5c2a89f1894de96f505831b11b77d332adb747d3
+DIST orca-43.1.tar.xz 3761604 BLAKE2B 924fce7c03abe51b46c406f9627f78a18700ad980adc52d9b522cecf73d07a978f4546fd3aec77ab92217627642928ba2ffb2ee73bb7a25163fb3610fa57cb9b SHA512 5d3ade5ae3c4f9b7ed8dfcabddbf7bcf5e2e15e731e0d9c1c69da692e9ce70d270aedcbfc8557a56ca0f2935b2c0c84e21fa4c6db64ec1c01c78dda7a429623f
diff --git a/app-accessibility/orca/orca-43.1.ebuild b/app-accessibility/orca/orca-43.1.ebuild
new file mode 100644
index 000000000000..cde3d66e714d
--- /dev/null
+++ b/app-accessibility/orca/orca-43.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.46:2[introspection]
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}