summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/analog/analog-6.0-r4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/analog/analog-6.0-r4.ebuild')
-rw-r--r--app-admin/analog/analog-6.0-r4.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-admin/analog/analog-6.0-r4.ebuild b/app-admin/analog/analog-6.0-r4.ebuild
new file mode 100644
index 000000000000..344dd3829a6f
--- /dev/null
+++ b/app-admin/analog/analog-6.0-r4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A webserver log analyzer"
+HOMEPAGE="http://www.analog.cx/"
+SRC_URI="http://www.analog.cx/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND=">=dev-libs/libpcre-3.4
+ >=media-libs/gd-1.8.4-r2[jpeg,png]
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cd src/
+ epatch "${FILESDIR}/${PN}-5.1-gentoo.diff"
+ epatch "${FILESDIR}/${P}-bzip2.patch"
+ epatch "${FILESDIR}/${P}-undefined-macro.patch"
+
+ sed -i Makefile \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ tc-export CC
+ # emake in main dir just executes "cd src && make",
+ # i.e. MAKEOPTS are ignored
+ emake -C src
+}
+
+src_install() {
+ dobin analog
+ newman analog.man analog.1
+
+ dodoc README.txt Licence.txt analog.cfg
+ dohtml -a html,gif,css,ico docs/*
+ dohtml -r how-to
+ dodoc -r examples
+ docinto cgi ; dodoc anlgform.pl
+
+ insinto /usr/share/analog/images ; doins images/*
+ insinto /usr/share/analog/lang ; doins lang/*
+ dodir /var/log/analog
+ dosym /usr/share/analog/images /var/log/analog/images
+ insinto /etc/analog ; doins "${FILESDIR}/analog.cfg"
+}