summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-12-14 12:28:29 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-12-14 12:28:45 -0600
commitf0a0b066fe74c6f5e3149a327cac1f1833695543 (patch)
tree67c82b7ce30af5b273695b3b4d290ec1b371d7b4 /app-admin/ansible/ansible-2.9.0.ebuild
parentdev-util/pkgcheck: Add missing any-of dep on snakeoil (diff)
downloadgentoo-f0a0b066fe74c6f5e3149a327cac1f1833695543.tar.gz
gentoo-f0a0b066fe74c6f5e3149a327cac1f1833695543.tar.bz2
gentoo-f0a0b066fe74c6f5e3149a327cac1f1833695543.zip
app-admin/ansible: 2.7.15 2.8.7 2.9.1 stable amd64/x86 with cleanup
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible/ansible-2.9.0.ebuild')
-rw-r--r--app-admin/ansible/ansible-2.9.0.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/app-admin/ansible/ansible-2.9.0.ebuild b/app-admin/ansible/ansible-2.9.0.ebuild
deleted file mode 100644
index 030cf12fa434..000000000000
--- a/app-admin/ansible/ansible-2.9.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~x64-macos"
-IUSE="doc test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile_all() {
- if use doc; then
- cd docs/docsite || die
- export CPUS=4
- emake -f Makefile.sphinx html
- fi
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
- distutils-r1_python_install_all
-
- dodoc -r examples
-}