summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-16 04:10:40 +0000
committerSam James <sam@gentoo.org>2023-02-16 04:10:40 +0000
commit096783dc3ddf40f5d970922f2cc4ac2192c9c0be (patch)
tree2fafa68845d2cfb5af80bdc9645e3443ebe8f524 /app-admin/apachetop
parentapp-antivirus/clamav: Stabilize 0.103.8 ppc, #894664 (diff)
downloadgentoo-096783dc3ddf40f5d970922f2cc4ac2192c9c0be.tar.gz
gentoo-096783dc3ddf40f5d970922f2cc4ac2192c9c0be.tar.bz2
gentoo-096783dc3ddf40f5d970922f2cc4ac2192c9c0be.zip
app-admin/apachetop: add 0.23.2
Closes: https://bugs.gentoo.org/886531 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/apachetop')
-rw-r--r--app-admin/apachetop/Manifest1
-rw-r--r--app-admin/apachetop/apachetop-0.23.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/apachetop/Manifest b/app-admin/apachetop/Manifest
index 3b37485c6fe9..60760ae14846 100644
--- a/app-admin/apachetop/Manifest
+++ b/app-admin/apachetop/Manifest
@@ -1 +1,2 @@
DIST apachetop-0.19.7.tar.gz 132665 BLAKE2B 248247c361d1585de68a0a9adae22f98db72991babfb4a75f01fa67ef28443a3c04cf1da9c1ea34ed923599955b58959528cc9e0a881fbb7b463b1d64c0cb7bd SHA512 40d546facee23a9914483c06323940e219602518751d80f729d835c4dbf991c7d1dd9bcebcaa4ca6a2d64799d48c8a00d421bc324afc2959691c962113386969
+DIST apachetop-0.23.2.tar.gz 169381 BLAKE2B fd524e8b313c8536bf016ab481f93d73ff32f256634b9fcc28c035207fda6821298087c240227508c1ab6fb7f80a0879945cc931125204bf81c3897b3d33408e SHA512 c278b6fc286eacb69746547e562c40eec50e7ff55df22a32e9387af057c25801e331c6c4b286726aa1bcee6ebcd3578747aca25be3dfec1745b876e95696d7fc
diff --git a/app-admin/apachetop/apachetop-0.23.2.ebuild b/app-admin/apachetop/apachetop-0.23.2.ebuild
new file mode 100644
index 000000000000..53d345d859e7
--- /dev/null
+++ b/app-admin/apachetop/apachetop-0.23.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A realtime Apache log analyzer"
+HOMEPAGE="https://github.com/tessus/apachetop"
+SRC_URI="https://github.com/tessus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="fam pcre"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ sys-libs/readline:=
+ fam? ( virtual/fam )
+ pcre? ( dev-libs/libpcre2 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-logfile="${EPREFIX}"/var/log/apache2/access_log \
+ --without-adns \
+ $(use_with fam) \
+ $(use_with pcre pcre2)
+}