summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2022-04-26 09:15:03 +0200
committerAgostino Sarubbo <ago@gentoo.org>2022-04-26 09:15:03 +0200
commitf06a3bb600ab7734f63a50e1040b4ae8de619ff6 (patch)
tree44bec2e0fa846aa909ce5a9819c2c85f41a9647f /app-admin/exo/exo-1.53.0.ebuild
parentdev-cpp/glog: amd64 stable wrt bug #840927 (diff)
downloadgentoo-f06a3bb600ab7734f63a50e1040b4ae8de619ff6.tar.gz
gentoo-f06a3bb600ab7734f63a50e1040b4ae8de619ff6.tar.bz2
gentoo-f06a3bb600ab7734f63a50e1040b4ae8de619ff6.zip
app-admin/exo: version bump to 1.53.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin/exo/exo-1.53.0.ebuild')
-rw-r--r--app-admin/exo/exo-1.53.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/exo/exo-1.53.0.ebuild b/app-admin/exo/exo-1.53.0.ebuild
new file mode 100644
index 000000000000..6149acedfa18
--- /dev/null
+++ b/app-admin/exo/exo-1.53.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}