summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2023-04-16 13:27:55 -0700
committerJohn Helmert III <ajak@gentoo.org>2023-04-16 13:32:48 -0700
commit2a9545df6b18c00c5f6963fb16d8600b056f79b9 (patch)
treea81e247e57a4bd2912ecb696208babdcc8cb4dfc /app-admin/gopass
parentwww-client/vivaldi-snapshot: Drop old 5.8.2978.3 (diff)
downloadgentoo-2a9545df6b18c00c5f6963fb16d8600b056f79b9.tar.gz
gentoo-2a9545df6b18c00c5f6963fb16d8600b056f79b9.tar.bz2
gentoo-2a9545df6b18c00c5f6963fb16d8600b056f79b9.zip
app-admin/gopass: add 1.15.5
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'app-admin/gopass')
-rw-r--r--app-admin/gopass/Manifest2
-rw-r--r--app-admin/gopass/gopass-1.15.5.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-admin/gopass/Manifest b/app-admin/gopass/Manifest
index 08d8376794ab..88d16640281d 100644
--- a/app-admin/gopass/Manifest
+++ b/app-admin/gopass/Manifest
@@ -2,3 +2,5 @@ DIST gopass-1.15.3-deps.tar.xz 36970888 BLAKE2B e338ba7a6a248694d33116a68aefc3ab
DIST gopass-1.15.3.tar.gz 2293686 BLAKE2B f6a5191dbb6642f448103d0b5017d792be2d7ab7d1156ceeebe52dc7bdaf9b027bf417982f0eb7a189ad09a8df06eab1fc2a637c8219a72721d583542ab51372 SHA512 1638c681c4343ff42247d7de5c153e9f992d34fc46b97a5199047c38f2658d968e8bd81029447f7768b39bf432464eb2a24d25215a7cff228e108b3ca4536220
DIST gopass-1.15.4-deps.tar.xz 34045072 BLAKE2B d8525a166df31c99b20a1a7262c2e287b7e429dcd010183585fbac7e58ae8ce4d5430fb936da0b9a85fd8a2f0ff08555d02140a649fddc07c818e11b3bcdb287 SHA512 0953101962d77116e788858652a98ffa3b8c0bd58137f59791da45d6e73cfd5fa39e40edd400c5d881cc549fc1b155b17dda48c6f59d9e06b6c000b259098d2a
DIST gopass-1.15.4.tar.gz 2301976 BLAKE2B f947d0e7b7ba599743404a231d9b09380d0069489543e1cc306eb11a3dbf369368dc8c8a464abac04558907fa6c93982a56575b79b7920ee84a46c94beb815ae SHA512 c6cf67de3b3ace253822ea9890a50ecbd2829eb7b625d05327d1b3549ed3ff6b84d1155f71276fa94b6392012b0c87b4b9e488ca0d14915d40af77fc21325603
+DIST gopass-1.15.5-deps.tar.xz 182300292 BLAKE2B 12878d90f59c1e15f18eefed331ffcb195292f9895243918cf6e66cc0d90b95bf0b0fa098ba80fb77ec559476c88b79e56102f191bfee6f6b68ef00dbcd7572b SHA512 1ba502d9074fd722c82a998791d291b2fba98c35339f404757b7ae10b3bb8971329e4a8c74bcf4b589e67dede0bf04b240d8a3db9812f4aa75bbd7f7ef9c1c51
+DIST gopass-1.15.5.tar.gz 2304217 BLAKE2B bc20ce1f738e01800def34dac131199c249742cb1383af8bd97b0f441b47163b10ba2a3cc41962c933e343b88ce37c60c74665a599724353f3d5a245cc42cc75 SHA512 4e99db0020e87cb494fa33e6d63a6d3d7af10ebff79a32c95bfb18201f881c5e99ce6593c87cb43a6aa2f38bfcae23b1496eee9fbc88026aad41871ca83a94be
diff --git a/app-admin/gopass/gopass-1.15.5.ebuild b/app-admin/gopass/gopass-1.15.5.ebuild
new file mode 100644
index 000000000000..c54c2b1d89a1
--- /dev/null
+++ b/app-admin/gopass/gopass-1.15.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module optfeature
+
+DESCRIPTION="a simple but powerful password manager for the terminal"
+HOMEPAGE="https://www.gopass.pw/"
+SRC_URI="https://github.com/gopasspw/gopass/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~ajak/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD MPL-2.0 BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+DEPEND=">=dev-lang/go-1.18"
+RDEPEND="
+ dev-vcs/git
+ >=app-crypt/gnupg-2
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.15.3-skip-tests.patch"
+)
+
+src_test() {
+ # https://github.com/gopasspw/gopass/blob/v1.15.3/.github/workflows/build.yml#L38
+ git config --global user.name nobody || die
+ git config --global user.email foo.bar@example.org || die
+
+ default
+}
+
+src_install() {
+ emake install DESTDIR="${ED}/usr"
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "browser integration" app-admin/gopass-jsonapi
+ optfeature "git credentials helper" app-admin/git-credential-gopass
+ optfeature "haveibeenpwnd.com integration" app-admin/gopass-hibp
+ optfeature "summon secrets helper" app-admin/gopass-summon-provider
+}