summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-10 08:48:55 +0100
committerSam James <sam@gentoo.org>2022-07-10 08:49:05 +0100
commit2bfdcf9b723a2ba16bffa03a1a4597ce818e89ea (patch)
treeaa28bcace38dcf8d0af641655a89b1188b9f1d82 /app-admin/pwgen
parentmedia-libs/libdvbpsi: drop 1.3.2 (diff)
downloadgentoo-2bfdcf9b723a2ba16bffa03a1a4597ce818e89ea.tar.gz
gentoo-2bfdcf9b723a2ba16bffa03a1a4597ce818e89ea.tar.bz2
gentoo-2bfdcf9b723a2ba16bffa03a1a4597ce818e89ea.zip
app-admin/pwgen: update EAPI 6 -> 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/pwgen')
-rw-r--r--app-admin/pwgen/pwgen-2.08-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-admin/pwgen/pwgen-2.08-r1.ebuild b/app-admin/pwgen/pwgen-2.08-r1.ebuild
new file mode 100644
index 000000000000..c9004c9dec93
--- /dev/null
+++ b/app-admin/pwgen/pwgen-2.08-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Password Generator"
+HOMEPAGE="https://sourceforge.net/projects/pwgen/"
+SRC_URI="mirror://sourceforge/pwgen/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="livecd"
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/etc/pwgen
+}
+
+src_install() {
+ default
+
+ use livecd && newinitd "${FILESDIR}"/pwgen.rc pwgen
+}