summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-02-21 09:21:50 +0100
committerMikle Kolyada <zlogene@gentoo.org>2020-02-21 21:37:56 +0300
commit6149dab136a2f73c4b5096b5d786ae4138c9a7d1 (patch)
tree1762cc92cbf7f2999dec1bc8c01e93ffeb33ed66 /app-admin/terraform/terraform-0.12.21.ebuild
parentmail-filter/procmail: replace sed separators (diff)
downloadgentoo-6149dab136a2f73c4b5096b5d786ae4138c9a7d1.tar.gz
gentoo-6149dab136a2f73c4b5096b5d786ae4138c9a7d1.tar.bz2
gentoo-6149dab136a2f73c4b5096b5d786ae4138c9a7d1.zip
app-admin/terraform: bump to 0.12.21
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-admin/terraform/terraform-0.12.21.ebuild')
-rw-r--r--app-admin/terraform/terraform-0.12.21.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-admin/terraform/terraform-0.12.21.ebuild b/app-admin/terraform/terraform-0.12.21.ebuild
new file mode 100644
index 000000000000..4196f78931b6
--- /dev/null
+++ b/app-admin/terraform/terraform-0.12.21.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-base go-module
+
+DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
+HOMEPAGE="https://www.terraform.io/"
+
+EGO_PN="github.com/hashicorp/${PN}"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 imagemagick ISC JSON MIT MIT-with-advertising MPL-2.0 unicode"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_prepare() {
+ default
+ # the sed command is necessary to generate tests outside of the
+ # default git root of `terraform', in our case the working dir
+ # is `work/$PN-$PV'
+ # sed -i -e "s/!=\s\+\"terraform\"/!=\ \"${P}\"/" \
+ # ./scripts/generate-plugins.go || die
+}
+
+src_compile() {
+ GOCACHE="${T}/go-cache" go build \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/terraform
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "If you would like to install shell completions please run:"
+ elog " terraform -install-autocomplete"
+}