summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-13 18:15:05 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-13 19:41:47 +0100
commit37e90f47ce2646c4409b0f1a856b56dc85d7a87e (patch)
tree769b0592028ffd520b0ce4e275c5ace2b6312b25 /app-arch/lunzip
parentdev-python/pyzmq: Disable adding RPATH (diff)
downloadgentoo-37e90f47ce2646c4409b0f1a856b56dc85d7a87e.tar.gz
gentoo-37e90f47ce2646c4409b0f1a856b56dc85d7a87e.tar.bz2
gentoo-37e90f47ce2646c4409b0f1a856b56dc85d7a87e.zip
app-arch/lunzip: Bump to 1.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/lunzip')
-rw-r--r--app-arch/lunzip/Manifest2
-rw-r--r--app-arch/lunzip/lunzip-1.15.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/lunzip/Manifest b/app-arch/lunzip/Manifest
index a0288d57857a..daa81277fe95 100644
--- a/app-arch/lunzip/Manifest
+++ b/app-arch/lunzip/Manifest
@@ -1,2 +1,4 @@
DIST lunzip-1.14.tar.gz 69284 BLAKE2B 8ef63a5cfd0cf839889785845ec84b23451cb69b1e09c84526e000b82b73aaaa01b99407e87bde416ca2ab638d9f9688fcb37f77fd53e2a8e0875646a54d304c SHA512 2aa530c4ef7ebcfa345c8ac8701712e7f973ee4a92d34c33a03dd02a31d76507c919da373b64bc6b49b7868af8e4444d4b12bd71b8760e9b333c2a013ad95da1
DIST lunzip-1.14.tar.gz.sig 72 BLAKE2B ab2ba6c265f197c322884898ae8ff5c8679ab8a1d2f71a2dfedcce9011e16fb723fd592b0edc3f48d540ad8d2578b799f28f9d609a7e26379e39e0cb7f908cc3 SHA512 38806848f904fb3700c908166a1ad2d601409fa13f1b0dc69372766b41a6f37ae0c5792964b8aae494320d47e603dc79f36b3fa7361ccf84b89835c14a6b7b11
+DIST lunzip-1.15.tar.gz 59612 BLAKE2B cd39d5cab04244c1c7303393f8ca56f9530d5283123a2745de18f675a1c1971f57295df1f83952cf9677c1752ff00b65d01741a09ddac65cebfea719e16e33e9 SHA512 737eec2a62f068aa1ef6ec316a04b7caa90ce99d7a7292d2358568bad455342d38dd82aae468123bd121240b12c6db0bd499e1f2f9e483d5d7540a40e5f00603
+DIST lunzip-1.15.tar.gz.sig 72 BLAKE2B e20a81167ca436c1b666f22ae608abd02b9853ef80025f98ce283c7f120277b5a202d0769b05aa763929ecf4bde662f26a6ec313ebd46bf4bf87c1e28fcc21c2 SHA512 9287496313576f5f09271bbee6ba3657e9e3ceffb118758807d4e8fbe011eba550d46c04c2193c30177f5b191850d5a53f7bea02776a3f339eee827f6744104a
diff --git a/app-arch/lunzip/lunzip-1.15.ebuild b/app-arch/lunzip/lunzip-1.15.ebuild
new file mode 100644
index 000000000000..a1bbbf0f32bc
--- /dev/null
+++ b/app-arch/lunzip/lunzip-1.15.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/antoniodiazdiaz.asc
+inherit toolchain-funcs verify-sig
+
+DESCRIPTION="Decompressor for the lzip format, written in C"
+HOMEPAGE="https://www.nongnu.org/lzip/lunzip.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/lunzip/${P}.tar.gz"
+SRC_URI+=" verify-sig? ( https://download.savannah.gnu.org/releases/lzip/${PN}/${P/_/-}.tar.gz.sig )"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-antoniodiazdiaz )"
+
+src_configure() {
+ # not autotools-based
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CC="$(tc-getCC)"
+ CPPFLAGS="${CPPFLAGS}"
+ CFLAGS="${CFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ ./configure "${myconf[@]}" || die
+}