summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-07 22:01:07 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-07 22:01:07 +0100
commit6f1e469d60041f416c19a17a8990220daccf4c95 (patch)
treeb6988ccfaf2127becf04c9e2a24167322755c3a0 /app-arch/plzip/plzip-1.9.ebuild
parentdev-libs/libxml2: drop x86-winnt bits (diff)
downloadgentoo-6f1e469d60041f416c19a17a8990220daccf4c95.tar.gz
gentoo-6f1e469d60041f416c19a17a8990220daccf4c95.tar.bz2
gentoo-6f1e469d60041f416c19a17a8990220daccf4c95.zip
app-arch/plzip: Bump to 1.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/plzip/plzip-1.9.ebuild')
-rw-r--r--app-arch/plzip/plzip-1.9.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-arch/plzip/plzip-1.9.ebuild b/app-arch/plzip/plzip-1.9.ebuild
new file mode 100644
index 000000000000..07980c802cd0
--- /dev/null
+++ b/app-arch/plzip/plzip-1.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Parallel lzip compressor"
+HOMEPAGE="https://www.nongnu.org/lzip/plzip.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="app-arch/lzlib:0="
+DEPEND=${RDEPEND}
+
+src_configure() {
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CXX="$(tc-getCXX)"
+ CPPFLAGS="${CPPFLAGS}"
+ CXXFLAGS="${CXXFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ # not autotools-based
+ ./configure "${myconf[@]}" || die
+}