summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2024-04-11 09:55:13 +0300
committerYixun Lan <dlan@gentoo.org>2024-04-11 21:43:43 +0000
commite61b1991025e879f7c039f548421043fb7d5b6a7 (patch)
treec2646d6d0ebb046cc6245e8e71a167622d2c5285 /app-arch/snappy
parentx11-libs/libXaw: Stabilize 1.0.16 arm64, #929188 (diff)
downloadgentoo-e61b1991025e879f7c039f548421043fb7d5b6a7.tar.gz
gentoo-e61b1991025e879f7c039f548421043fb7d5b6a7.tar.bz2
gentoo-e61b1991025e879f7c039f548421043fb7d5b6a7.zip
app-arch/snappy: drop 1.1.9-r1
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-arch/snappy')
-rw-r--r--app-arch/snappy/Manifest1
-rw-r--r--app-arch/snappy/files/snappy-1.1.9_gcc_inline.patch67
-rw-r--r--app-arch/snappy/snappy-1.1.9-r1.ebuild46
3 files changed, 0 insertions, 114 deletions
diff --git a/app-arch/snappy/Manifest b/app-arch/snappy/Manifest
index 2b0fde8309f0..24675ae6e384 100644
--- a/app-arch/snappy/Manifest
+++ b/app-arch/snappy/Manifest
@@ -1,2 +1 @@
DIST snappy-1.1.10.tar.gz 1105312 BLAKE2B 5195335fb1883974d290e7dca2b6d928bde2b183f3f61bca9da28855b39fd9a4ee1c24014322d238d2ec94f3a3a55fd43110c88283e85865272226e11cbb4834 SHA512 3578597f1d4ec09104ce0296b825b013590351230dfe56c635081fd282ce7a13a34caf2c283ac77bd24065e2d27af6db068d1f84b98cec2fd39a0e37a0d77070
-DIST snappy-1.1.9.tar.gz 1102382 BLAKE2B 926d03156168e3d4800dc17144db3de2c182c6eb9970d87a00b94fb09b67e403479a64cbed75833b83fd03173c1bb8caaf248a55627e89fe2a34456f12ff3b42 SHA512 f1f8a90f5f7f23310423574b1d8c9acb84c66ea620f3999d1060395205e5760883476837aba02f0aa913af60819e34c625d8308c18a5d7a9c4e190f35968b024
diff --git a/app-arch/snappy/files/snappy-1.1.9_gcc_inline.patch b/app-arch/snappy/files/snappy-1.1.9_gcc_inline.patch
deleted file mode 100644
index 04d35f56ee98..000000000000
--- a/app-arch/snappy/files/snappy-1.1.9_gcc_inline.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 0c716d435abe65250100c2caea0e5126ac4e14bd Mon Sep 17 00:00:00 2001
-From: "Georgi D. Sotirov" <gdsotirov@gmail.com>
-Date: Wed, 5 May 2021 14:16:46 +0300
-Subject: [PATCH] Add inline with SNAPPY_ATTRIBUTE_ALWAYS_INLINE
-
-Add inline with SNAPPY_ATTRIBUTE_ALWAYS_INLINE on AdvanceToNextTag to
-fix the following compilation errors and a warning with GCC:
-
-[ 2%] Building CXX object CMakeFiles/snappy.dir/snappy.cc.o
-/usr/bin/c++ -DHAVE_CONFIG_H -Dsnappy_EXPORTS
--I/tmp/snappy-1.1.9/build -I/tmp/snappy-1.1.9 -O3
--march=i586 -mtune=i686 -Wall -Wextra -fno-exceptions -fno-rtti -O3
--DNDEBUG -fPIC -std=c++11 -o CMakeFiles/snappy.dir/snappy.cc.o -c
-/tmp/snappy-1.1.9/snappy.cc
-/tmp/snappy-1.1.9/snappy.cc:1017:8: warning: always_inline
-function might not be inlinable [-Wattributes]
- size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
- ^
-/tmp/snappy-1.1.9/snappy.cc: In function 'std::pair<const
-unsigned char*, int> snappy::DecompressBranchless(const uint8_t*, const
-uint8_t*, ptrdiff_t, T, ptrdiff_t) [with T = char*; uint8_t = unsigned
-char; ptrdiff_t = int]':
-/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
-call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
-size_t*)': function body can be overwritten at link time
-/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
- size_t tag_type = AdvanceToNextTag(&ip, &tag);
- ^
-/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
-call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
-size_t*)': function body can be overwritten at link time
- size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
- ^
-/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
- size_t tag_type = AdvanceToNextTag(&ip, &tag);
- ^
-/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
-call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
-size_t*)': function body can be overwritten at link time
- size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
- ^
-/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
- size_t tag_type = AdvanceToNextTag(&ip, &tag);
- ^
-CMakeFiles/snappy.dir/build.make:137: recipe for target
-'CMakeFiles/snappy.dir/snappy.cc.o' failed
-
-Just like with other functions using SNAPPY_ATTRIBUTE_ALWAYS_INLINE
-macro (i.e. __attribute__((always_inline)) ) it is necessary to use C++
-inline specifier.
----
- snappy.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/snappy.cc b/snappy.cc
-index 79dc0e8..51157be 100644
---- a/snappy.cc
-+++ b/snappy.cc
-@@ -1014,7 +1014,7 @@ void MemMove(ptrdiff_t dst, const void* src, size_t size) {
- }
-
- SNAPPY_ATTRIBUTE_ALWAYS_INLINE
--size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
-+inline size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
- const uint8_t*& ip = *ip_p;
- // This section is crucial for the throughput of the decompression loop.
- // The latency of an iteration is fundamentally constrained by the
diff --git a/app-arch/snappy/snappy-1.1.9-r1.ebuild b/app-arch/snappy/snappy-1.1.9-r1.ebuild
deleted file mode 100644
index b6cbd7792108..000000000000
--- a/app-arch/snappy/snappy-1.1.9-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-DESCRIPTION="A high-speed compression/decompression library by Google"
-HOMEPAGE="https://github.com/google/snappy"
-SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV%%.*}"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-cpp/gtest )"
-
-DOCS=( format_description.txt framing_format.txt NEWS README.md )
-
-PATCHES=(
- "${FILESDIR}/${P}_gcc_inline.patch"
- "${FILESDIR}/${P}_external_gtest.patch"
- "${FILESDIR}/${P}-clang-werror.patch"
- "${FILESDIR}/${P}_remove-no-rtti.patch"
-)
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DCMAKE_CXX_STANDARD=14 # Latest gtest needs -std=c++14 or newer
- -DSNAPPY_BUILD_TESTS=$(usex test)
- -DSNAPPY_BUILD_BENCHMARKS=OFF
- # Options below are related to benchmarking, that we disable.
- -DHAVE_LIBZ=NO
- -DHAVE_LIBLZO2=NO
- -DHAVE_LIBLZ4=NO
- )
- cmake_src_configure
-}
-
-multilib_src_test() {
- # run tests directly to get verbose output
- cd "${S}" || die
- "${BUILD_DIR}"/snappy_unittest || die
-}