summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-01 20:25:54 +0000
committerSam James <sam@gentoo.org>2022-11-01 20:26:36 +0000
commit181fb059e9924236f81f552e49ef26d11e998509 (patch)
treefc26c8d0d2faf7bbbde9b39dc9e5f13ca514ed11 /app-arch/upx
parentsys-kernel/gentoo-sources: add 5.4.222 (diff)
downloadgentoo-181fb059e9924236f81f552e49ef26d11e998509.tar.gz
gentoo-181fb059e9924236f81f552e49ef26d11e998509.tar.bz2
gentoo-181fb059e9924236f81f552e49ef26d11e998509.zip
app-arch/upx: simplify testing
- No need for IUSE=test & RESTRICT unless we're doing something conditionally like building tests. Running tests is always conditional on FEATURES=test. - Pass argument to cmake_src_test instead of calling ctest directly for -j1. Bug: https://bugs.gentoo.org/878977 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/upx')
-rw-r--r--app-arch/upx/upx-4.0.0.ebuild6
1 files changed, 1 insertions, 5 deletions
diff --git a/app-arch/upx/upx-4.0.0.ebuild b/app-arch/upx/upx-4.0.0.ebuild
index 45118519051f..04a011030c35 100644
--- a/app-arch/upx/upx-4.0.0.ebuild
+++ b/app-arch/upx/upx-4.0.0.ebuild
@@ -13,15 +13,11 @@ S="${WORKDIR}/${P}-src"
LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="test"
-
-RESTRICT="!test? ( test )"
RDEPEND="!app-arch/upx-bin"
BDEPEND="app-arch/xz-utils[extra-filters]"
src_test() {
# Don't run tests in parallel, #878977
- cd "${BUILD_DIR}" || die
- ctest || die
+ cmake_src_test -j1
}