summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-07-29 21:59:39 +0200
committerFabian Groffen <grobian@gentoo.org>2024-07-29 21:59:39 +0200
commit7a5e420e408012a569f8170b8138c318abcebda7 (patch)
tree9ce5718e3decb8bf1046dbe31d0c4f9bec089b5d /app-arch
parentapp-crypt/gnupg-2.4.5-r2: accept pointer type differences on Solaris (diff)
downloadgentoo-7a5e420e408012a569f8170b8138c318abcebda7.tar.gz
gentoo-7a5e420e408012a569f8170b8138c318abcebda7.tar.bz2
gentoo-7a5e420e408012a569f8170b8138c318abcebda7.zip
app-arch/libarchive-3.7.4: add patch from upstream for INT_MAX usage
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/libarchive/files/libarchive-3.7.4-INT_MAX.patch26
-rw-r--r--app-arch/libarchive/libarchive-3.7.4.ebuild2
2 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/libarchive/files/libarchive-3.7.4-INT_MAX.patch b/app-arch/libarchive/files/libarchive-3.7.4-INT_MAX.patch
new file mode 100644
index 000000000000..150216b3344d
--- /dev/null
+++ b/app-arch/libarchive/files/libarchive-3.7.4-INT_MAX.patch
@@ -0,0 +1,26 @@
+From 6ff1cd1e487ddf545337b88da3f1f5ca69a2f958 Mon Sep 17 00:00:00 2001
+From: Tim Kientzle <kientzle@acm.org>
+Date: Mon, 6 May 2024 20:46:26 -0700
+Subject: [PATCH] Define INT_MAX via `#include <limits.h>` (#2170)
+
+#2110 added usages of INT_MAX here without adding the necessary header.
+
+Resolves #2162
+---
+ tar/bsdtar.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/tar/bsdtar.c b/tar/bsdtar.c
+index 42baab286..f0e71afd1 100644
+--- a/tar/bsdtar.c
++++ b/tar/bsdtar.c
+@@ -43,6 +43,9 @@
+ #ifdef HAVE_LANGINFO_H
+ #include <langinfo.h>
+ #endif
++#ifdef HAVE_LIMITS_H
++#include <limits.h>
++#endif
+ #ifdef HAVE_LOCALE_H
+ #include <locale.h>
+ #endif
diff --git a/app-arch/libarchive/libarchive-3.7.4.ebuild b/app-arch/libarchive/libarchive-3.7.4.ebuild
index 7c609d3a3f58..695219f457cd 100644
--- a/app-arch/libarchive/libarchive-3.7.4.ebuild
+++ b/app-arch/libarchive/libarchive-3.7.4.ebuild
@@ -74,6 +74,8 @@ PATCHES=(
# https://github.com/libarchive/libarchive/issues/2069
# (we can simply update the command since we don't support old lrzip)
"${FILESDIR}/${PN}-3.7.2-lrzip.patch"
+ # https://github.com/libarchive/libarchive/commit/6ff1cd1e487ddf545337b88da3f1f5ca69a2f958
+ "${FILESDIR}/${PN}-3.7.4-INT_MAX.patch"
)
src_prepare() {