summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-03-20 17:50:43 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-03-20 17:51:19 -0400
commit02ba85d880d88de79561b93e5a449d02687855c8 (patch)
tree1b6ee7b2d8a2e1472c6ada2b11424774a9661584 /app-backup/borgbackup/borgbackup-9999.ebuild
parentapp-emulation/docker-compose: remove version 1.4.0 (diff)
downloadgentoo-02ba85d880d88de79561b93e5a449d02687855c8.tar.gz
gentoo-02ba85d880d88de79561b93e5a449d02687855c8.tar.bz2
gentoo-02ba85d880d88de79561b93e5a449d02687855c8.zip
app-backup/borgbackup: initial commit
Borg is a fork of attic. Attic may be dead upstream while borg is currently actively being maintained. Package-Manager: portage-2.2.26
Diffstat (limited to 'app-backup/borgbackup/borgbackup-9999.ebuild')
-rw-r--r--app-backup/borgbackup/borgbackup-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-backup/borgbackup/borgbackup-9999.ebuild b/app-backup/borgbackup/borgbackup-9999.ebuild
new file mode 100644
index 000000000000..5267b911de82
--- /dev/null
+++ b/app-backup/borgbackup/borgbackup-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/borgbackup/borg.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/b/borgbackup/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Deduplicating backup program with compression and authenticated encryption."
+HOMEPAGE="https://borgbackup.github.io/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="libressl +fuse"
+
+RDEPEND="
+ app-arch/lz4
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ fuse? ( dev-python/llfuse[${PYTHON_USEDEP}] )
+"
+
+DEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ ${RDEPEND}
+"