summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/cpdup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/cpdup')
-rw-r--r--app-backup/cpdup/Manifest1
-rw-r--r--app-backup/cpdup/cpdup-1.18.ebuild46
-rw-r--r--app-backup/cpdup/files/Makefile.linux13
-rw-r--r--app-backup/cpdup/files/cpdup-1.11-unused.patch14
-rw-r--r--app-backup/cpdup/metadata.xml5
5 files changed, 79 insertions, 0 deletions
diff --git a/app-backup/cpdup/Manifest b/app-backup/cpdup/Manifest
new file mode 100644
index 000000000000..bd75b7fc18eb
--- /dev/null
+++ b/app-backup/cpdup/Manifest
@@ -0,0 +1 @@
+DIST cpdup-1.18.tgz 42841 SHA256 3893de9a8ebe5543b9b11c4b575075e59509ddb0f26e6229b2554ee625d25687 SHA512 5c57be20951005d731866629a601b6dae91e112067f103d6cfc3f668fbd88b3b7b65990d9fad55f18c0e8238c2642a7b85aea543a0787f21084bda35e0da0e26 WHIRLPOOL 66b8b3ae3bbb5c6dbae52e4de7e107728733ab429bbd61d658599de74355bbd0889c283f58548873b12b97b662ee9d565182291f19d3b998d3b014b27448a5c4
diff --git a/app-backup/cpdup/cpdup-1.18.ebuild b/app-backup/cpdup/cpdup-1.18.ebuild
new file mode 100644
index 000000000000..629aede8ee1e
--- /dev/null
+++ b/app-backup/cpdup/cpdup-1.18.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A comprehensive filesystem mirroring program"
+HOMEPAGE="http://apollo.backplane.com/FreeSrc/"
+SRC_URI="http://apollo.backplane.com/FreeSrc/${P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86-fbsd ~amd64"
+IUSE="userland_GNU threads"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.11-unused.patch
+
+ if use userland_GNU; then
+ cp "${FILESDIR}"/Makefile.linux Makefile
+ # bits/stat.h has __unused too
+ sed -i 's/__unused/__cpdup_unused/' *.c
+ echo "#define strlcpy(a,b,c) strncpy(a,b,c)" >> cpdup.h
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ use threads || MAKEOPTS="$MAKEOPTS NOPTHREADS=1"
+ MAKE=make emake || die "emake failed"
+}
+
+src_install() {
+ dobin cpdup || die "cannot install cpdup"
+ doman cpdup.1
+ docinto scripts
+ dodoc scripts/*
+}
diff --git a/app-backup/cpdup/files/Makefile.linux b/app-backup/cpdup/files/Makefile.linux
new file mode 100644
index 000000000000..3e18e4e0b218
--- /dev/null
+++ b/app-backup/cpdup/files/Makefile.linux
@@ -0,0 +1,13 @@
+OBJS = cpdup.o fsmid.o hclink.o hcproto.o misc.o
+
+CFLAGS += -D__cpdup_unused="__attribute__ ((unused))" -D_GNU_SOURCE -D__USE_FILE_OFFSET64 -DNOMD5
+
+ifndef NOPTHREADS
+CFLAGS += -DUSE_PTHREADS=1 -pthread
+endif
+
+all: $(OBJS)
+ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) -o cpdup
+
+.c.o:
+ $(CC) $(CFLAGS) -c -o $@ $<
diff --git a/app-backup/cpdup/files/cpdup-1.11-unused.patch b/app-backup/cpdup/files/cpdup-1.11-unused.patch
new file mode 100644
index 000000000000..1757cb441adc
--- /dev/null
+++ b/app-backup/cpdup/files/cpdup-1.11-unused.patch
@@ -0,0 +1,14 @@
+--- cpdup.c.orig 2009-02-05 12:22:10.000000000 +0100
++++ cpdup.c 2009-02-05 12:23:23.000000000 +0100
+@@ -1543,7 +1543,11 @@
+ */
+
+ static int
++#ifdef _ST_FLAGS_PRESENT_
+ xrename(const char *src, const char *dst, u_long flags)
++#else
++xrename(const char *src, const char *dst, u_long flags __unused)
++#endif
+ {
+ int r;
+
diff --git a/app-backup/cpdup/metadata.xml b/app-backup/cpdup/metadata.xml
new file mode 100644
index 000000000000..ecedda4aa2cc
--- /dev/null
+++ b/app-backup/cpdup/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>bsd</herd>
+</pkgmetadata>