summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-15 07:09:16 +0100
committerSam James <sam@gentoo.org>2023-04-15 07:09:16 +0100
commit33824c7f4f0794f74d48232ed7cf0163c2ab1770 (patch)
tree884ee68ec5d4772408bbfe1abedabe255c0f360b /app-backup
parentapp-text/ttf2pt1: fix build w/ clang 16 (diff)
downloadgentoo-33824c7f4f0794f74d48232ed7cf0163c2ab1770.tar.gz
gentoo-33824c7f4f0794f74d48232ed7cf0163c2ab1770.tar.bz2
gentoo-33824c7f4f0794f74d48232ed7cf0163c2ab1770.zip
app-backup/amanda: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/amanda/amanda-3.5.1-r4.ebuild (renamed from app-backup/amanda/amanda-3.5.1-r3.ebuild)7
-rw-r--r--app-backup/amanda/files/amanda-3.5.1-configure-clang16.patch22
2 files changed, 27 insertions, 2 deletions
diff --git a/app-backup/amanda/amanda-3.5.1-r3.ebuild b/app-backup/amanda/amanda-3.5.1-r4.ebuild
index 53df15f23433..af53d4e00d12 100644
--- a/app-backup/amanda/amanda-3.5.1-r3.ebuild
+++ b/app-backup/amanda/amanda-3.5.1-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -51,7 +51,10 @@ BDEPEND="
virtual/pkgconfig
nls? ( sys-devel/gettext )"
-PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${PN}-3.5.1-configure-clang16.patch
+)
MYFILESDIR="${T}/files"
ENVDIR="/etc/env.d"
diff --git a/app-backup/amanda/files/amanda-3.5.1-configure-clang16.patch b/app-backup/amanda/files/amanda-3.5.1-configure-clang16.patch
new file mode 100644
index 000000000000..a95c8ed55aed
--- /dev/null
+++ b/app-backup/amanda/files/amanda-3.5.1-configure-clang16.patch
@@ -0,0 +1,22 @@
+https://github.com/zmanda/amanda/pull/220
+
+From 74610ac5522caa779b30323f1c731775083c5bbc Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Fri, 14 Apr 2023 15:45:16 +0200
+Subject: [PATCH] configure: Avoid an implicit int in the IPv6 test
+
+Otherwise, the test fails unconditionally with compilers that
+do not support implicit ints (a language feature that was removed with
+the C99 language revision).
+--- a/config/amanda/ipv6.m4
++++ b/config/amanda/ipv6.m4
+@@ -85,7 +85,7 @@ AC_DEFUN([AMANDA_CHECK_IPV6],
+ #include <sys/socket.h>
+ #include <errno.h>
+
+-main()
++int main(void)
+ {
+ int aa;
+ aa = socket(AF_INET6, SOCK_STREAM, 0);
+