summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2024-10-20 13:14:30 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2024-10-20 13:14:30 +0200
commita647e010c175db37a70b28802580935b0913dcd7 (patch)
tree88e8bda0eb22a724c8ee942f61c0cd27c5d98755 /app-backup
parentmedia-sound/qjackctl: dropped obsolete 1.0.1 (diff)
downloadgentoo-a647e010c175db37a70b28802580935b0913dcd7.tar.gz
gentoo-a647e010c175db37a70b28802580935b0913dcd7.tar.bz2
gentoo-a647e010c175db37a70b28802580935b0913dcd7.zip
app-backup/bacula: Drop reliance on 'which' command
Closes: https://bugs.gentoo.org/940692 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/bacula/bacula-15.0.2.ebuild3
-rw-r--r--app-backup/bacula/files/bacula-drop-which.patch12
2 files changed, 15 insertions, 0 deletions
diff --git a/app-backup/bacula/bacula-15.0.2.ebuild b/app-backup/bacula/bacula-15.0.2.ebuild
index d5c84855a449..5b3556d73298 100644
--- a/app-backup/bacula/bacula-15.0.2.ebuild
+++ b/app-backup/bacula/bacula-15.0.2.ebuild
@@ -184,6 +184,9 @@ src_prepare() {
sed -i -e "s/(INSTALL_PROGRAM) /(INSTALL_LIB) /" src/plugins/fd/Makefile ||die
sed -i -e "s/(INSTALL_PROGRAM) /(INSTALL_LIB) /" src/plugins/fd/docker/Makefile ||die
+ # drop reliance on installed 'which' program (bug #940692)
+ eapply "${FILESDIR}"/${PN}-drop-which.patch
+
# fix bundled libtool (bug 466696)
# But first move directory with M4 macros out of the way.
# It is only needed by autoconf and gives errors during elibtoolize.
diff --git a/app-backup/bacula/files/bacula-drop-which.patch b/app-backup/bacula/files/bacula-drop-which.patch
new file mode 100644
index 000000000000..0c34ddabbf61
--- /dev/null
+++ b/app-backup/bacula/files/bacula-drop-which.patch
@@ -0,0 +1,12 @@
+diff --git a/scripts/getgitcommit b/scripts/getgitcommit
+index 6897091..d82a7e5 100755
+--- a/scripts/getgitcommit
++++ b/scripts/getgitcommit
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+
+-GIT=$(which git)
++GIT=$(command -v git)
+ if [ "x$GIT" != "x" ]
+ then
+ COMMIT=$(git log --pretty=format:%h -n 1 2>/dev/null)