summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2023-08-30 14:15:26 -0400
committerRichard Freeman <rich0@gentoo.org>2023-08-30 14:15:26 -0400
commita6d242ce273d060eee0d3a5a69cbc58a88b54982 (patch)
treeca47959951e992af34c5b7de73073bb437d0c25f /app-backup
parentwww-client/firefox: force use of llvm-readelf (diff)
downloadgentoo-a6d242ce273d060eee0d3a5a69cbc58a88b54982.tar.gz
gentoo-a6d242ce273d060eee0d3a5a69cbc58a88b54982.tar.bz2
gentoo-a6d242ce273d060eee0d3a5a69cbc58a88b54982.zip
app-backup/duplicity: add 2.1.0
Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-2.1.0.ebuild51
-rw-r--r--app-backup/duplicity/files/duplicity-2.1.0-fix-docs-cmd.patch20
3 files changed, 72 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index 88a759463af9..93ecbb9e09d5 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -1,3 +1,4 @@
DIST duplicity-1.0.1.tar.gz 1928618 BLAKE2B f7ffdd488e42219b66b6174dbb944283d02910f57cae9fcf849e8f5363986664a49ba7e316d6b3efdce89deec7e4c6a65a95bcb365fa23b928244b5e8f29d48b SHA512 dab8341b990b1899de6080f2539681f0a84f1875fabf04ccd68908e8dcdf55cd31f26d1431488b49ac6b048a1e7ff2e0a0afa27f6eccfd6a20f47dd7193b4563
DIST duplicity-1.2.2.tar.gz 1427493 BLAKE2B d30f91054c59695483a60a684ebc11440b1a490dc635fdc856d7e3e75d7c3b8bc3f8680ecec0af435fe3064c292c6ff0db392e6bb33c682e9527561196e842e1 SHA512 5da4addd0742afa93c62c506f49235b396a7d4bb6576bfd5ec223e04936072ef92e874c533f0f7ece3c1460bf017c2e1875d4ed5c08181113e2509dd28b4521b
DIST duplicity-1.2.3.tar.gz 1438570 BLAKE2B 12afa69f537d2207343c1638df1cf69ad3e170b2f1368e5d8b86716ccc67564834798e2076a90f021bae8f1d8574ff50f0615fd873cdcddf1399349974d8d4c2 SHA512 d2a31b4ed2c0a188d6d2ac543d3d4a474b4c10028a3005b26f57bd57e8c7441eb96e361aa9805fedc6aa09e76e86d3d1e99800669dfb7b2510233e2c0aba15de
+DIST duplicity-2.1.0.tar.gz 1502980 BLAKE2B eb90898b75128cd4140f0ab49172da439b675cb512b03c7a449db295ffb6e0beee77773fcf364e69c9303b094ab5572a4bf72fb4fbbbfdec29bc3ab40812ab8f SHA512 c8777903935391b0968aeea562202a175625d6c2cac5cfab422ec0c9c002652b34f14f74a820971a74b2f62c58efea49d37bef3918943210fe623a12278f4ce8
diff --git a/app-backup/duplicity/duplicity-2.1.0.ebuild b/app-backup/duplicity/duplicity-2.1.0.ebuild
new file mode 100644
index 000000000000..003ceb5ad3d3
--- /dev/null
+++ b/app-backup/duplicity/duplicity-2.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_10 python3_11 )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="https://duplicity.gitlab.io/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto3[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs-cmd.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-2.1.0-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-2.1.0-fix-docs-cmd.patch
new file mode 100644
index 000000000000..538ee80f9604
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-2.1.0-fix-docs-cmd.patch
@@ -0,0 +1,20 @@
+--- duplicity-2.1.0/setup.py 2023-08-30 13:39:42.430023811 -0400
++++ duplicity-2.1.0/setup.py 2023-08-30 13:41:59.154868245 -0400
+@@ -92,17 +92,6 @@
+ 'bin/duplicity.1',
+ ]
+ ),
+- (f'share/doc/duplicity-{Version}',
+- [
+- 'CHANGELOG.md',
+- 'CONTRIBUTING.md',
+- 'COPYING',
+- 'README.md',
+- 'README-LOG.md',
+- 'README-REPO.md',
+- 'README-TESTING.md',
+- ],
+- ),
+ ]
+
+ # short circuit fot READTHEDOCS