summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2024-10-24 11:16:26 -0400
committerZac Medico <zmedico@gentoo.org>2024-10-24 12:52:10 -0700
commit4193619d18a9b6302d5285db67f5da2096a20438 (patch)
tree6a56e762694d75e69f190edda7c341de54feb27d /app-containers
parentapp-containers/podman: fix SELinux relabeling (diff)
downloadgentoo-4193619d18a9b6302d5285db67f5da2096a20438.tar.gz
gentoo-4193619d18a9b6302d5285db67f5da2096a20438.tar.bz2
gentoo-4193619d18a9b6302d5285db67f5da2096a20438.zip
app-containers/buildah: fix SELinux relabeling
The Makefile relabels the buildah executable during installation and defaults to using container_runtime_exec_t which does not exist in Gentoo's SELinux policies. Disable the automatic relabeling during install and let portage take care of it to avoid this error. Closes: https://bugs.gentoo.org/927311 Signed-off-by: Kenton Groombridge <concord@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39098 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/buildah/buildah-1.35.3.ebuild3
-rw-r--r--app-containers/buildah/buildah-1.35.4.ebuild3
-rw-r--r--app-containers/buildah/buildah-1.36.0.ebuild3
-rw-r--r--app-containers/buildah/buildah-9999.ebuild3
4 files changed, 8 insertions, 4 deletions
diff --git a/app-containers/buildah/buildah-1.35.3.ebuild b/app-containers/buildah/buildah-1.35.3.ebuild
index acfc92a67c55..36648c2ae5a7 100644
--- a/app-containers/buildah/buildah-1.35.3.ebuild
+++ b/app-containers/buildah/buildah-1.35.3.ebuild
@@ -120,6 +120,7 @@ src_compile() {
tc-export AS LD STRIP
export GOMD2MAN="$(command -v go-md2man)"
+ export SELINUXOPT=
default
}
@@ -128,6 +129,6 @@ src_test() {
}
src_install() {
- emake DESTDIR="${ED}" install install.completions
+ emake DESTDIR="${ED}" SELINUXOPT= install install.completions
einstalldocs
}
diff --git a/app-containers/buildah/buildah-1.35.4.ebuild b/app-containers/buildah/buildah-1.35.4.ebuild
index e1c7e23390e5..79687044616a 100644
--- a/app-containers/buildah/buildah-1.35.4.ebuild
+++ b/app-containers/buildah/buildah-1.35.4.ebuild
@@ -120,6 +120,7 @@ src_compile() {
tc-export AS LD STRIP
export GOMD2MAN="$(command -v go-md2man)"
+ export SELINUXOPT=
default
}
@@ -128,6 +129,6 @@ src_test() {
}
src_install() {
- emake DESTDIR="${ED}" install install.completions
+ emake DESTDIR="${ED}" SELINUXOPT= install install.completions
einstalldocs
}
diff --git a/app-containers/buildah/buildah-1.36.0.ebuild b/app-containers/buildah/buildah-1.36.0.ebuild
index 1d1b2acc5e46..2dcea51820e2 100644
--- a/app-containers/buildah/buildah-1.36.0.ebuild
+++ b/app-containers/buildah/buildah-1.36.0.ebuild
@@ -115,6 +115,7 @@ src_compile() {
tc-export AS LD STRIP
export GOMD2MAN="$(command -v go-md2man)"
+ export SELINUXOPT=
default
}
@@ -123,6 +124,6 @@ src_test() {
}
src_install() {
- emake DESTDIR="${ED}" install install.completions
+ emake DESTDIR="${ED}" SELINUXOPT= install install.completions
einstalldocs
}
diff --git a/app-containers/buildah/buildah-9999.ebuild b/app-containers/buildah/buildah-9999.ebuild
index 1d1b2acc5e46..2dcea51820e2 100644
--- a/app-containers/buildah/buildah-9999.ebuild
+++ b/app-containers/buildah/buildah-9999.ebuild
@@ -115,6 +115,7 @@ src_compile() {
tc-export AS LD STRIP
export GOMD2MAN="$(command -v go-md2man)"
+ export SELINUXOPT=
default
}
@@ -123,6 +124,6 @@ src_test() {
}
src_install() {
- emake DESTDIR="${ED}" install install.completions
+ emake DESTDIR="${ED}" SELINUXOPT= install install.completions
einstalldocs
}