summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-19 23:40:42 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-20 00:51:47 -0800
commitcc0c1e49ee53f01fe49a5742a3b441c1c9f6fa8b (patch)
tree389e7f81d1949e65db3bfd0183fc2347b19718ba /app-containers
parentMove {app-emulation -> app-containers}/snapd (diff)
downloadgentoo-cc0c1e49ee53f01fe49a5742a3b441c1c9f6fa8b.tar.gz
gentoo-cc0c1e49ee53f01fe49a5742a3b441c1c9f6fa8b.tar.bz2
gentoo-cc0c1e49ee53f01fe49a5742a3b441c1c9f6fa8b.zip
Move {app-emulation -> app-containers}/umoci
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/umoci/Manifest2
-rw-r--r--app-containers/umoci/metadata.xml8
-rw-r--r--app-containers/umoci/umoci-0.2.1.ebuild42
-rw-r--r--app-containers/umoci/umoci-0.4.6.ebuild35
4 files changed, 87 insertions, 0 deletions
diff --git a/app-containers/umoci/Manifest b/app-containers/umoci/Manifest
new file mode 100644
index 000000000000..0f09907185d6
--- /dev/null
+++ b/app-containers/umoci/Manifest
@@ -0,0 +1,2 @@
+DIST umoci-0.2.1.tar.gz 241472 BLAKE2B 2802fcb14e717a6460f9dc06226d3b430cce2181838a32064e86987131317947a4b117e91d11f981fa1df027804dbf2d92472b5c21749783b4f2ed371c699e7e SHA512 dfd7bbd1afd232400a9bffaf6c074d28ce4ce696c9f3c70bd436cc41b96928415d0793d57b1cf34dd70efd7d0e5eb567eaeea65d793c27ff9ea46fb190bd1807
+DIST umoci-0.4.6.tar.gz 2273608 BLAKE2B d5a36c78918697b9c8f54a5c4b914a9124b5e989dff3efc81a9f64f1bd276189d15a565a6ec2e8d4021925017e9a7a17f7cc5359a552f7c57dda414c25d2fb02 SHA512 0614dd583e00b6e2e69256f1ae1d3316e5bb5989a177d18c5ceacf3af18ab82ccf8edef879b6c813855d878d5af53c541ac433d81e6c20796885a26c57564118
diff --git a/app-containers/umoci/metadata.xml b/app-containers/umoci/metadata.xml
new file mode 100644
index 000000000000..db463f3eeb66
--- /dev/null
+++ b/app-containers/umoci/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-containers/umoci/umoci-0.2.1.ebuild b/app-containers/umoci/umoci-0.2.1.ebuild
new file mode 100644
index 000000000000..ad66e4afe83d
--- /dev/null
+++ b/app-containers/umoci/umoci-0.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/openSUSE/umoci"
+COMMIT=0465f83826bc4f52e6e3c4dbb1022ec5792c421f
+inherit golang-vcs-snapshot
+
+DESCRIPTION="Manipulation tool for OCI images"
+HOMEPAGE="https://github.com/openSUSE/umoci"
+SRC_URI="https://github.com/openSUSE/umoci/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-go/go-md2man"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+RESTRICT="test"
+
+src_compile() {
+ set -- env GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go build -v -work -x \
+ -ldflags "-w -X main.gitCommit=${COMMIT} -X main.version=${PV}" \
+ -o "bin/${PN}" ./cmd/${PN}
+ echo "$@"
+ "$@" || die
+ cd man
+ for f in *.1.md; do
+ go-md2man -in ${f} -out ${f%%.md} || die
+ done
+}
+
+src_install() {
+dobin bin/${PN}
+doman man/*.1
+dodoc CHANGELOG.md
+einstalldocs
+}
diff --git a/app-containers/umoci/umoci-0.4.6.ebuild b/app-containers/umoci/umoci-0.4.6.ebuild
new file mode 100644
index 000000000000..f315c80c886b
--- /dev/null
+++ b/app-containers/umoci/umoci-0.4.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+COMMIT=5efa06acfb3bb4e65d2711cf5255970948e047cf
+inherit go-module
+
+DESCRIPTION="Manipulation tool for OCI images"
+HOMEPAGE="https://github.com/opencontainers/umoci"
+SRC_URI="https://github.com/opencontainers/umoci/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-go/go-md2man"
+
+RESTRICT+=" test "
+
+src_compile() {
+ go build -buildmode=pie -mod=vendor \
+ -ldflags "-w -X main.gitCommit=${COMMIT} -X main.version=${PV}" \
+ -o "bin/${PN}" ./cmd/${PN} || die
+ cd doc/man
+ for f in *.1.md; do
+ go-md2man -in ${f} -out ${f%%.md} || die
+ done
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman doc/man/*.1
+ dodoc CHANGELOG.md
+ einstalldocs
+}