summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/bsign
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/bsign')
-rw-r--r--app-crypt/bsign/Manifest1
-rw-r--r--app-crypt/bsign/bsign-0.4.5-r1.ebuild34
-rw-r--r--app-crypt/bsign/bsign-0.4.5.ebuild35
-rw-r--r--app-crypt/bsign/files/bsign-0.4.5-build.patch31
-rw-r--r--app-crypt/bsign/files/bsign-0.4.5-non-gnu.patch42
-rw-r--r--app-crypt/bsign/files/bsign-0.4.5-scripts.patch48
-rw-r--r--app-crypt/bsign/metadata.xml13
7 files changed, 204 insertions, 0 deletions
diff --git a/app-crypt/bsign/Manifest b/app-crypt/bsign/Manifest
new file mode 100644
index 000000000000..f3277e00c2c9
--- /dev/null
+++ b/app-crypt/bsign/Manifest
@@ -0,0 +1 @@
+DIST bsign_0.4.5.tar.gz 77471 SHA256 a80b27286a3b1b1be6df7b93d27457a4a6941a1eaf797070b1044412f47d3106 SHA512 a4dba37d648f683bb5b14bc9aafeb72fb0bd06e21cedb1a4bbd73dfc0a5f7bb22b5b33ef8727b5070d727afb2d97489ed4b9be28bf1025c9e618ccf47f1ef634 WHIRLPOOL 067ff40119578e6208beeba7ebe9ea21fcb0667abe1ca9780f858a250048035705faad5009d5dfa6814cd4778338722c596caab469d3f8b6d7da05794f1fcbd9
diff --git a/app-crypt/bsign/bsign-0.4.5-r1.ebuild b/app-crypt/bsign/bsign-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..c2b4476d4cd2
--- /dev/null
+++ b/app-crypt/bsign/bsign-0.4.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="embed secure hashes (SHA1) and digital signatures (GNU Privacy Guard) into files"
+HOMEPAGE="http://packages.debian.org/sid/bsign"
+SRC_URI="mirror://debian/pool/main/b/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86 ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-non-gnu.patch # for Darwin, BSD, Solaris, etc.
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-scripts.patch
+ eautoreconf
+}
+
+src_configure() {
+ use static-libs && append-ldflags -static
+ default
+}
+
+src_install() {
+ dobin bsign_sign bsign_verify bsign_hash bsign_check
+ newbin o/bsign-unstripped bsign
+ doman bsign.1
+ dodoc README
+}
diff --git a/app-crypt/bsign/bsign-0.4.5.ebuild b/app-crypt/bsign/bsign-0.4.5.ebuild
new file mode 100644
index 000000000000..ab50a477b541
--- /dev/null
+++ b/app-crypt/bsign/bsign-0.4.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="embed secure hashes (SHA1) and digital signatures (GNU Privacy Guard) into files"
+HOMEPAGE="http://packages.debian.org/sid/bsign"
+SRC_URI="mirror://debian/pool/main/b/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc ~ppc-macos ~x86 ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-non-gnu.patch # for Darwin, BSD, Solaris, etc.
+
+ if ! use static-libs || [[ ${CHOST} == *-darwin* ]]; then
+ sed -i -e '/^LFLAGS/s/-static//' Makefile.in
+ fi
+
+ sed -i -e "/^CFLAGS/d" \
+ -e "/^CXXFLAGS/d" configure.in
+ eautoreconf
+ tc-export CC CXX
+}
+
+src_install() {
+ dobin bsign_sign bsign_verify bsign_hash bsign_check || die
+ newbin o/bsign-unstripped bsign || die
+ doman bsign.1 || die
+ dodoc README || die
+}
diff --git a/app-crypt/bsign/files/bsign-0.4.5-build.patch b/app-crypt/bsign/files/bsign-0.4.5-build.patch
new file mode 100644
index 000000000000..c6e40ada4cb2
--- /dev/null
+++ b/app-crypt/bsign/files/bsign-0.4.5-build.patch
@@ -0,0 +1,31 @@
+diff -urNp bsign-0.4.5/configure.in bsign-0.4.5.new/configure.in
+--- bsign-0.4.5/configure.in 2002-01-18 03:16:44.000000000 +0200
++++ bsign-0.4.5.new/configure.in 2013-06-16 00:54:36.470673947 +0300
+@@ -14,12 +14,8 @@ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+ AC_PROG_INSTALL
+
+-CFLAGS=-g
+-CXXFLAGS=-g
+-
+ if test "${GXX}" = "yes" ; then
+ CFLAGS_W=" -Wall -Wno-parentheses -Wno-unused"
+- CFLAGS="${CFLAGS}"
+ fi
+
+ dnl Checks for header files.
+diff -urNp bsign-0.4.5/Makefile.in bsign-0.4.5.new/Makefile.in
+--- bsign-0.4.5/Makefile.in 2002-01-27 22:56:56.000000000 +0200
++++ bsign-0.4.5.new/Makefile.in 2013-06-16 00:56:30.254676986 +0300
+@@ -56,9 +56,8 @@ CFLAGS=@CFLAGS@ @DEFS@
+ #CFLAGS_O=-O2 -fomit-frame-pointer
+ #CFLAGS_P=$(CFLAGS) -pg
+ CFLAGS_=-g $(CFLAGS_I)@CFLAGS_W@ $(CFLAGS_O) $(CFLAGS_P)
+-CXXFLAGS=$(CFLAGS)
+-CXXFLAGS_=$(CFLAGS_)
+-LFLAGS=-g -static @LDFLAGS@ @LIBS@
++CXXFLAGS=@CXXFLAGS@ @DEFS@
++LFLAGS=-g @LDFLAGS@ @LIBS@
+ #LFLAGS=-g @LDFLAGS@ @LIBS@
+ #LFLAGS=-pg ${LFLAGS}
+ DEPEND=depend.m
diff --git a/app-crypt/bsign/files/bsign-0.4.5-non-gnu.patch b/app-crypt/bsign/files/bsign-0.4.5-non-gnu.patch
new file mode 100644
index 000000000000..b07d78450ee1
--- /dev/null
+++ b/app-crypt/bsign/files/bsign-0.4.5-non-gnu.patch
@@ -0,0 +1,42 @@
+--- Makefile.in
++++ Makefile.in
+@@ -62,7 +62,7 @@
+ #LFLAGS=-g @LDFLAGS@ @LIBS@
+ #LFLAGS=-pg ${LFLAGS}
+ DEPEND=depend.m
+-ECHO=@/bin/echo
++ECHO=@echo
+ INSTALL=@INSTALL@
+ INSTALL_PROGRAM=@INSTALL_PROGRAM@
+ INSTALL_DATA=@INSTALL_DATA@
+@@ -192,11 +192,11 @@
+ #
+
+ .version: .version_major .version_minor .version_patch
+- @/bin/echo -n `cat .version_major`.`cat .version_minor`.`cat \
++ @echo -n `cat .version_major`.`cat .version_minor`.`cat \
+ .version_patch` > .version
+
+ _version.h: .version
+- @/bin/echo -e \#define SZ_VERSION \"`cat .version`\" > _version.h
++ @echo -e \#define SZ_VERSION \"`cat .version`\" > _version.h
+
+ .PHONY: transmit
+ transmit: # distribution-archive
+@@ -209,12 +209,12 @@
+
+ version.sed: _version.h
+ @echo Creating version-specific sed script...
+- @/bin/echo s/\<\<version\>\>/`cat .version`/ > version.sed
+- @/bin/echo s/\<\<date\>\>/`date +"%d%b%y" \
++ @echo s/\<\<version\>\>/`cat .version`/ > version.sed
++ @echo s/\<\<date\>\>/`date +"%d%b%y" \
+ | sed -e y/abceglnoprtuvy/ABCEGLNOPRTUVY/`/ >> version.sed
+- @/bin/echo s/\<\<tar-file\>\>/${PACKAGE}-`cat .version`.tar.gz/ \
++ @echo s/\<\<tar-file\>\>/${PACKAGE}-`cat .version`.tar.gz/ \
+ >> version.sed
+- @/bin/echo s/\<\<lsm-file\>\>/${PACKAGE}-`cat .version`.lsm/ >> version.sed
++ @echo s/\<\<lsm-file\>\>/${PACKAGE}-`cat .version`.lsm/ >> version.sed
+
+ .PHONY: ${PACKAGE}.lsm
+ ${PACKAGE}.lsm: version.sed LSM
diff --git a/app-crypt/bsign/files/bsign-0.4.5-scripts.patch b/app-crypt/bsign/files/bsign-0.4.5-scripts.patch
new file mode 100644
index 000000000000..97f79e68e29c
--- /dev/null
+++ b/app-crypt/bsign/files/bsign-0.4.5-scripts.patch
@@ -0,0 +1,48 @@
+diff -urNp bsign-0.4.5/bsign_check bsign-0.4.5.new2/bsign_check
+--- bsign-0.4.5/bsign_check 2002-01-27 22:49:04.000000000 +0200
++++ bsign-0.4.5.new2/bsign_check 2013-06-16 01:00:55.862655310 +0300
+@@ -9,7 +9,7 @@
+ # LOCATIONS gives the path includes and excludes that guide where
+ # bsign looks for input files.
+
+-LOCATIONS=-i / -e /boot -e /cdrom -e /dev -e /proc -e $BASE_PATH
++LOCATIONS="-i / -e /boot -e /cdrom -e /dev -e /proc -e $BASE_PATH"
+
+ # MAIL_TO is the list of email addresses that will receive email when
+ # this script terminates. The mail will contain the output of
+diff -urNp bsign-0.4.5/bsign_hash bsign-0.4.5.new2/bsign_hash
+--- bsign-0.4.5/bsign_hash 2002-01-27 22:49:04.000000000 +0200
++++ bsign-0.4.5.new2/bsign_hash 2013-06-16 01:00:43.543657092 +0300
+@@ -9,7 +9,7 @@
+ # LOCATIONS gives the path includes and excludes that guide where
+ # bsign looks for input files.
+
+-LOCATIONS=-i / -e /boot -e /cdrom -e /dev -e /proc
++LOCATIONS="-i / -e /boot -e /cdrom -e /dev -e /proc"
+
+ # --- End of customization macros
+
+diff -urNp bsign-0.4.5/bsign_sign bsign-0.4.5.new2/bsign_sign
+--- bsign-0.4.5/bsign_sign 2002-01-27 20:44:09.000000000 +0200
++++ bsign-0.4.5.new2/bsign_sign 2013-06-16 01:00:17.737660680 +0300
+@@ -23,7 +23,7 @@ KEY_PATH=$BASE_PATH
+ # LOCATIONS gives the path includes and excludes that guide where
+ # bsign looks for input files.
+
+-LOCATIONS=-i / -e /boot -e /cdrom -e /dev -e /proc -e $BASE_PATH
++LOCATIONS="-i / -e /boot -e /cdrom -e /dev -e /proc -e $BASE_PATH"
+
+ # --- End of customization macros
+
+diff -urNp bsign-0.4.5/bsign_verify bsign-0.4.5.new2/bsign_verify
+--- bsign-0.4.5/bsign_verify 2002-01-27 20:44:09.000000000 +0200
++++ bsign-0.4.5.new2/bsign_verify 2013-06-16 01:00:28.114659254 +0300
+@@ -23,7 +23,7 @@ KEY_PATH=$BASE_PATH
+ # LOCATIONS gives the path includes and excludes that guide where
+ # bsign looks for input files.
+
+-LOCATIONS=-i / -e /boot -e /cdrom -e /dev -e /proc -e $BASE_PATH
++LOCATIONS="-i / -e /boot -e /cdrom -e /dev -e /proc -e $BASE_PATH"
+ #LOCATIONS=-i /bin -i /sbin -i /usr/bin -i /usr/sbin
+
+ # MAIL_TO is the list of email addresses that will receive email when
diff --git a/app-crypt/bsign/metadata.xml b/app-crypt/bsign/metadata.xml
new file mode 100644
index 000000000000..e2e168b2d9c2
--- /dev/null
+++ b/app-crypt/bsign/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <longdescription>
+ This package embeds secure hashes (SHA1) and digital signatures (GNU
+ Privacy Guard) into files for verification and authentication.
+ Currently, target file types are all ELF format: executables, kernel
+ modules, schared and static link libraries. This program has
+ functionality similar to tripwire and integrit without the need to
+ maintain a database.
+ </longdescription>
+</pkgmetadata>