summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-12 21:15:33 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-12 21:26:19 +0200
commit983b44ff57d50ad5762a91779fc2a19e783563fa (patch)
tree06e11d3c3568d581fbaf1a5805aab5f37d7b3c92 /app-crypt
parentapp-crypt/certbot-dns-dnsimple: Remove old (diff)
downloadgentoo-983b44ff57d50ad5762a91779fc2a19e783563fa.tar.gz
gentoo-983b44ff57d50ad5762a91779fc2a19e783563fa.tar.bz2
gentoo-983b44ff57d50ad5762a91779fc2a19e783563fa.zip
app-crypt/certbot-dns-dnsimple: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.10.0.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.10.0.ebuild b/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.10.0.ebuild
index 49462ea339f0..3ccc8046224d 100644
--- a/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.10.0.ebuild
+++ b/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.10.0.ebuild
@@ -4,16 +4,22 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
+MY_P=certbot-${PV}
DESCRIPTION="DNSimple Authenticator plugin for Certbot (Let's Encrypt Client)"
-HOMEPAGE="https://github.com/certbot/certbot https://certbot-dns-dnsimple.readthedocs.io/en/stable/"
+HOMEPAGE="
+ https://github.com/certbot/certbot/
+ https://certbot-dns-dnsimple.readthedocs.io/en/stable/
+"
# Use common certbot tarball
-SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.gh.tar.gz"
-
-S="${WORKDIR}/certbot-${PV}/${PN}"
+SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/${PN}
LICENSE="Apache-2.0"
SLOT="0"
@@ -25,5 +31,6 @@ RDEPEND="
>=dev-python/dns-lexicon-3.2.1[${PYTHON_USEDEP}]
"
-distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
distutils_enable_tests pytest