summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-08-27 11:49:45 +0200
committerUlrich Müller <ulm@gentoo.org>2019-08-27 12:24:08 +0200
commitece70ecf8cdc499919365e26af0c195d8597e8c5 (patch)
tree87687a8d9913b567b2d54b4c481724cb5d91891d /app-editors/ersatz-emacs/ersatz-emacs-20060515-r1.ebuild
parentdev-ada/gtkada: fix repoman warnings (diff)
downloadgentoo-ece70ecf8cdc499919365e26af0c195d8597e8c5.tar.gz
gentoo-ece70ecf8cdc499919365e26af0c195d8597e8c5.tar.bz2
gentoo-ece70ecf8cdc499919365e26af0c195d8597e8c5.zip
app-editors/ersatz-emacs: Bump EAPI to 7.
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/ersatz-emacs/ersatz-emacs-20060515-r1.ebuild')
-rw-r--r--app-editors/ersatz-emacs/ersatz-emacs-20060515-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-editors/ersatz-emacs/ersatz-emacs-20060515-r1.ebuild b/app-editors/ersatz-emacs/ersatz-emacs-20060515-r1.ebuild
new file mode 100644
index 000000000000..2506526d39d2
--- /dev/null
+++ b/app-editors/ersatz-emacs/ersatz-emacs-20060515-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A very minimal imitation of the famous GNU Emacs editor"
+HOMEPAGE="https://web.archive.org/web/20171126221613/http://hunter.apana.org.au/~cjb/Code/"
+# taken from http://hunter.apana.org.au/~cjb/Code/ersatz.tar.gz
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}
+ !app-editors/ee"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-gentoo.patch
+ sed -i -e "s%/usr/local/share/%/usr/share/doc/${PF}/%" ee.1 \
+ || die "sed failed"
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wall" \
+ LFLAGS="${LDFLAGS} $("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
+
+src_install() {
+ # Note: /usr/bin/ee is "easy edit" on FreeBSD, so if this
+ # is ever keyworded *-fbsd the binary has to be renamed.
+ dobin ee
+ doman ee.1
+ dodoc ChangeLog ERSATZ.keys README
+}