summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-09-28 14:02:16 +1300
committerKent Fredric <kentnl@gentoo.org>2017-09-28 14:02:47 +1300
commit0783bd6eb14f40386abf1ca4c6b6ef30b68ae11b (patch)
tree5a9ae1b59b3da5a1895bec4cef00f70da404156d /app-editors
parentdev-python/python-iptables: Version bump to 0.12.0 (diff)
downloadgentoo-0783bd6eb14f40386abf1ca4c6b6ef30b68ae11b.tar.gz
gentoo-0783bd6eb14f40386abf1ca4c6b6ef30b68ae11b.tar.bz2
gentoo-0783bd6eb14f40386abf1ca4c6b6ef30b68ae11b.zip
app-editors/padre: Fix compile without '.' in @INC on Perl 5.26
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/padre/padre-1.0.0-r1.ebuild7
-rw-r--r--app-editors/padre/padre-1.0.0.ebuild8
2 files changed, 13 insertions, 2 deletions
diff --git a/app-editors/padre/padre-1.0.0-r1.ebuild b/app-editors/padre/padre-1.0.0-r1.ebuild
index 1ce32256f585..aae5b0669614 100644
--- a/app-editors/padre/padre-1.0.0-r1.ebuild
+++ b/app-editors/padre/padre-1.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -106,3 +106,8 @@ src_configure() {
unset DISPLAY
perl-module_src_configure
}
+src_prepare() {
+ sed -i -e 's/^use inc::Module::Install/use lib q[.];\nuse inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}
diff --git a/app-editors/padre/padre-1.0.0.ebuild b/app-editors/padre/padre-1.0.0.ebuild
index 17201614f89c..bc3967a1dbb3 100644
--- a/app-editors/padre/padre-1.0.0.ebuild
+++ b/app-editors/padre/padre-1.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -104,3 +104,9 @@ src_configure() {
unset DISPLAY
perl-module_src_configure
}
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.];\n use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}