summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-09-04 15:52:21 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-09-09 14:50:27 +0200
commit2e83dfb34c6642e9c23a343231824b867a498d80 (patch)
treec59e54c79f122d3ea5265c59cec290f7994ba619 /app-editors
parentsys-apps/eza: add 0.19.2 (diff)
downloadgentoo-2e83dfb34c6642e9c23a343231824b867a498d80.tar.gz
gentoo-2e83dfb34c6642e9c23a343231824b867a498d80.tar.bz2
gentoo-2e83dfb34c6642e9c23a343231824b867a498d80.zip
app-editors/dav: add 0.9.0, update sources
- bump EAPI - avoid exec permissions on the manpage & apply custom compression (thanks to arkamar for the suggestion!) - update SRC_URI & HOMEPAGE - remove empty src_configure Signed-off-by: Filip Kobierski <fkobi@pm.me> Closes: https://github.com/gentoo/gentoo/pull/38432 Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/dav/Manifest1
-rw-r--r--app-editors/dav/dav-0.9.0.ebuild41
-rw-r--r--app-editors/dav/metadata.xml2
3 files changed, 43 insertions, 1 deletions
diff --git a/app-editors/dav/Manifest b/app-editors/dav/Manifest
index 517d870648d3..825981e03a07 100644
--- a/app-editors/dav/Manifest
+++ b/app-editors/dav/Manifest
@@ -1 +1,2 @@
DIST dav-0.8.5.tar.gz 22824 BLAKE2B 969458aa6b914f9cd624554690a88f4c2999dcc6e89db38d13d9ba98db7881a34ce1575ccbdf74b3ecca34345f2ec639cfc805a350e31f856f7d086cf23752de SHA512 cdedff875df392e8525399b40d45cdf4e984b1b014f03d9f5cd5be270eebe0003fcf48e9738f6ac2789138973970bb9fe6d0b8babd20c1df61e193f84ee066b3
+DIST dav-text-0.9.0.tar.gz 23882 BLAKE2B 6845b40bbb74d57438625c2736758c52fbe4cff3e020fd451dee540f06fb893d71e11469f828845c193e9fbbd8a8e0b31dcb9a6fa29383053b61dd9a9d7b0ce4 SHA512 8bb9d111c25e7e41c7d75ee559aeae47494ff68f19f40d2ba3e2ebca23577538b94ba72b58ccf4e64ef92d9e740ee843fa249ef0e4148971b3037259b4f280c5
diff --git a/app-editors/dav/dav-0.9.0.ebuild b/app-editors/dav/dav-0.9.0.ebuild
new file mode 100644
index 000000000000..132aba699103
--- /dev/null
+++ b/app-editors/dav/dav-0.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Minimal console text editor"
+HOMEPAGE="https://github.com/atsb/dav-text"
+SRC_URI="https://github.com/atsb/dav-text/archive/refs/tags/dav-text-${PV}.tar.gz"
+S="${WORKDIR}/dav-text-dav-text-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.8.5-fno-common.patch )
+
+DOCS=( README.md )
+
+src_prepare() {
+ unpack ./dav.1.gz
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS} $( $(tc-getPKG_CONFIG) --libs ncurses)"
+}
+
+src_install() {
+ dobin dav
+ doman dav.1
+ einstalldocs
+}
diff --git a/app-editors/dav/metadata.xml b/app-editors/dav/metadata.xml
index 3e5986cf560b..283d15ae53cd 100644
--- a/app-editors/dav/metadata.xml
+++ b/app-editors/dav/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<!-- maintainer-needed -->
<upstream>
- <remote-id type="sourceforge">dav-text</remote-id>
+ <remote-id type="github">atsb/dav-text</remote-id>
</upstream>
</pkgmetadata>