summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBharath Saiguhan <bharathsaiguhan@protonmail.com>2022-10-31 11:56:23 +0530
committerSam James <sam@gentoo.org>2022-11-02 20:02:16 +0000
commit317d433897aa1ecb0138d97df6d9374ace4005b4 (patch)
treea27597e2675787d4e4c8c93d9e5ab606ab3824d6 /app-editors
parentdev-libs/libgrapheme: add 2.0.2 (diff)
downloadgentoo-317d433897aa1ecb0138d97df6d9374ace4005b4.tar.gz
gentoo-317d433897aa1ecb0138d97df6d9374ace4005b4.tar.bz2
gentoo-317d433897aa1ecb0138d97df6d9374ace4005b4.zip
app-editors/neovim: fix cmake-release-type.patch
Upstream converted the (old) runtime/autoload/health/nvim.vim file into the (new) runtime/lua/nvim/health.lua file. This causes patching to fail during building, since the old file won't be found. This commit modifies the patch file to work on the new file. Signed-off-by: Bharath Saiguhan <bharathsaiguhan@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/28048 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake-release-type.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/app-editors/neovim/files/neovim-9999-cmake-release-type.patch b/app-editors/neovim/files/neovim-9999-cmake-release-type.patch
index 8114e2a92b74..8c24b6b6123f 100644
--- a/app-editors/neovim/files/neovim-9999-cmake-release-type.patch
+++ b/app-editors/neovim/files/neovim-9999-cmake-release-type.patch
@@ -1,16 +1,16 @@
Ensure that :checkhealth is happy with the Gentoo build type.
https://bugs.gentoo.org/757744
---- a/runtime/autoload/health/nvim.vim
-+++ b/runtime/autoload/health/nvim.vim
-@@ -135,7 +135,7 @@ function! s:check_performance() abort
- let buildtype = matchstr(execute('version'), '\v\cbuild type:?\s*[^\n\r\t ]+')
- if empty(buildtype)
- call health#report_error('failed to get build type from :version')
-- elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo)'
-+ elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo|Gentoo)'
- call health#report_ok(buildtype)
- else
- call health#report_info(buildtype)
+--- a/runtime/lua/nvim/health.lua
++++ b/runtime/lua/nvim/health.lua
+@@ -149,7 +149,7 @@ local function check_performance()
+ let s:buildtype = matchstr(execute('version'), '\v\cbuild type:?\s*[^\n\r\t ]+')
+ if empty(s:buildtype)
+ call health#report_error('failed to get build type from :version')
+- elseif s:buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo)'
++ elseif s:buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo|Gentoo)'
+ call health#report_ok(s:buildtype)
+ else
+ call health#report_info(s:buildtype)
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -137,12 +137,6 @@ else()