summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-02-22 22:36:22 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-02-22 22:36:22 +0200
commit74317b867bc26855fab6e78e6a4cfac096242871 (patch)
tree902ca8b4538554bf648e6ecde7a9f4d921dd160d /app-editors
parentapp-portage/cpuid2cpuflags: Stabilize 14 ppc, #924094 (diff)
downloadgentoo-74317b867bc26855fab6e78e6a4cfac096242871.tar.gz
gentoo-74317b867bc26855fab6e78e6a4cfac096242871.tar.bz2
gentoo-74317b867bc26855fab6e78e6a4cfac096242871.zip
app-editors/ne: add 3.3.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ne/Manifest1
-rw-r--r--app-editors/ne/ne-3.3.3.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-editors/ne/Manifest b/app-editors/ne/Manifest
index 3fdacc2f64f0..2b9232daa17f 100644
--- a/app-editors/ne/Manifest
+++ b/app-editors/ne/Manifest
@@ -1,2 +1,3 @@
DIST ne-3.3.1.tar.gz 1138072 BLAKE2B 8494ff955b456bbac2e82823ee155980f8fab5a1071d0bfd6a987f1ed0724129ab2ecb70737547836b592369b45daf5e499d50d7230b04c5eabfd1536a56271f SHA512 d8c1d8cd9bbafcc7c8c485ca4454d6979be3d33ae918139865ce5f76e428f165043707c95c2e440bd9bccd00c67ce81a41f87f94b85cae3518c4749233718123
DIST ne-3.3.2.tar.gz 1154326 BLAKE2B 8c11abac9a960a41de2faed9b2e948cca9ca7f8345757796fb7daa112e62d565096b1cd3a4ca2e76cfb1616ee8c0dad01bb2fe5306bac6f0aadca0644b91eb6d SHA512 6c4fabb0ecade31322d5f96203f3bba3316264d8f98a46188796ce88f4b7fd17af8569832ae2638770f8ceb59138b0395b0e03817db961bfe94c917fa390ebf3
+DIST ne-3.3.3.tar.gz 1162423 BLAKE2B 72db1088757eb752e94480e0d0f02a85edc2df8b45bb6de732c43a6b6bfbcf0d54038462f8730ef3772a81f13ce0ca6154cced5aa10f1a0aa96ddc8697a0aaff SHA512 13bf4fae6977230cd7f3b46d12a25a605d2e83e363cf54202dc4b9e8fb19cc51bac5f30611166839bc1f717c5367db272c8d215b8006f7aa9eec312a817d35c7
diff --git a/app-editors/ne/ne-3.3.3.ebuild b/app-editors/ne/ne-3.3.3.ebuild
new file mode 100644
index 000000000000..0c90f784c008
--- /dev/null
+++ b/app-editors/ne/ne-3.3.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="The nice editor, easy to use for the beginner and powerful for the wizard"
+HOMEPAGE="https://ne.di.unimi.it/"
+SRC_URI="https://ne.di.unimi.it/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+"
+BDEPEND="virtual/pkgconfig"
+
+HTML_DOCS=( doc/html/. )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's/-O3//' \
+ -e 's/-Wp,-D_FORTIFY_SOURCE=2//' \
+ -e '/-flto/d' \
+ src/makefile || die
+}
+
+src_configure() {
+ # bug #776799
+ sed -i -e "s/-lcurses/$($(tc-getPKG_CONFIG) --libs ncurses)/" src/makefile || die
+}
+
+src_compile() {
+ append-cflags -std=c11
+
+ emake -C src CC="$(tc-getCC)" \
+ NE_GLOBAL_DIR="/usr/share/${PN}" \
+ OPTS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ "${PN}"
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /usr/share/${PN}/syntax
+ doins syntax/*.jsf
+
+ doman doc/${PN}.1
+ dodoc CHANGES README.md NEWS doc/*.{txt,pdf,texinfo} doc/default.*
+}