summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-10-10 19:31:51 +0200
committerUlrich Müller <ulm@gentoo.org>2024-10-24 11:34:24 +0200
commit897831538c5699aa4dcfe53e85f01fb6a913430d (patch)
tree5cc25a7fc60a39361a0c39c56112ebab3b1d812d /app-editors
parentmedia-video/mpv: Stabilize 0.39.0 arm64, #941961 (diff)
downloadgentoo-897831538c5699aa4dcfe53e85f01fb6a913430d.tar.gz
gentoo-897831538c5699aa4dcfe53e85f01fb6a913430d.tar.bz2
gentoo-897831538c5699aa4dcfe53e85f01fb6a913430d.zip
app-editors/emacs: Restore replacing -O[3-9] by -O2 in CFLAGS
This partially reverts commit 4ca8019087aab182e0f3f1211f235f128d537b8a. Bug: https://bugs.gentoo.org/839405 Closes: https://bugs.gentoo.org/941225 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/emacs-26.3-r19.ebuild3
-rw-r--r--app-editors/emacs/emacs-27.2-r17.ebuild4
-rw-r--r--app-editors/emacs/emacs-28.2-r13.ebuild4
-rw-r--r--app-editors/emacs/emacs-29.4.ebuild4
-rw-r--r--app-editors/emacs/emacs-30.0.91.ebuild4
-rw-r--r--app-editors/emacs/emacs-30.0.9999-r1.ebuild4
-rw-r--r--app-editors/emacs/emacs-31.0.9999.ebuild4
7 files changed, 20 insertions, 7 deletions
diff --git a/app-editors/emacs/emacs-26.3-r19.ebuild b/app-editors/emacs/emacs-26.3-r19.ebuild
index 1fb9cb7f2f7f..4fce2690b4f9 100644
--- a/app-editors/emacs/emacs-26.3-r19.ebuild
+++ b/app-editors/emacs/emacs-26.3-r19.ebuild
@@ -119,9 +119,10 @@ src_prepare() {
src_configure() {
strip-flags
filter-flags -pie #526948
- replace-flags "-O[3-9]" -O2
+ replace-flags "-O[3-9]" -O2 #839405
# We want floating-point arithmetic to be correct #933380
+ replace-flags -Ofast -O2
append-flags -fno-fast-math -ffp-contract=off
local myconf
diff --git a/app-editors/emacs/emacs-27.2-r17.ebuild b/app-editors/emacs/emacs-27.2-r17.ebuild
index db9b0cc4c050..cb1eb9824a1f 100644
--- a/app-editors/emacs/emacs-27.2-r17.ebuild
+++ b/app-editors/emacs/emacs-27.2-r17.ebuild
@@ -160,8 +160,10 @@ src_prepare() {
}
src_configure() {
+ replace-flags "-O[3-9]" -O2 #839405
+
# We want floating-point arithmetic to be correct #933380
- replace-flags -Ofast -O3
+ replace-flags -Ofast -O2
append-flags -fno-fast-math -ffp-contract=off
local myconf
diff --git a/app-editors/emacs/emacs-28.2-r13.ebuild b/app-editors/emacs/emacs-28.2-r13.ebuild
index f7e8fa9848ff..7af80421f66d 100644
--- a/app-editors/emacs/emacs-28.2-r13.ebuild
+++ b/app-editors/emacs/emacs-28.2-r13.ebuild
@@ -184,8 +184,10 @@ src_prepare() {
}
src_configure() {
+ replace-flags "-O[3-9]" -O2 #839405
+
# We want floating-point arithmetic to be correct #933380
- replace-flags -Ofast -O3
+ replace-flags -Ofast -O2
append-flags -fno-fast-math -ffp-contract=off
local myconf
diff --git a/app-editors/emacs/emacs-29.4.ebuild b/app-editors/emacs/emacs-29.4.ebuild
index e5cacab45886..e8ff177693e1 100644
--- a/app-editors/emacs/emacs-29.4.ebuild
+++ b/app-editors/emacs/emacs-29.4.ebuild
@@ -216,8 +216,10 @@ src_prepare() {
}
src_configure() {
+ replace-flags "-O[3-9]" -O2 #839405
+
# We want floating-point arithmetic to be correct #933380
- replace-flags -Ofast -O3
+ replace-flags -Ofast -O2
append-flags -fno-fast-math -ffp-contract=off
local myconf
diff --git a/app-editors/emacs/emacs-30.0.91.ebuild b/app-editors/emacs/emacs-30.0.91.ebuild
index b151a0271ab1..3c000ffedb94 100644
--- a/app-editors/emacs/emacs-30.0.91.ebuild
+++ b/app-editors/emacs/emacs-30.0.91.ebuild
@@ -213,8 +213,10 @@ src_prepare() {
}
src_configure() {
+ replace-flags "-O[3-9]" -O2 #839405
+
# We want floating-point arithmetic to be correct #933380
- replace-flags -Ofast -O3
+ replace-flags -Ofast -O2
append-flags -fno-fast-math -ffp-contract=off
local myconf
diff --git a/app-editors/emacs/emacs-30.0.9999-r1.ebuild b/app-editors/emacs/emacs-30.0.9999-r1.ebuild
index b151a0271ab1..3c000ffedb94 100644
--- a/app-editors/emacs/emacs-30.0.9999-r1.ebuild
+++ b/app-editors/emacs/emacs-30.0.9999-r1.ebuild
@@ -213,8 +213,10 @@ src_prepare() {
}
src_configure() {
+ replace-flags "-O[3-9]" -O2 #839405
+
# We want floating-point arithmetic to be correct #933380
- replace-flags -Ofast -O3
+ replace-flags -Ofast -O2
append-flags -fno-fast-math -ffp-contract=off
local myconf
diff --git a/app-editors/emacs/emacs-31.0.9999.ebuild b/app-editors/emacs/emacs-31.0.9999.ebuild
index 37f94d0002ec..33390f3a6274 100644
--- a/app-editors/emacs/emacs-31.0.9999.ebuild
+++ b/app-editors/emacs/emacs-31.0.9999.ebuild
@@ -213,8 +213,10 @@ src_prepare() {
}
src_configure() {
+ replace-flags "-O[3-9]" -O2 #839405
+
# We want floating-point arithmetic to be correct #933380
- replace-flags -Ofast -O3
+ replace-flags -Ofast -O2
append-flags -fno-fast-math -ffp-contract=off
local myconf